Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lost Power abruptly and now explorer.exe hangs

27 Dec 2016   #1
BelGarion

Windows 7 x64
 
 
Lost Power abruptly and now explorer.exe hangs

So, the story so far. On Christmas eve got a brown out and the computer shut down abruptly. On a reboot the system seemed ok until I tried to access some files and explorer.exe started to hang, other programs started to hang as well, like Chrome, Firefox, etc. So I ran all sorts of tests, chkdsk /f on the C: drive, sfc /scannow , Western Digital's Data Lifeguard on the C: drive (It's a Western Digital drive), etc and no errors found. So I reinstalled Windows 7, after some drama with Windows Update (got that fixed thanks to you guys) I got the system to update finally, started to access the back up files and bam! explorer.exe froze solid for several minutes repeatedly. So once more into the breach this time using Seatools to test all four drives (1 boot, 3 data, 2 WD and 2 Seagate) to see if any of them were failing. Nothing, all four passed an extended test. Don't hear any of them clicking and when it's frozen the drive activity light only flickers on occasion like normal. The last time I had a drive puke the activity light went ballistic and the drive clicked. This time, none of that. So I don't know, this is a fresh install, I backed up and formatted the boot drive before installing Windows 7 again. Anyone might know what is causing explorer.exe to freak out and lock up my system for minutes at a time?


My System SpecsSystem Spec
.
27 Dec 2016   #2
Megahertz07

Windows 7 HP
 
 

Win updates can use a lot of resources.
Try to disable it on services - %windir%\system32\services.msc
My System SpecsSystem Spec
27 Dec 2016   #3
BelGarion

Windows 7 x64
 
 

It was before I reinstalled that it started to do this then after a reinstalling Windows 7 and there were no more important updates were left.
My System SpecsSystem Spec
.

27 Dec 2016   #4
GetTheClicker

Ohio
 
 

I have had that issue and man it's a nightmare... first it was a failing hard drive and then it was a failing PSU. Replaced them both and the hangs went away.

I too ran every single test and checked drive health and everything said my system was ok. No errors. When the hard drive fails your system will check for inconsistencies deleting corruptions and recovering orphaned files after only a few normal reboots. Things stop working, errors everywhere.

When the PSU was failing my system would hang, I'd get bsod about memory management, and random restarts where my boot order was screwed up. BOOTMGR MISSING. Please insert a bootable device. blah blah blah.
My System SpecsSystem Spec
28 Dec 2016   #5
BelGarion

Windows 7 x64
 
 

So the tests won't tell me which drive is failing? >.< Oy! Ok. So it's down to elimination rounds, power down, pull the data cable boot up, and access the files and see if it freezes, if so, repeat until the drive is found? Then for certainty swap the data cable and recheck. Right?
My System SpecsSystem Spec
28 Dec 2016   #6
GetTheClicker

Ohio
 
 

yeah disconnect drives one at a time. in this instance though it was my psu. i upgraded today from 850 to 1000 watts then plugged in my suspected failing drive and nothings gone wrong yet. i think i was just demanding too much power and the drives couldnt get enough.
My System SpecsSystem Spec
28 Dec 2016   #7
BelGarion

Windows 7 x64
 
 

I'll check that once I figure out where my DMM went. >.<
My System SpecsSystem Spec
29 Dec 2016   #8
BelGarion

Windows 7 x64
 
 

Ok, so, two things. In safe mode I don't have Explorer.exe lagging and when I unplug just the data cable of the 4 tb WD Black it doesn't lag neither. I'd expect it to be the drive except the safe mode thing. Thing is that the drive worked with out lagging the system for nearly a year. Now through 3 reinstalls of Windows 7 unless I am in safe mode or have the 4 tb unplugged explorer hangs to the point Windows offers to restart it. So I guess I will swap out the data cable just to be extra sure before I RMA the drive.
My System SpecsSystem Spec
30 Dec 2016   #9
BelGarion

Windows 7 x64
 
 

Update, it took a *lot* longer but while playing Minecraft (for the third time in nearly two days) it eventually locked up, Chrome couldn't connect to the web, and for the giggles I tried File Explorer and it was locked. So, again, for the giggles, I ran MemTest86 overnight, nearly two passes and no errors. So I am back to square one. Not drives, though just unplugging the data cable (not power, the drive is still powered up) on the 4tb hdd helps. So far I've reinstalled Win 7 about three times, downloaded all available drivers from the web, so drivers are all up to date. Thanks to you guys the updates from Microsoft are all installed. I've unplugged just the data cables (not power, just so it's pulling the same amount of power) from all four drives, reinstalled Windows 7 onto a lightly used data drive for when I pulled the current primary drive. Tested memory. Tested the power supply, well, the +12 and +5 volt drive rails, the DMM's probes are too big to back probe the 24 pin ATX connector, and that tested fine. So I am at a loss. What next? O.o
My System SpecsSystem Spec
30 Dec 2016   #10
GetTheClicker

Ohio
 
 

Have you checked your event viewer logs?
My System SpecsSystem Spec
Reply

 Lost Power abruptly and now explorer.exe hangs




Thread Tools




Similar help and support threads
Thread Forum
Lost Hyperlinks in Excel and a lost Internet Explorer 11
Dear Forum After constant stress with online software changing my PC settings (adobe one of many) I wanted to separate my main computer from the internet. This I tried. I turned off broadband. I then removed all my browsers, virus and malware protection and gave my hard-drive a bit of a...
General Discussion
Windows 7 hangs on Welcome screen after power outage (again)
I had posted all this several days ago, but for some reason, my thread vanished. Below is the compilation of two posts I made to the original thread recording the problem and what I've tried to do to resolve it. This is what I posted on September 18th: Having a tough time with my Windows 7...
Installation & Setup
Corrupt Os When Lost the Power?
Hi, I am using Windows 7 Home premium 32 bit since 3 years in my acer laptop . It was battery problem without power source can not stand by on battery . When it was Shut down power lost it can't load os, it shows empty then i need to install new os . Can i solve this problem and how please...
General Discussion
Lost Sound after Power Shortage
Hi everyone, I forgot my laptop in sleep mode yesterday, and since my battery is dead, someone from the house removed the AC Adapter and the PC turned off, when i turned it on this morning, there was no sound, there is no red cross on the sound icon in the notification bar, that one is fully...
Sound & Audio
System hangs on shut down after power loss during update installation
I had a power loss while installing a windows update about two months ago. Ever since then my system will hang either on logging off or shutting down. I have tried making a new user (No Help) it hangs in safe mode also. I also do not have a list of prior updates in control panel since this...
Windows Updates & Activation
Lost power on install!
Ok. I was installing windows 7 when I was almost complete and the power went out in the house from a storm. I tried reloading windows and it went back to install and said because it shutdown I had to restart to reinstall and it did and still gives me the same message. I did a upgrade and I dont...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App



Windows 7 Forums