Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: My PC runs between 10% and 20% CPU usage while idle

22 Jan 2017   #1
xblade

Win7Ultx64
 
 
My PC runs between 10% and 20% CPU usage while idle

Hello.

I have been having this issue for a bit of time now actually. My PC used to run between 0% and 5% idle, and it still does until it's finished loading everything from boot. It's almost as if there's some software running in the background or something that I can't see, because all programs shown in the Task Manager show 0% usage.

I recently cleaned out my PC and re-applied thermal paste to the CPU, and there was no change. I also did a ton of malware scans and such yesterday with Malwarebytes, RogueKiller, Eset online scanner, and Adware Clean. RogueKiller found a couple of PUP's and Adware Clean found a couple too, and they were removed. No change from that either.

So now I am stumped. As far as I know, it simply looks like nothing is making my CPU do that, but that can't be. There must be something going on, but I surely haven't a clue. Can anyone suggest something?


My System SpecsSystem Spec
.
22 Jan 2017   #2
xblade

Win7Ultx64
 
 

Sorry for the trouble. I seem to have found the culprit. After clicking "Show processes from all users" in Task Manager, I found a sneaky svchost.exe. I clicked it and clicked "Go to service" and among several processes, one of them was Windows Update Service, and I had a suspicion that it was the one doing it, so I disabled it, and lo and behold, my CPU usage is back to a normal 0% use.

Again, sorry for the trouble. Seems like there was no reason to open a thread afterall!
My System SpecsSystem Spec
22 Jan 2017   #3
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Probably missing these 2 or at least one of these updates that is causing svchost to run a mack
Refer to post #2 here
Windows Update will not update and I've tried multiple fixes
My System SpecsSystem Spec
.

22 Jan 2017   #4
xblade

Win7Ultx64
 
 

Oh! I was actually wondering about that, since Windows stopped updating in November. Interesting. Thanks a bunch! I got Windows Update up and running again. I was actually just planning to leave it off for good, ha!
My System SpecsSystem Spec
23 Jan 2017   #5
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
You still can turn off or switch the updates service to manual if you want too I do
My System SpecsSystem Spec
Reply

 My PC runs between 10% and 20% CPU usage while idle




Thread Tools




Similar help and support threads
Thread Forum
CPU runs at close to 100% all the time, regardless of usage
Imgur: The most awesome images on the Internet (image won't embed, or I don't know what i'm doing. Take your pick) You can see that i'm currently running malwarebytes to see if it can find anything, but i've already ran adaware and avast! to find any viruses or malware. My little laptop sits...
Performance & Maintenance
CPU Usage at 25% even when Idle?
Hi, I notice the last few days my PC has been running slow. When I looked at the Windows task Manager my CPU Performance seems to be at 20-30%...Mostly 25%...Even when Idle with no Applications running in the background. This isn't normal is it? In the past when I have looked at my CPU...
Performance & Maintenance
CPU usage in idle
Hello, I have question regarding CPU usage when my laptop has not have any application up and running (at least not by my request). I have changed some of the Start Up in msconfig. Everything that I don't really need on immediate Windows start up I have not selected. That is fine. But still...
Performance & Maintenance
60% Ram usage on idle.
i bought a new pc, and installed windows 7, and in the ram usage gadget thingy. it shows 60% ram usage. and the pc is idle, nothing is on, and i checked the proccesses and didnt see anything suspisios.. why is that? i got 2g ram DDRII
Performance & Maintenance
Win 7 RAM usage at 46% idle?
Hi My Win 7 Acer RAM (3GB) is running at 46% idle? This seems to be alot? Though it does not increase that much with windows open, even when I open WMP and play music it only goes up to 49-50%. I use the gadget on screen and double check it with task manager, they are the same. This is more...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App