Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Set the Registry Size Limit to "unlimited"

21 Mar 2011   #11

MS Windows 7 Home Premium 64-bit SP1

Dear miche,
QUOTE" In Microsoft Windows XP, the Registry Size Limit (RSL) functionality has been removed. Therefore, there are no longer any limits on the total amount of space that may be consumed by registry data (hives) in paged pool memory, and in disk space. However, there is a limit for the system hive which is a permanent part of the registry associated with a set of files that contains information related to the configuration of the computer on which the operating system is installed. configured items include applications,user preferences,devices and so on. So you have to remove unused settings from the system hive"(underlining is mine as also the bold type for emphasis)UNQUOTE

Source : Low on registry space

This quote comes from a MSFT in the above MS forum

The forum nicely dovetails onto an MS article which i found particularly interesting as it's crux seems to emphasize on reducing the entries from the system hive and the article is : The System hive memory limitation is improved in Windows Server 2003

I can understand the gravity of the situation as your second pc's life is in peril! I request you read the discussion in my first link and then the MS article and i also wish to tell you not to lose hope at any cost!

I have a gut feeling that there are too many a programs or enough number of big programs to give you this kind of pain!


My System SpecsSystem Spec
21 Mar 2011   #12

Windows 7 Home Premium 64-bit
Just stating my experience

I'm not a tech guru nor do I claim to know the internals of Windows registry. I'm only stating my experience so that someone else having the same issue might benefit from it.

I was having one hell of a time trying to install EndNote and Matlab and they both kept trying to install a prerequisite called 'Visual C++ 2005 Redistributable'. Installation would get to a certain point and then it would seem to freeze and then timeout in 4-5 minutes with the following error message:

ERROR:Error 1935.An error occurred during the installation of assembly 'Microsoft.VC80.ATL,type="win32",version="8.0.50727.42",publicKeyToken="1fc8b3b9a1e18e3b",processorA rchitecture="amd64"'. Please refer to Help and Support for more information. HRESULT: 0x800736B3.
[11/15/07,18:09:55] Microsoft Visual Studio 2005 Professional Edition - ENU: [2] ACTION FAILURE:Action ended

(This is not the exact error, I found a similar one for reference. The exact error had to do with the redistributable not the full version of Visual Studio)

I tried various tricks that have worked before in situations like this (including rebooting several times) but nothing worked. I had given up when I accidentally stumbled upon this one discussion on ESRI support forums where someone had mentioned changing the value of RegistrySizeLimit to ffffffff and rebooting.

I did exactly that and viola. All computers (six new Windows 7 installations) started working again. Windows updates were failing as well before and this fixed that problem too. Visual C++ 2005 redistributable installed just fine and so did 2008 redistributable.

Nothing else was changed in those computers. So draw your own conclusions. I'm just happy it worked and I can finally get paid
My System SpecsSystem Spec
21 Mar 2011   #13

MS Windows 7 Home Premium 64-bit SP1

Dear miche,
I know you are looking for solutions! Here we may be looking at some light at the end of a longish tunnel.

If you have read the article in the first link in my post, there was a mention of a UPHC i.e, User Profile Hive Clean. I am providing a link to an MS article from where you may download the small app. and put it to good use! Though it mentions XP, it works for win.7 too! Download details: User Profile Hive Cleanup Service

Best wishes,
My System SpecsSystem Spec

21 Mar 2011   #14

Windows 10 Pro. EFI boot partition, full EFI boot

You know bugs do creep into software - sometimes old code is accidentally reintroduced. Even in Windows

I looked around the Microsoft forums and there were quite a number of people whose installs of various software failed on Windows 7 and this registry hack appears to have fixed it. Perhaps there is n actual limit but a module still checks to see if there is enough room in the registry and assume a default if there is no value in the registry and fails with "not enough resources" or whatever. It could be a bad version of some library or the installation software.

Some of the threads have a common: hack registry, reboot, run sfc. sfc might be it, but from what I read, it sounded like the registry hack fixed it
My System SpecsSystem Spec
21 Mar 2011   #15


These threads are sometimes amusing.

Sidebar: "Lucy" was thought to be the oldest human, having lived about 3 million years ago. Later, human remains dated to about 4.5 million years ago were discovered. More recently, French and Kenyan scientists have discovered human remains that they believe are about 6 million years old. Note however that after about 6 MILLION years of evolution, religion and science, humans "discovered" air about 200 years ago. Brilliant!

Whether we discuss the position of electrons, cause and effect, or trace computer logic, version control and deployment methodologies, my own preference is generally not to speak in terms of absolutes such as "always" and "never". Besides, it makes for more colorful adjectives in the thought stream.
My System SpecsSystem Spec
23 Mar 2011   #16

Windows: 7-Vista, Linux: Ubuntu-Sabayon

Wow guys...good to have you back ...I had honestly completely forgotten about it! (1 year and 1/2! that issue still around?!)

Thanks Sreedhav for your concern and I actually read those articles though I didn't quite catch the point of the matter...are you saying that "I (my pc) am in danger?"...

After that fix I never had any trouble and my VAIO ran smoothly since then!

I actually just purchased a new one...another VAIO, (poor guy, the old one is still there but it is not taking any other sw got a bit slow !) and now I'm curious to see if it behaves the same way.

As soon as I'm done with the installation of all my sw I will let you know about it.
Thanks again.

My System SpecsSystem Spec
20 Apr 2011   #17

Windows: 7-Vista, Linux: Ubuntu-Sabayon

Hey there...I've been using my new system for quite a while and everything is fine.
No need for the hack this time

Thanks again.

My System SpecsSystem Spec
03 Jul 2011   #18

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by miche View Post

Key: RegistrySizeLimit
Value: 0xffffff (4294967295)


As a Administrator open a Command Prompt and run "SFC /SCANNOW". The command should complete successfully and if any errors were found, they should be corrected.
i registered on this web forum just to say - miche you are my HERO !! your trick absolutelly works !!

Yes its 7/2011 and the issue is still around !
I have fresh Windows 7 Ultimate 64-bit SP1 with all updates on a brand new Intel i7-2600K and Autodesk Maya 2010 was throwing an error during installation:

Product: Maya 2010 (64-bit) -- Error 1935.An error occurred during the installation of assembly 'Microsoft.VC90.OpenMP,type="win32", processorArchitecture="amd64", publicKeyToken="1fc8b3b9a1e18e3b", version="9.0.30729.1"'. Please refer to Help and Support for more information. HRESULT: 0x8007041D. assembly interface: IAssemblyCacheItem, function: Commit, component: {6A4999AC-73A7-3777-9FBB-FC12EB68FCE8}

after googling the Error 1935 i found that tons of Autodesk users have the same problem with other products from Autodesk (AutoCAD, Inventor, Maya, etc.) with no solution anywhere...

this little trick of yours did the job - now the installation completed 100%

btw. i restarted billion times before applying this registry hack and NO restarting doesnt fix this problem...

cheers miche
My System SpecsSystem Spec
04 Aug 2011   #19

Windows 7 Premium 32 bit
The Registry edit method did it for me!

Thanks to everyone (maybe not logicearth whom seems to owe an apology to the forum!) for putting up and discussing this fix for the empty "Turn Windows features on or off" window problem.
For several months I had been trying all the other "standard" methods suggested on other sites including Windows System File Checker (e.g. SFC /SCANNOW : Run in Command Prompt at Boot)
but nothing worked. Sfc could not be run while logged on to the computer and didn't find any problems when run offline.
I would come back to the problem every few weeks and try again. I posted on other forums (Microsoft) to no avail - very frustrating.
The reg edit fixed the problem.

The only thing I can add is that when I pasted 0xffffff into the key value it was immediately altered to something else (41ffffff) that was not correct (was not decimal 4294967295) after clicking OK. When I just pasted in ffffffff it worked.
Could be a trap for the unwary.

I can now install IIS!
My System SpecsSystem Spec
10 Aug 2011   #20

Windows: 7-Vista, Linux: Ubuntu-Sabayon

MAN!..this is an endless one, innit?

..well mizpulyn, maybe the guy from that post I started this threat with should be your hero
I just looked for the solution on the web and quoted what I thought it was!

I'm glad you guys found a way out like me!
Thanks to everyone for your help!

My System SpecsSystem Spec

 Set the Registry Size Limit to "unlimited"

Thread Tools

Similar help and support threads
Thread Forum
Save/Open Dialog-boxes, remembering "SIZE" & "POSITION"
I have some programs I would like to have there save/open dialog boxes remember - SIZE - POSITION Namely: Firefox, because I download program updates and export/HTML my FF bookmarks for a use in Firefox as a single scrolling list for quick update checks... frequently... it seems to...
General Discussion
"Windows Backup size" not reflecting actual backup file size
I'm having a problem with a system image (C: drive and System Reserved drive, that I made with a scheduled Windows Backup) and its size. I have a D: drive where I store it. First of all, I noticed this in D: drive properties: ...
Backup and Restore
How to file type limit content search? Ex. IN *.htm* find word "étant"
RE: How to Make Windows 7 Search File Contents: 12 Steps OK I have enable Win7 content search, but when I open Explorer to a desired directory and do CTRL+F I see the normal search window. How do I search for instance within all htm(l) extended file, for all the files containing the word...
General Discussion
How to Limit "Favorites" tab to Only Display Internet Explorer Folders
I apologise for in advance for not being able to ask the question clearly, but if I could do THAT I could probably figure this out on my own. Win7 is different in that the "Favorites" drop down menu has EVERYTHING on my entire computer, and I have to manually poke arond and figure out where the...
General Discussion
What's the diffrent between "size" and "size on Disk"?
Hello! When i check folders properties i can see this "Size" and "Size on Disk". Both fields are show same amount so what is the different between that?:cry:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:00.
Twitter Facebook Google+