Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Clock Wrong After Resume from Suspend

12 May 2017   #1
clarknova

Windows 7 Professional x64
 
 
Clock Wrong After Resume from Suspend

Dell Latitude
Windows 7 SP1 x64

I worked on a couple of Dell Latitude laptops for a client. I forget the exact model, but they are identical hardware to each other and shipped with Windows 7 32-bit. I upgraded them to 8 GB RAM and replaced the hdd with an SSD and did a clean (non-Dell) install of Windows 7 x64. Or more specifically, I did the clean Windows install on a single of these, ran all the updates and drivers, had the client install their software, then cloned one SSD to the other so that both are now running identical hardware and software.

All is well, except the client has complained that both laptops now have the same problem since I did the work, which is that after resuming from sleep (I disabled hibernate), Windows shows the wrong time. It will display the time that the laptop went to sleep, and continue keeping time, having lost the time that passed while asleep.

I've done some googling on this, and the recommendation is usually to replace the CMOS battery, but I'm not sure that fix would apply here because we are not hibernating the system, only putting it to sleep. Plus, this issue reportedly affects two laptops after a fresh install, where the issue allegedly did not exist right before the upgrade was effected.

If we force an ntp update, then the time gets corrected, but I've never had to do this on another system. Should not Windows refer to either the hardware clock or internet time shortly after resuming from sleep?

What is the recommended action here? I read of a registry entry in Vista that will force ntp updates at a prescribed interval, but I would prefer to find the root of the problem.


My System SpecsSystem Spec
.
12 May 2017   #2
johnhoh

Win7 pro x64
 
 

did a quick search and someone solved this on their system by updating drivers.
My System SpecsSystem Spec
14 May 2017   #3
Megahertz07

Windows 7 HP 64
 
 

The clock you see is a reading from the hardware clock that never stops, even when computer is off. If it's frozen after a wake up, it's a software issue.
On a CMD window, run sfc /scannow.
My System SpecsSystem Spec
.

Reply

 Clock Wrong After Resume from Suspend




Thread Tools




Similar help and support threads
Thread Forum
BSODs while AFK (perhaps related to suspend/resume/hibernation?)
Hey. I don't have much more to go on with this. I've been coming back to my laptop recently after being away for five minutes to find its had a BSOD and restarted. I suspect that its failing to hibernate properly, when it goes into standby. Tried to install the debugging tools to have a look...
BSOD Help and Support
BitLocker Drive Encryption - Suspend or Resume Protection on Windows 7 Drive
How to Suspend or Resume BitLocker Protection on Windows 7 Drive This will show you how to temporarily suspend (unlock) BitLocker drive encryption protection on a Windows 7 or other operating system drive or partition, and to resume (lock) protection when needed.Suspend protection is...
Tutorials
Sluggish Resume From Suspend Then Network Goes Down
I find that after leaving my box in suspend overnight, it is very sluggish to resume. But after being online for the first 10 mins the network goes down & I have to run network diagnostics to fix. The network card gets reset each time with a host not found fault. I am using a Edimax Wireless...
Performance & Maintenance
Sleep/Suspend Results in, no Resume
Hello, I am having issues with the windows sleep/suspend option. When i put the computer (desktop) into sleep/suspend state (HDD light is fully emitting), it powers down as it should saving power. But when i turn the PC back on using the power button, the computer fails to resume, at this...
General Discussion
Wrong clock speed!
Hi, I have a Q8400 @3.3GHz, but in My computer > Properties It only says 2.66, This was working some time ago, but now it wont, whats the problem? can i change some registry files to make it correct? please help!!
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App