Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fresh Windows 7 install large performance loss

14 Jul 2017   #21
longtimepie

windows 7 ultimate 64 bit
 
 

The keyboard and mouse are fine now but i am still getting frame drops in certain games and whilst using certain programs. overwatch or VLC media player for example.

When before they both ran beauitfully


My System SpecsSystem Spec
.
14 Jul 2017   #22
Megahertz07

Windows 7 HP 64
 
 

Look for a graphics card driver update.
My System SpecsSystem Spec
16 Jul 2017   #23
longtimepie

windows 7 ultimate 64 bit
 
 

Already done and nothing seems to of changed unfortunatley =/
anything else i cna check for?
My System SpecsSystem Spec
.

16 Jul 2017   #24
Megahertz07

Windows 7 HP 64
 
 

Did you open device manager to see if there is no yellow alerts?
My System SpecsSystem Spec
16 Jul 2017   #25
longtimepie

windows 7 ultimate 64 bit
 
 



Attached Images
Fresh Windows 7 install large performance loss-yellow.png 
My System SpecsSystem Spec
16 Jul 2017   #26
longtimepie

windows 7 ultimate 64 bit
 
 

apart from that I have tried many a thing to fix the issues with overwatch but the only fix I have found is to run it in fullscreen. which was never needed on windows 10.

Is this maybe just an os compatibility issue or something else?
My System SpecsSystem Spec
17 Jul 2017   #27
Megahertz07

Windows 7 HP 64
 
 

You have 3 missing drivers.
Open device manager, right click on one - properties - Details tab - Right click on fist string - copy
Paste the string here. Is something like PCI\VEN_168C&DEV_001A&SUBSYS_2052168C&REV_01
Do it for the 3 drivers.
My System SpecsSystem Spec
17 Jul 2017   #28
longtimepie

windows 7 ultimate 64 bit
 
 

unfortunately I have tried to update them via a driver updater tool that I paid for and the only search that shows anything for them is just similar tools for auto driver installations which Is rather irritating.

I havent been able to find any direct (trustworthy) websites hosting the downloads.

Any ideas?
My System SpecsSystem Spec
17 Jul 2017   #29
Megahertz07

Windows 7 HP 64
 
 

Did you try to install the drivers using the disk that came with your MB?
You didn't do what I suggested you on my last post.
My System SpecsSystem Spec
18 Jul 2017   #30
longtimepie

windows 7 ultimate 64 bit
 
 

Sorry I didn't see that part of your post but the Mobo install disc is long gone now.

PCI\VEN_8086&DEV_2F9C&SUBSYS_2F9C8086&REV_02
PCI\VEN_14E4&DEV_43A0&SUBSYS_86591043&REV_03
IUSB3\ROOT_HUB30&VID_8086&PID_8D31&REV_0005&SID_86001043
My System SpecsSystem Spec
Reply

 Fresh Windows 7 install large performance loss




Thread Tools




Similar help and support threads
Thread Forum
Downlaoding/Updating Games Causes Performance Loss
Hi, I made a new PC a while back and the one thing I do notice is when I DL a game or update it from an Launch Pad or similar Game launching program. My CPU usage is tops 15% maybe 25% but my desktop reaction is slowed I have to wait for folders or programs to open. It makes no sense to me why...
Performance & Maintenance
Game performance loss after waking from sleep
Literally that. After waking it up from sleep, my Windows 7 rig seems to lose a lot of framerate in games. I have no idea what could be causing that, any ideas? System: Windows 7 Ultimate x64 4970K @ 4.0GHz 32GB Corsair Vengeance @ 1600Mhz Z97X Gaming 3 mobo 780GTX
Gaming
Fresh Install - Large Windows Update Crash
Hello all, Installed a new motherboard and everything went well with that untill I start updating windows. Windows downlaods all the updates then does a restart and on the restart I get the blue screen of death. Please help. Many Thanks in advance.
BSOD Help and Support
Huge performance loss
My system is the following 1x E-VGA 680i SLI A1 1x Quad Core Q6600 w/ G0 Stepping 1x 2x2GB Dominators PC8500 with fan 1x XFI Titanium PCI-E 1x E-VGA GTX-260 216 896MB 1x Memorex External DVD Burner 1x Seagate barracuda 7200.8 500GB
Performance & Maintenance
Win7 sudden loss of performance
after installing AMD overdrive (and accidentally hitting apply on stock settings) and uninstalling it. It gives me the infamous BSOD and after that it's like.. totally killed the speed/power of my computer. I attemtped to re-install then uninstall, did nothing but give me BSOD a couple more times....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App