Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Many Fonts Not Working in Windows 7

30 Aug 2017   #1
wolfreich

Windows 7 Ultimate x64
 
 
Many Fonts Not Working in Windows 7

I used to have Windows 7 Ultimate.

I upgraded to Windows 10.

Destroyed my computer (despite saying it could handle it)

Deleted my HD, and PURCHASED a Windows 7 install (because ASUS nor Windows provides them)

Back to normal now.

Except fonts.

The help forums said to install all the language packs.

I did that.

But still nothing.

How do I get all my fonts to work?

They all pop up as square blocks...

Thank you!




My System SpecsSystem Spec
.
30 Aug 2017   #2
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

Go to Control Panel / Appearance and Personalization / Fonts / Font Settings. Click Restore default font settings.
My System SpecsSystem Spec
30 Aug 2017   #3
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi wolfreich,
sounds like the media was corrupt

Why purchase another ?? if the comp originally came with or you bought a retail/System builder version
the key is STILL valid

Installing additional language packs will not repair the fonts.

couple of options
run KB947821, (SURT a system repair tool)

or i can provide a download link for an Iso, this will be a 2 part operation.

Roy
My System SpecsSystem Spec
.

30 Aug 2017   #4
wolfreich

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by mrjimphelps View Post
Go to Control Panel / Appearance and Personalization / Fonts / Font Settings. Click Restore default font settings.
Done.

Now what?
My System SpecsSystem Spec
30 Aug 2017   #5
wolfreich

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi wolfreich,
sounds like the media was corrupt

Why purchase another ?? if the comp originally came with or you bought a retail/System builder version
the key is STILL valid

Installing additional language packs will not repair the fonts.

couple of options
run KB947821, (SURT a system repair tool)

or i can provide a download link for an Iso, this will be a 2 part operation.

Roy
"Update is not Applicable to Your Computer."
My System SpecsSystem Spec
30 Aug 2017   #6
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

Quote   Quote: Originally Posted by mrjimphelps View Post
Go to Control Panel / Appearance and Personalization / Fonts / Font Settings. Click Restore default font settings.
Quote   Quote: Originally Posted by wolfreich View Post
Done.

Now what?
Reboot.

If that doesn't work, then I don't know.
My System SpecsSystem Spec
30 Aug 2017   #7
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi wolfreich,

try this link for Surt - 64bit
Download System Update Readiness Tool for Windows 7 for x64-based Systems (KB947821) [October 2014] from Official Microsoft Download Center

SURT works on both 32/64 bit but is OS type specific.

Roy
My System SpecsSystem Spec
30 Aug 2017   #8
wolfreich

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi wolfreich,

try this link for Surt - 64bit
Download System Update Readiness Tool for Windows 7 for x64-based Systems (KB947821) [October 2014] from Official Microsoft Download Center

SURT works on both 32/64 bit but is OS type specific.

Roy
That one worked!

But it did not fix anything

BTW-My product key still worked. But I needed to buy a Windows disc to install it.

It is strange. I never had an issue with fonts. Ever. You think it would be an easy fix.
My System SpecsSystem Spec
31 Aug 2017   #9
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi wolfreich,

can you post the log
it can be found here
C >> Windows >> Logs >> CBS - SURT.

run this tool please, copy/paste the output

http://go.microsoft.com/fwlink/?LinkID=52012

I suspect the install media was corrupt

Roy
My System SpecsSystem Spec
01 Sep 2017   #10
wolfreich

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi wolfreich,

can you post the log
it can be found here
C >> Windows >> Logs >> CBS - SURT.

run this tool please, copy/paste the output

http://go.microsoft.com/fwlink/?LinkID=52012

I suspect the install media was corrupt

Roy

Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-Q6MMK-KYK6X-VKM6G
Windows Product Key Hash: 289NoAWl2ZoVfuieux/315WkDIc=
Windows Product ID: 00426-OEM-8992662-00173
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010100.1.0.001
ID: {ADA73E35-7577-447B-B094-AEFD9BADC014}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Ultimate
Architecture: 0x00000009
Build lab: 7601.win7sp1_ldr.170707-0600
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 100 Genuine
Microsoft Office Word 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-800a_E2AD56EA-766-191_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{ADA73E35-7577-447B-B094-AEFD9BADC014}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.001</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-VKM6G</PKey><PID>00426-OEM-8992662-00173</PID><PIDType>2</PIDType><SID>S-1-5-21-3029281650-1430048941-1997643684</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc.</Manufacturer><Model>K42F</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>502</Version><SMBIOSVersion major="2" minor="6"/><Date>20110729000000.000000+000</Date></BIOS><HWID>31073C07018400FC</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-001B-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Word 2007</Name><Ver>12</Ver><Val>BCD72299F752D86</Val><Hash>068lO0ay6rs9LAvgHDhjVT63wL4=</Hash><Pid>89407-707-6552566-63579</Pid><PidType>14</PidType></Product></Products><Applications><App Id="1B" Version="12" Result="100"/></Applications></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->


Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 8:5:2017 02:21
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: KgAAAAEAAQABAAEAAAABAAAAAQABAAEAln2khfZ7ACkWGKK8jCmoBlxd

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
APIC _ASUS_ _ASUS_
FACP _ASUS_ _ASUS_
HPET _ASUS_ _ASUS_
MCFG _ASUS_ _ASUS_
ECDT _ASUS_ _ASUS_
SLIC _ASUS_ Notebook
SSDT PmRef CpuPm




THANKS!
My System SpecsSystem Spec
Reply

 Many Fonts Not Working in Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Title fonts in all web browsers viewing as open face fonts error
This started around the 1st of September. It seems like the title/headline fonts across all browsers, Firefox, IE and Chrome, has changed to an open face style font. I'm note sure what font it is. There was a windows update KB 2993651 that corresponded to my issue. I did a system restore to a...
Browsers & Mail
Control Panel -> Fonts Folder: Some Fonts Display Strangely
I am running Win 7 Pro 64-bit with 24GB memory and lots of disk with a Dual Core i7 930. When I go to Control Panel->All Control Panel Items->Fonts I see file icons, most of which have examples of the fonts they represent. The hidden fonts are grayed out. But I have a significant number of fonts...
General Discussion
Web Browser fonts changed after installing new fonts to computer
Recently I installed two fonts onto computer for Typography, and upon doing so the fonts changed on Google Chrome and Firefox to this bold font. It appears to be the default font as before, just in bold now. I've tried checking the browsers font settings, and they're at the settings they were...
Browsers & Mail
Microsoft Updates Core System Fonts To Fix Blurred Fonts Issues
Source A Guy
Browsers & Mail
Extracting fonts to c:/windows/fonts - its not there?
ehh I got it, I had to save it to desk top & drag & drop which doesnt make any sense.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:40.
Twitter Facebook Google+