Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Random lag spikes after a while (GPU 2 usage goes up)

08 Mar 2018   #1
kakas123455

Windows 7 Professional x64
 
 
Random lag spikes after a while (GPU 2 usage goes up)

Hello.First of all,excuse me for my bad English in some bits and you should know I am not an expert in this kind of stuff. So,recently,I am starting to get some random lag spikes after a while of playing games (specifically,League of Legends and CS GO). Whenever the lag spikes happen,I check MSI afterburner and I see the GPU 2 usage going up (from near 27 to 80-90something). I am not really sure but my second GPU is Intel HD family Graphics,I dont know if it helps. Also,I haven't experienced this before. Some things to note:
I have tried checking for malware and setting up a fan below my laptop to prevent overheating. Model is Dell Inspiron 3537. I would really appreciate some help as its starting to become exhausting. If you need any further information,feel free to ask me,I will try to inform with whatever you need.


My System SpecsSystem Spec
.
08 Mar 2018   #2
Megahertz07

Windows 7 HP 64
 
 

Welcome to the Forum.

Do you have a second monitor?
Does your Laptop have a discrete GPU or it uses the internal graphics?

Games makes the GPU to work hard. Do you have a hardware monitor to see if the max temperatures are below 85șC?
My System SpecsSystem Spec
09 Mar 2018   #3
kakas123455

Windows 7 Professional x64
 
 

Hello again. Ok so: 1) I don't have a second monitor 2)I went to dxdiag and I saw that my Intel HD Family Graphics card is internal,as for the AMD Radeon HD 8670M I will have to guess that its discrete. I think it uses the internal one. 3)I have SpeedFan and MSI but MSI refuses to co-operate so I will watch the Speed Fan's measures to see the temperature.I will inform you about it as soon as I get a lag spike.
My System SpecsSystem Spec
.

09 Mar 2018   #4
kakas123455

Windows 7 Professional x64
 
 

Actually the problem seems to have been fixed.In power settings I set everything to High Performance and now its fine although it still has a bit of staggering.Thank you for trying to help.
My System SpecsSystem Spec
Reply

 Random lag spikes after a while (GPU 2 usage goes up)




Thread Tools




Similar help and support threads
Thread Forum
CPU usage spikes
Hey everyone! :) I have been having CPU usage problems for some time now. Recently i bought a new cooler for my CPU to resolve that problem. Before i had 70C while gaming while now i have 35C tops, but still CPU usage goes up and down fast. I downloaded Procexp to see what is going on and i...
Performance & Maintenance
dxm.exe causing random spikes of high CPU usage.
Hi, recently I've been experiencing random spikes of lag in my laptop. I use AllCPUMeter gadget to monitor my systems. The symptom was that CPU usage would increase highly without any major programs being runned. This had happened while my laptop was idle and after a few seconds of hang, my Aero...
Performance & Maintenance
Firefox CPU Usage Spikes
I recently installed Firefox 3.6.6, and ever since I have been getting huge CPU usage spikes -- up to nearly 50% on one core. These spikes occur about once every ten seconds. When the spike occurs, any action in my browser is delayed a second or two, resulting in annoying lags during scrolling and...
Browsers & Mail
Physical Ram Usage Spikes to 99%
On occasion my physical memory usage will quickly rise form between 1 to 2 gigs of memory usage to over four until it reaches 98-99% percent of memory usage. I am running on 5 gigs of ram. This problem has even occurred while the computer was essentially idle. When this happens the computer loses...
Performance & Maintenance
Wierd CPU usage spikes
Hello, I upgraded to windows 7 this past Friday, Dec 4. I went with doing the upgrade from vista 64bit over doing a fresh install to prevent re-installing programs and just laziness. The past 2 days or so I have been noticing some programs running slow, one such is Ventrilo. I did the...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App