Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Why is AIDA64 giving me wrong system specs for my RAM?

08 Jan 2019   #1
Super Starman

Windows 7 Ultimate x64
Why is AIDA64 giving me wrong system specs for my RAM?

AIDA64 is an extremely powerful diagnostic, repair and sensor program that I bought a used CD for the non-free version at flee market prices. It strangely did not know what my Motherboard was, so it asked me to scan and send them my desktop's details...not something I am a fan of, but that mobo isn't some obscure one, if you check my profile, it's an ASUS M5A97 LE R2.0 (AMD3+ socket). But that's not the biggest question right now.

At boot, and Speccy tell me the truth, I have 16gb of ram at 1866mhz...Speccy describes them just fine, Corsair Vengeance 4x4gb sticks at 933mhz each, the dual channel making them 1866mhz together. It also finds the correct settings that are right on the sticks themselves, 9-10-9-27, which I do have to specify myself in the BIOS because, it's not an Intel, there's no XMP(sic?). I also have to put HT from 1 to 2, then the desktop boots up with 4gb of ram at 1866mhz.

AIDA64 sees them as 1333mhz sticks with different timers? What's the deal here? My CPU is a AMD-FX8350 Octocore Black Edition (unlocked for overclocking), not long after I bought it, I got rid of the noisy, crappy stock cpu stock fan that comes with for an EVO Turbo Cooling Tower that's so big, a couple of inches more and it would not fit my medium sized tower...I intend to replace it..I've been carrying it since december 2005 since it was such a great tower and I only do my own builts, it's cheaper and better to do so, especially with AMD processors, an equivalent i7 would have cost me double in price, plus I don't trust Intel, but that's entirely another matter.

I'm puzzled by the info it's giving me about my RAM more so...

DIMM1: Corsair CMZ8GX3M2A1866C9    4 Go DDR3-1333 DDR3 SDRAM  (9-9-9-24 @ 666 MHz)  (8-8-8-22 @ 592 MHz)  (7-7-7-19 @ 518 MHz)  (6-6-6-16 @ 444 MHz)
DIMM2: Corsair CMZ8GX3M2A1866C9    4 Go DDR3-1333 DDR3 SDRAM  (9-9-9-24 @ 666 MHz)  (8-8-8-22 @ 592 MHz)  (7-7-7-19 @ 518 MHz)  (6-6-6-16 @ 444 MHz)
DIMM3: Corsair CMZ8GX3M2A1866C9    4 Go DDR3-1333 DDR3 SDRAM  (7-7-7-20 @ 533 MHz)  (6-6-6-17 @ 457 MHz)
DIMM4: Corsair CMZ8GX3M2A1866C9    4 Go DDR3-1333 DDR3 SDRAM  (7-7-7-20 @ 533 MHz)  (6-6-6-17 @ 457 MHz)
Is me using AMD Overdrive to overclock the cpu to 4.2ghz resulting in diverting power from the motherboard away from the memory to the processor? I know I could overclock it much more with the as-good-as-it-gets-without-being-water-cooling EVO Turbo Cooling Tower to 4.6ghz if I wanted. Maybe I should drop AMD Overdrive (disable it) and go through AI Suite's Auto-Tuning, which I cannot use when Overdrive is on? It has 2 settings, "Fast" and "Extreme", but the process demands going through 2 or 3 reboots where it sets everything automatically and should be trusted over Overdrive, apparently, since it knows how to set everything up perfectly?

I dual-boot, I have a Linux Mint install on another drive and I never ever experience crashes there, I bought that AIDA64 program because from time to time I will get BSOD's, never with the same message really. Always happens when I am NOT using that desktop, I'll wake up and the Mint login screen since the grub menu puts Mint at the top of the boot menu and after 30 seconds will auto-select whatever is there first.

So, nothing critical, and I tried my sticks on a couple other desktops and they worked fine from the get-go on an Intel machine, same for a more recent AMD motherboard a friend has....but I need some help, definitely. I hear AMD Overdrive is bad news and that's why they don't have it for download since a long time on AMD's site.

I would appreciate an explanation/suggestions, anything...only one thing, do not tell me to reset my BIOS options to default, that will definitely have the desktop boot up showing I have 1333mhz ram, which is not the case, unfortunately, I have to set the timers...I think it's due to the motherboard, it is compatible with what was the strongest AMD processors for a good while until the FX9xxx series showed up, I could have bought that 3 years ago when I bought this rig piece by piece, but it was already 279 CAD + taxes (so, 330 bucks) for the FX-8350 Black Edition, so I bought the motherboard for a 100 dollars, evening it out.

Thanks for your attention! Happy new year to everyone on here, although it is the final year for win7, even x64 Ultimate is my understanding, I don't know what I'll do when the last updates in April happen..I despise Win 8/8.1 and Win10, well, back then I sure made it so that the free win10 update never happened, I'm already shunning a lot of surveillance and win10 is basically you bringing a trojan horse in your house with all that telemetry I hear is very difficult to get rid of, if at all.

p.s. I can provide screengrabs on demand.

My System SpecsSystem Spec
08 Jan 2019   #2
wither 2

Windows 7 Pro SP1 64 bit

Hi Super Starman-

Seems this is a question best answered by the vendor-

Contact with FinalWire | AIDA64

If you contact them, let us know what they have to say.
My System SpecsSystem Spec
09 Jan 2019   #3

Windows 7 HP 64

My System SpecsSystem Spec

09 Jan 2019   #4

Win7 pro x64

no idea if this is what is happening but some programs will interrogate the memory dimms directly to find its info, and others will interrogate windows. It doesn't matter what the dimm default is or even what the bios says, what you care about is what windows is able to use. I recommend using the cmd command Wmic Memorychip to be sure what something is running at. Here are the wmic argument options.

Useful WMIC Queries | Ask the Performance Team Blog
My System SpecsSystem Spec
09 Jan 2019   #5

Windows 7 Pro 64 bit

You may have an old version of AIDA64.

Obtaining detailed hardware information can be tricky and often requires that the application have knowledge of your hardware. An old version may not have it. And interrogating hardware is by no means foolproof.
My System SpecsSystem Spec

 Why is AIDA64 giving me wrong system specs for my RAM?

Thread Tools

Similar help and support threads
Thread Forum
Windows Update giving wrong CPU
Hi, Earlier this year I found that someone had a fix for the CPU check in Windows Update. I have had a PC crash and cannot find what the fix was, does anyone know what it was and wherte I can get it? Thanks, Gerald
Windows Updates & Activation
System Specs for Win 7
:cool: Any improvement suggestions?
General Discussion
System Specs
Hello, I'm a newbie and need help. I'm not sure my system specs are complete-wasn't sure what parts and pieces are in my laptop: HP dv9700 Pavilion, Centrino duo CPU. I did go to the system information and copied that. My OS is Win 7 home premium, 32 bit, upgraded from Vista home. So far, no...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:48.
Twitter Facebook