Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System getting slow and lagging on some things

3 Weeks Ago   #1
debodun

Windows 7 Ultimate x64
 
 
System getting slow and lagging on some things

For about a month now, my system seem to have a lot of lag, slow boot, slow shutdown, desktop icons slow to appear on desktop after boot and slow to open programs from desktop icons, some Internet sites do not open quickly.

Things I have tried on my own that didn't help: refresh desktop, defrag, disk cleanup (got stuck on Windows Update Cleanup), MBAM scan (didn't find anything suspicious), scandisk, chkdsk.


Here is a Speccy report on the hardware:




Attached Images
System getting slow and lagging on some things-speccy.jpg 
My System SpecsSystem Spec
.
3 Weeks Ago   #2
samuria

win 8 32 bit
 
 

Have you checked what runs at start? Getting a new ssd drive about 50 for 512 gigs would make a big difference the specs of the pc are low so it wont be a speed machine
My System SpecsSystem Spec
3 Weeks Ago   #3
debodun

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by samuria View Post
Have you checked what runs at start?

Here is the startup menu:


Attached Images
System getting slow and lagging on some things-startup.jpg 
My System SpecsSystem Spec
.

3 Weeks Ago   #4
Megahertz07

Windows 7 HP 64
 
 

You're probably using / running virtual memory.
Open Speccy - Ram - Physical Memory. How much available memory you have?

First thing I see on your specs is that you are running Win 7 64bits with only 3G of memory and internal graphics.
With 4G or lower you should have Win 7 32bits. It will be more free memory for the programs.

Try do run a Clean Boot. Open M$Config, go to the services tab, hide all M$ services and disable all others. On the StartUp, disable all.
Restart.
My System SpecsSystem Spec
3 Weeks Ago   #5
br4

Windows 7 Ultimate x64
 
 

Did you recently start using Microsoft Security Essentials for anti-virus? When I switched from Avast Free to MSE, my system did some things slower, including the desktop icons refresh. I switched back to AF and all is much better.
My System SpecsSystem Spec
Reply

 System getting slow and lagging on some things




Thread Tools




Similar help and support threads
Thread Forum
PC Slow/Lagging
Hello, I am seeking help regarding the speed of my PC lately. It has been lagging very much these days, much more than it used to. It takes forever to load up the proper window when I simply right click on something for example. I am assuming this is because of cookies / something of that sort that...
Performance & Maintenance
Windows 7 lagging badly and very slow
Hi guys. I'm new to this forum and to Win 7. Finally updated my 6 year old Acer Aspire laptop (AMD turon 64 x 2, 2 Gig ram, XP Media Centre) with a HP DV7-5005TX (I7-2720 2.2g, 8 gig DDR3, ATI Radeon HD6570 Graphics with 1 gig Ram & 2TB HD). It was preloaded with Windows 7 Home Premium 64bit...
Performance & Maintenance
iTunes Visualizer lagging & terribly slow?
Haven't had any issues with iTunes visualizer running bad & now it's reallllly slow & lagging. I have 8g of ram & no other programs running, any idea what it could be? My computer was running really slow in general the other day too. What can I check? Computer specs are in my sig
Software
Game lagging and slow performance of pc.Suggestion about a gaming rig?
hello everyone, nowadays my pc are running slow and my game are lagging. When i run some of my game, my cpu usage become 100 percent and cause my game to lag. But this is not because of the graphic settings i have on the game. I have already try to defrag and do some checking like scanning with...
Gaming
upgraded to win 7 - now unusably slow and lagging
I'm a noob with this so please understand some ignorance on my end. Thanks in advance for any help! I recently upgraded my Windows Vista home premium (64 bit) to Windows 7 home premium (64bit). Now everything takes forever to load (run) if it even loads at all. The CPU itself is only running...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:10.
Twitter Facebook