Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DISM cannot mount wim image (access denied) - tried everything!

29 Mar 2020   #1
10Fan

Windows 10 x64
 
 
DISM cannot mount wim image (access denied) - tried everything!

I was mounting and unmounting a WIM image no problem, I updated it to include USB3 and NVMe support, then installed that from USB onto a new system. Everything ran smooth.

Now in my new system using all the exact same files (including DISM) on the same OS, it will not mount the image (error 5: access denied).

It stalls at 99%...



The error in the log file is 0x80070005

What I have tried:

- Making sure the install.wim is not read only (it's not).
- Taking ownership of the mount folder, and my DISM files, and the Windows source that contains the WIM.
- Making sure the registry key is clear (HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images)
- Checking I'm not using McAfee (I'm not).
- Making sure I'm logged in as an administrator (I am).
- Rebooting
- Taking deep breaths... getting angry lol...

Now what?! I have no idea why it's not mounting the image.

This is the same install.wim from the ISO I just installed Windows from, that I was working on perfectly fine, using all the same files I am using now. The computer user name is the same too.

All the answers I can find say disable McAfee (I'm not using it at all) and make sure install.wim is not read only (it's not).

I ran this then rebooted but it's not fixed it...

Code:
dism.exe /Cleanup-Wim
DISM\dism.exe /Unmount-wim /MountDir:D:\mount /Discard
Echo Y | REG DELETE "HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images"
rd /s /q D:\mount
Something else is at play.

I am mounting on a NVMe drive, maybe that's it, I will post back if mounting to my standard SATA HDD doesn't work... if you never see me in this thread again - it worked lol.

Nope - it just says the exact same thing again, after taking 5 times longer to mount.

OK I will put my Windows source files and the mount folder both on my SATA HDD, after running the above commands again to clear it all up. I'll come back whining again if that doesn't work...

EDIT: That's not worked.

I cannot mount the WIM on a NVMe drive or a standard SATA HDD. The same error always happens "access denied".

EDIT: The 7updater package can mount and unmount fine, but I can't. After using 7updater, I can mount and unmount successfully once, then any further attempts fail with "Access denied".

I just wish that 7updater package had 2 batch files (like it has one to optimize the WIM and one to create an ISO) where one batch file can mount the WIM and another can do unmount /commit. I can't use the 7update to mount unless I run the main batch file and put in a dummy DRIVER.7z file (then I will forget I did that and end up updating with no drivers next time knowing me).

Why can the 7updater batch file mount and unmount fine but I can't, it's such a PITA.

I supposed I can try to use its DISM or something, with my own mount/unmount batch files. They were working the other day, now on a new PC, they aren't (notwithstanding 7updater, that always works).

EDIT: I copied all the files from "\7UPv50\amd64\dism" to the DISM folder I have been using and still get access denied. I'm going to cry in a minute.

DISM++ says the same thing, it just tells me it with a dialog window... "Access is denied".

REALLY

My System SpecsSystem Spec
.
30 Mar 2020   #2
10Fan

Windows 10 x64
 
 

I am so sick of this now, I give up.

It's never going to be fixed - unless I do an upgrade install of Windows - but I can't even do that because the exact same ISO I installed from, now miraculously tells me my installed version of Windows is too new! WHAT? I installed from that exact same ISO, so it's simply insane that it could even come up with that message, yet it does and I can't do the upgrade install to fix this access denied garbage with DISM.

Incidentally I can mount and unmount once (and once only!) after using 7updater, but that's it. Try to mount again (yes after doing the clean wim command and successfully unmounting) it just goes into this stupid access denied mode. Nothing I tried in the first post makes one bit of difference, with the only "fix" to do an upgrade install of Windows - which it's not letting me do even from the same installation media. This is all a complete shambles!

I know how to fix it...

Now I am running on a NVMe drive and by the grace of god bought a 500GB one so I have the space to do this - I am going to setup a virtual machine especially for doing this ultra-annoying DISM stuff - I will save a snapshot before any DISM command is ever run - then I will just do every single thing to do with DISM, inside that VM.

When it starts saying "Access denied" and I need to do a repair install of Windows and all the other nonsense I have read to fix this, I won't have to care, I'll just click the snapshot button in VMware and get it all back how it was in 5 seconds.

EDIT: It worked perfectly. I just created a 50GB VM. It seems when you mount a WIM image, it doesn't really take up the GB's of space it does take up when expanded, weird but nice lol.

Finally I can carry on updating and tweaking it.
My System SpecsSystem Spec
01 Apr 2020   #3
ian50

Windows 7 Pro x64
 
 

10Fan


That's quite an interesting on-going story - and it has an ending.


Thank you for relaying that.
My System SpecsSystem Spec
.

Reply

Thread Tools




Similar help and support threads
Thread Forum
Unable to mount images using daemon tools - Error: Access Denied
Long story short, I tried mounting recently and daemon tool gives me a access denied pop up. I haven't encountered this before and it worked before, but now it's broken? I have re-installed it and the same conclusion occurs. I have tried restarting the service and that does nothing. I tried another...
Virtualization
Updates not injecting into image using DISM
Is this forum a good place for posting WDS related question? If not please direct me to the correct forum. Thank you. Issue, short version: after running DISM commands to inject updates to the WDS images, we use the image on a box and there are no new updates installed. Only the originally...
Windows Updates & Activation
Access is denied, Trying to recover files from .wim image
Hi all, I've been searching for answers the past few days... I have successfully mounted a .wim recovery file, and I can access the folders etc. through Explorer. My problem is: The directories I need to access to recover files (like Users\Default user) gives me a "Access is denied" message. I...
Backup and Restore
DISM - Deployment Image Servicing and Management tool
I found this tool while searching the system32 folder: DISM.EXE C:\Users>dism Deployment Image Servicing and Management tool Version: 6.1.7048.0 DISM.exe {WIM_command}
Backup and Restore
System Image - Access is denied (0x80070005)
On the Backup and Restore icon, when I click on the Create a system image link. and when I choose On a hard disk, on the drop down menu I get <Refresh> When selected it says: Access is denied. (0x80070005) I want to take the image back up on other drive which is new, formatted and 230gb space....
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:34.
Twitter Facebook