Is my PC able to run Windows 7 Smoothly ??

Page 1 of 2 12 LastLast

  1. Posts : 93
    Windows 7 Ultimate 64-bit
       #1

    After Install Windows 7 , Some Problems , Help Needed


    Hi all

    Here is my PC specifications

    CPU:Intel® Core™ 2 Duo CPU E7200 @ 2.53GHz 3MB L2 Cach
    Motherboard:GIGABYTE GA-EP35-DS3L
    RAM:4x1GB KINGSTONE DDR2 800MHz
    Video Card:GIGABYTE ATI Radeon HD 3650 PCI-E 2.0 x16

    So will i be able to run it good

    Now i am using Vista Ultimate 64-bit and works great

    also will my vista drivers work good with it

    thanks a lot and waiting

    Now Downloading Microsoft Windows 7 Build 6801 64Bit


    Last edited by MohamedYousri; 13 Nov 2008 at 17:46.
      My Computer


  2. Posts : 1,027
    Windows 7 Ultimate x64/ Windows Vista Ultimate x64
       #2

    Yeah it should run good, also welcome to 7 forums.
      My Computer


  3. Posts : 93
    Windows 7 Ultimate 64-bit
    Thread Starter
       #3

    thank u mansrm81

    i am downloading it now and will try it
      My Computer


  4. Posts : 4
    Windows 7
       #4

    Yes it will run great. I'm running Windows 7 on a P4 2.8ghz w/HT and 1GB of ram and a Radeon x700 - it runs like a dream!!
      My Computer


  5. Posts : 93
    Windows 7 Ultimate 64-bit
    Thread Starter
       #5

    timmmay

    so windows 7 is more lighter than Vista

    it's seems that windows 7 worth to be tested
      My Computer


  6. Posts : 154
    Windows 7 Build 7100
       #6

    Yes it should work fine Mohamed!! Welcome to Seven Forums as well!!!
      My Computer


  7. Posts : 93
    Windows 7 Ultimate 64-bit
    Thread Starter
       #7

    linuzo

    Thank u dude
      My Computer


  8. Posts : 440
    Windows 7 Ultimate Edition x64
       #8

    Yea it runs much much lighter than Vista... For now!
      My Computer


  9. Posts : 93
    Windows 7 Ultimate 64-bit
    Thread Starter
       #9

    i am running it now

    first i am not familiar with the new windows media player

    second not all my drivers for vista works with 7 , after install sound and network adapter i found them already working , downloaded the ATI driver for windows 7 and working with it now

    haven't test any games yet

    any video i have with subtitle .SRT or .IDX doesn't load with the video don't know why although i already installed K-Lite Codec Pack

    can't find any other PC at my network although i tried to setup it more than 4 times and still can't find any other PC

    also picture at WMP working slowly like a slow motion but not so slow

    can't enable the new task bar of windows 7

    Last edited by MohamedYousri; 13 Nov 2008 at 17:06.
      My Computer


  10. Posts : 576
    Vista X32. Windows 7 32bit
       #10

    Welcome to the forums MohamedYousri, Great that you've got it up and going. Please don't forget to post any solutions, or new problems you find. Thats how we all learn.
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:08.
Find Us