Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Your power plan information isn't available" error msg

08 Jan 2010   #1

windows 7 Ultimate
"Your power plan information isn't available" error msg

I am trying to change power setting but I got a message "Your power plan information isn't available." I will download a game that will take me like 8 hours. I'm about to sleep already and decided to change power setting and sleep option but options are not available. I activated the account administrator and have 2 account administrators. I logged in on the account administrator and got no option. Same as with the other account. What should I do?

My System SpecsSystem Spec
08 Jan 2010   #2

64-bit Windows 10 Pro

Hello Whinner, and welcome to Seven Forums.

You might see if doing OPTION ONE in the tutorial below to reset all power plans back to default may be able to help.

Power Plan - Restore Default Settings

Hope this helps,
My System SpecsSystem Spec
09 Jan 2010   #3

windows 7 Ultimate

i already tried that but did not work. I was reading topics and forum before i post this and think im missing registry. i do system scan in cmd and found out that WIndows Resource Protection found corrupt files. I think i need to add those registry
My System SpecsSystem Spec

09 Jan 2010   #4

64-bit Windows 10 Pro


The easiest way to go about this I believe would be to do a repair install. It will fix it for you without losing anything. It's a lot safer.
My System SpecsSystem Spec
26 Jun 2011   #5

Windows 7 64-bit

I also had this problem so posting a reply for all it might help.

Here's how to walk thru changing the security on the LIDCLOSE (and any other power option that is blocked, all this is general purpose):

1. Get your GUID for the active profile
powercfg -getactivescheme

2. Dump the list of permissions/settings
powercfg -qh {GUID from above} > list.txt
(this is a large output redirect it to a file)

Now in this you will see the following if you search for "lid"

NOTE: see in the below the current index is "1" for ac (plugged in) as well as dc (battrery). This is what we are trying to change! I want "0" (Do nothing)

Power Scheme GUID: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c
Subgroup GUID: 4f971e89-eebd-4455-a8de-9e59040e7347 (Power buttons and lid)
Power Setting GUID: 5ca83367-6e45-459f-a27b-476b1d01c936 (Lid close action)
Possible Setting Index: 000
Possible Setting Friendly Name: Do nothing
Possible Setting Index: 001
Possible Setting Friendly Name: Sleep
Possible Setting Index: 002
Possible Setting Friendly Name: Hibernate
Possible Setting Index: 003
Possible Setting Friendly Name: Shut down
Current AC Power Setting Index: 0x00000001
Current DC Power Setting Index: 0x00000001

3. In order to be able to change it, either thru the Power Management UI or thru the command line, the security descriptor for LID CLOSE needs to be changed

4. Get the current security descriptor:
powercfg -getsecuritydescriptor LIDACTION

on my system, this returned:

5. In the above the first two items in parens relate to permissions for BU (Built-in Users) and BA (Built-in Administrators)

6. Note that for SY (Local System) the Registry Key Access is set to "KA" for All Key Access vs. "KR" for Key Read

7. Change that value to unlock this function
powercfg -setsecuritydescriptor LIDACTION O:BAG:SYD:P(A;CI;KA;;;BU)(A;CI;KA;;;BA)(A;CI;KA;;;SY)(A;CI;KA;;;CO)
[just change the "KR" to "KA"]

8. Now you can set thru the UI or, thru the command line using :
powercfg -setacvalueindex Scheme_GUID Sub_GUID Setting_GUID SettingIndex

use all the GUIDs for your current scheme, sub and setting (clearly noted from the -qh output) and on my system the setting index is "0" for "Do nothing"

9. You can check thru UI, -qh again, and so forth
My System SpecsSystem Spec
19 Nov 2012   #6

windows 7 Untimate x64
Solution that Works

I have had this problem literally for years. I have fixed it many times, but it always comes back sometime within the next couple of days or couple of months.
If you research it, you will find many suggestions. I have probably tried them all, including begging Microsoft for an answer. All of the fixes people suggest work occasionally, but only one that I know of fixes the problem every time. That fix is to compact the registry. It takes a long time and the problem still comes back, but at least I have something that gives me temporary relief. I use JV16 to compact the registry, but there are other programs that do it.
I hope this helps.
My System SpecsSystem Spec
08 Apr 2013   #7

Windows 7 Ultimate x64
your power plan information isn't available then....

note: this is applicable for samsung laptops oly...

if it show then pls go to start ----> All programs ----> fast start ----> pls click on off buttom...
then u can change the power plan..
My System SpecsSystem Spec
08 Apr 2013   #8

windows 7 Untimate x64

I don't have a Samsung.
My System SpecsSystem Spec

 "Your power plan information isn't available" error msg

Thread Tools

Similar help and support threads
Thread Forum
Re: Would TWC's Newer "Everyday Low Price" Internet Plan Work?
Hello. I have a question to ask you. Time Warner Cable (TWC) has their latest "Everyday Low Price" for $14.99 for "Download up to 2Mbps" and with "Upload up to 1Mbps". I am not sure if this pricing schedule is particular to my area or nationwide. I have Time Warner Cable Internet with Turbo...
General Discussion
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
Major ISPs agree to "six strikes" copyright enforcement plan
Dont know where to put this, but I thought people should be aware of it! especally if they have kids who use P2P software ect! Major ISPs agree to "six strikes" copyright enforcement plan
BSOD with "usbhub.sys" and "driver power state failure"
I have been getting the BSOD since a few weeks and found out by trial and error that a USB-hub is causing the problem. Whenever I disconnect the hub before I shut off the computer I do not get the blue screen. Yesterday I also got a BSOD that mentioned driver power state failure. After I had...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App