Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High RAM and CPU usage

24 Jan 2010   #1
fuzzy29

XP, Win7, Ubuntu, Mac
 
 
High RAM and CPU usage

Hi, When I start my pc, and select Windows7 from the dual boot menu, I get the usual logo, then my screen goes blank for about a minute. Once that has gone, and I login, my CPU and RAM are, on average, CPU: 30%, RAM: 60-70%, although the CPU and RAM have peaked at 100%.

I have disables SuperFetch, scanned my system for viruses/worms/etc... Using Avast.
I have Spybot S&D , as well as teatimer.exe (Prevents registry access without giving permission).

Does anyone know what could be causing this? Any help would be greatly appreciated.
Thanks in advance, Dan.

( 4GB RAM - 32bit Win7 [So it can only use 3.5Gb] - 9.6 GHz Quad Core CPU )


My System SpecsSystem Spec
.
24 Jan 2010   #2
Wishmaster

Windows 7 Home Premium 64bit
 
 

You mean a 2.4Ghz Quad? as in your spec ?


First thing, how many processes/programs are starting with Windows?

Does it drop down after its running a few minutes or only happening at first boot?

You can try something like autoruns or even CCleaner (startup tab) to see what all is booting with windows
My System SpecsSystem Spec
24 Jan 2010   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by fuzzy29 View Post
Hi, When I start my pc, and select Windows7 from the dual boot menu, I get the usual logo, then my screen goes blank for about a minute. Once that has gone, and I login, my CPU and RAM are, on average, CPU: 30%, RAM: 60-70%, although the CPU and RAM have peaked at 100%.

I have disables SuperFetch, scanned my system for viruses/worms/etc... Using Avast.
I have Spybot S&D , as well as teatimer.exe (Prevents registry access without giving permission).

Does anyone know what could be causing this? Any help would be greatly appreciated.
Thanks in advance, Dan.

( 4GB RAM - 32bit Win7 [So it can only use 3.5Gb] - 9.6 GHz Quad Core CPU )
I would bet that is caused by what ever A/V you have installed. It's a very common problem in fact.
My System SpecsSystem Spec
.

25 Jan 2010   #4
fuzzy29

XP, Win7, Ubuntu, Mac
 
 

@Wishmaster:
yes, does it matter (other than it'd be amazing if they had a single core that fast)
Only about 40 processes, and it stays at the same high levels all the time I'm using it.

@chev65:
I have the same Avast running on my XP machine at the moment (With firefox, A/V, Spybot, MSN, Steam), and the RAM usage is 14%, the CPU usage 1%.

Thanks for the quick replies.
My System SpecsSystem Spec
Reply

 High RAM and CPU usage




Thread Tools




Similar help and support threads
Thread Forum
Svchost.exe Crazy High CPU Usage and Crazy High Memory Usage
There is a serious issue with svchost.exe on my windows 7 computer. My HP Touchsmart 300-1025 has windows 7 64bit installed and svchost is slowing down the computer and using very high cpu and memory usage. It is not a virus or malware. I know the computer is not infected because one the computer...
Performance & Maintenance
Very high physical memory usage, no high usage programs running
Hello everyone, I've been having a very weird problem recently, in which I BELIEVE is involving high physical memory usage. Sometimes I will be doing things such as playing a game, or watching a stream, and my computer will run fine for a little while. But at random times, my computer will majorly...
Performance & Maintenance
Stuttering and high CPU usage while downloading at high speeds
I've been having this problem now for an year or so now. It started when I upgraded my connection from 8/1 ADSL to 100/10 cable (so the problem wasn't noticeable even if it was there before) and when I download at high speeds (in steam, for example) my CPU usage jumps to 80% and higher, and my pc...
Network & Sharing
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App