Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I cant delete my file.

02 Feb 2010   #1

Window 7 Professional X86
I cant delete my file.

Hi, Im facing a problem here. I cannot delete my file and it stuck in "Preparing to recycle". It keep calculationg.
Another thing is when i try to delete the file, my CPU usage increase from 10% to 50%.

Here are the screenshots..

Before i delete my file.

After i try to delete the file.

Anyone know what is going on?
Only some of the files facing this problem as i can delete most of my files.

My System SpecsSystem Spec
02 Feb 2010   #2

Windows 7 Professional x64


First off, what files are you trying to delete? Could they be in use or protected?

Second, have you tried rebooting yet? Sometimes that will fix the problem.

Hope this helps,
My System SpecsSystem Spec
02 Feb 2010   #3
Agent Zach

Windows® 7 Home Premium SP1 [x64]

I recommend using this utility called "Unlocker". It seems to work the best when you have this issue, and 80% of the time, it doesn't even require you to restart.

My System SpecsSystem Spec

02 Feb 2010   #4

Window 7 Professional X86

I try to delete my movie(.rmvb). I have reboot my laptop for times..
yet still facing this problem.

Sometime when i try to delete huge size of file like 1.5GB, it can be deleted but take some times if compare to window vista.
Is that the compatible problem with my hdd?
Im using western digital scorpio blue 500GB with window 7 professional.
My System SpecsSystem Spec
02 Feb 2010   #5

Windows 7 Professional x64

If it is not a permissions issue you can go into Windows "recovery environment" and delete it from CMD. Kind of drastic, but it will probably work.

My System SpecsSystem Spec
02 Feb 2010   #6
Agent Zach

Windows® 7 Home Premium SP1 [x64]

Are you trying to "Delete to Recycle Bin" or are your doing a "Hard Delete" on the file?

If you're Deleting to the Recycle Bin, try to "Hard Delete" the file.
  1. Select the file (Single Click it)
  2. Press & hold Left Shift, and press "Delete" on your keyboard.
  3. Click Yes/OK
If it's a No-Go, try the Unlocker Utility.
My System SpecsSystem Spec
02 Feb 2010   #7

Window 7 Professional X86

Im trying to search for the unlocket utility.
Because i try to use the DEL in CMD. it hang over there.
try Left Shift + Delete, same problem occured, it calculating.
My System SpecsSystem Spec
02 Feb 2010   #8
Agent Zach

Windows® 7 Home Premium SP1 [x64]

Thinking that it could possible be a DLL (Dynamic Link Library) issue internally, I think you should run the System File Checker.

  1. Click your Start Orb
  2. Type the letters "cmd" into your Start Search
  3. When you see the CMD icon, Press and Hold Ctrl + Shift, and Click the CMD icon
    • Holding CTRL + Shift and Clicking an icon will open it as Administrator
  4. Type in the following: sfc /scannow
  5. Press {Enter} and let it check your system files
    • This may take Hours to complete
  6. Restart your computer, then try again.
If the problem still exists, your Copy of Windows might be "pooched" metaphorically speaking.
My System SpecsSystem Spec
02 Feb 2010   #9

Window 7 Professional X86

Thanks all for the help.
I manage to delete the file using ProXic method.
After a scan and i restart my laptop, i can delete my file.
Thanks ProXic.
My System SpecsSystem Spec
02 Feb 2010   #10
Agent Zach

Windows® 7 Home Premium SP1 [x64]

You're very welcome. Glad to help.

Hope all is well. :)
My System SpecsSystem Spec

 I cant delete my file.

Thread Tools

Similar help and support threads
Thread Forum
File permissions, can't delete file with 0 bytes size
I downloaded a file, didn't download correctly, size = 0 bytes. Reports owner unknown. I can't change ownership, remove file properties, any of that stuff. Can't rename or delete. I'm logged in as administrator but it keeps asking for administrator permission. ?? Another question about...
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
Help file wont delete win 7 says there is no file
I have a download that got interrupted and now have a file with extension .file that cant be deleted. Cleaning software wont catch it, restarting not working either. Havent tried a restore yet
General Discussion
Can't delete file due to invalid file name
Hey all! I have a .png file on my secondary hard drive, which I cannot seem to delete. When I try to delete or rename it, it tells me: "The selected file name is invalid or too long". I came across the programs Delinvfile and Unlocker, but they did not seem to work for me. Appreciate any...
General Discussion
Can't delete a jpg file
I can't delete a jpg file from our computer. The issue is that we can't even click on the file w/o it freezing the computer. I noticed the problem because I tried to run a defrag and virus check but both get stuck on this same file. I can't right click on it or even drag a box over it w/o the...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App