Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System lags while downloading .

21 Feb 2010   #1
Deeko78

Windows 7 Ultimate 32 bit
 
 
System lags while downloading .

Hi all at W7 forums.

I'm having a problem I just cant seem to figure out. Recently upgraded to Windows 7 Ultimate 32 bit, from Vista, & have loved it so far until I had broadband connected at my new flat.

Whenever I try to download anything at all as soon as the speed reaches around 100kB/s my system seems to lag unbearably. My mouse movement get so jerky its very difficult to do anything.

Checked task manager & everything is fine there. CPU & memory usage is fine. Also checked all my drivers are updated, defragged both my hard drives, ran virus, & malware scans, but it still happens as soon as anything is being downloaded. The instant I stop the download my system behaves normally.

Googled around & see that it has happened to a few others, but no real solution to the problem. Dont think its a network problem as web browsing & online gaming are fine, as long as I dont download.

Any help would be greatly appreciated.

CPU Type - DualCore AMD Athlon 64 X2, 2600 MHz
Motherboard Name - Biostar MCP6P M2+
Motherboard Chipset - nVIDIA nForce 6100-4xx, AMD Hammer
System Memory - 2048 MB
Video Adapter - NVIDIA GeForce 9600 GT (512 MB)
Disk Drives - ExcelStor J9250S (250GB), Seagate 7200.8 (300GB)


My System SpecsSystem Spec
.
21 Feb 2010   #2
Nemix

Windows 7 Professional
 
 

Try reading this thread:

Downloading makes 7 really slow

My System SpecsSystem Spec
21 Feb 2010   #3
Deeko78

Windows 7 Ultimate 32 bit
 
 

Thanks Nemix, but I read that thread earlier. Poor guys still having the issue by the looks of it.

Thought it may be the IRQ problem as my network adapter & standard enhanced PCI to USB host controller share the same IRQ of 20. Spent 2 hours trying to change one of them, but there are no options in my bios for changing IRQ's, & I couldnt find any info on how to do that.
My System SpecsSystem Spec
.

21 Feb 2010   #4
Nemix

Windows 7 Professional
 
 

Do you have the latest OEM drivers for your motherboard from NVIDIA download site?

Is your networkcard onbaord? If so, is it Realtek is the device manager?

My System SpecsSystem Spec
21 Feb 2010   #5
Deeko78

Windows 7 Ultimate 32 bit
 
 

Yep. All my drivers are up to date. My network card is onboard, Nvidia nForce Networking Controller.

Not sure what your asking about Realtek, but yes thats my audio controller in the device manager.

Thanks for your time.
My System SpecsSystem Spec
21 Feb 2010   #6
Nemix

Windows 7 Professional
 
 

No, because some motherboards can install both NVIDIA network drivers and Realtek drivers if the chip onboard is Realtek.

My old nForce 2 motherboard allowed me to do this with the onboard soundcard.

I've checked out you motherboard specs, Realtek does not offer drivers for you NIC becuase it's PHY.

Sorry, I cannot help you.

My System SpecsSystem Spec
21 Feb 2010   #7
Deeko78

Windows 7 Ultimate 32 bit
 
 

No probs Nemix.

Thanks anyway.
My System SpecsSystem Spec
21 Feb 2010   #8
Nemix

Windows 7 Professional
 
 

One other thing I forgot to mention, have to updated to the latest BIOS for your motherboard?

Also, have you tried diagnosing the problem in Windows 7?:

Start>Control Panel>Network and Sharing Center>Change Adapter Settings>Right Click 'Diagnose" on your NIC Adapter.

My System SpecsSystem Spec
21 Feb 2010   #9
Deeko78

Windows 7 Ultimate 32 bit
 
 

Yep, BIOS is up to date also.

Just tried diagnosing the network adapter & it came back with this -

Your computer appears to be correctly configured, but the device or resource (DNS server) is not responding.
My System SpecsSystem Spec
21 Feb 2010   #10
Frostmourne

Windows 7 Ultimate x86-64
 
 

1) Install the latest nforce chipset driver.

2) Disable the COM, Serial and any other unnecessary ports in the BIOS.

3) Reboot.
My System SpecsSystem Spec
Reply

 System lags while downloading .




Thread Tools




Similar help and support threads
Thread Forum
Buzzing/System freeze when downloading
Hi all Been a lurker for a while and need some help. I work in tech support and can normally isolate an issue pretty fast but I am seriously stuck with this one. Just to clear up, I am getting no BSOD. As soon as I start downloading, whether that be from utorrent or chrome, my computer...
General Discussion
nt kernal & system 25% CPU usage, internet lags
4c/8t processor uses 25% of its cpu to this nt kernel & system. system lags a bit but barely and what hit me was the internet speed. i went to speakeasy for speed test and im still getting the usual 15mbps, but when i game online it constantly lag and got me thinking its something to do with my...
Network & Sharing
my game meets the system requirements but still lags
my game is nfs underground 1 i searched the req is p3 700mhz, p4 for better.. ram 256mb needed...gpu 32mb, 64mb better my specs: P4 1.8 ghz ram 768mb 64mb integrated it lags even at low to medium graphics settings
Gaming
My new $800 system is worthless while downloading.Help!
I have a new Toshiba Satellite that is running Windows 7 32bit Dual Core with 3GB RAM and ATI Radeon Graphics. Whenever I download ANYTHING, my mouse becomes so slow and choppy that it is literally impossible to do any other task while downloading anything (Firefox and uTorrent downloads.) It...
Performance & Maintenance
System Lags Every 5 minutes
My system lags every 5 minutes for about 5 seconds or so and everything freezes solid. Even the clock will stop ticking, music will skip, videos will hiccough, you name it. What is going on to cause this? I'm running 7 Pro 64 bit on an Acer Travelmate 5730-6188 (Core Duo processor 2.0ghz and 3...
BSOD Help and Support
System Interrupt while downloading
Hi, I recently installed windows 7 Home Premium x64 from XP (did a custom ijnstall) Everything seems to be fine until I download. (Downloading my games from steam and even browsing youtube) My CPU will randomly shoot up to 80 - 100% and my linksys usb internet adapter will stop functioning...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App