Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: downloads causing heavy PC lag

16 Mar 2010   #1
MrCharles

Windows 7 Ultimate
 
 
downloads causing heavy PC lag

This is the strangest problem I've come across with Windows 7. once I start downloading files, or my browser starts downloading images/streaming videos my entire PC lags until the downloads are complete or have been paused. Then my computer runs fine again.

This never occurred when I first installed Windows 7 it just started happening out of nowhere after 2 months of using the OS. I've tried reinstalling and it fixed everything and ran perfect, and now its back again! And yes it was 100% a clean install.
Along with my entire PC lagging if I have music on it starts playing as if there's no memory, and its unbearable to listen - the song starts playing in slow motion an choppy while my mouse is lagging like crazy also.

The only solution I have found is to reinstall the OS, and I really don't want to keep reinstalling every two months or so I'm going to lose my mind!

-Video drivers / Audio drivers all up to date.
-Only programs running are Firefox/Eset NOD32/Malwarebytes and Winamp
-I have 2 Gigs of DDR2 memory running along with a Pentium 4 processor


My System SpecsSystem Spec
.
16 Mar 2010   #2
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Right click on the taskbar and click on Task Manager. In the Task manager window, click on "Processes" tab, that will tell you what processes are hogging your cpu.
Incidentally, do you have Zone Alarm installed? Have seen some such issues with that.
My System SpecsSystem Spec
16 Mar 2010   #3
MrCharles

Windows 7 Ultimate
 
 

No zone Alarm installed, I'm just using the Windows firewall
My System SpecsSystem Spec
.

16 Mar 2010   #4
DeZ

Windows 7 Ultimate 64
 
 

Sorry to jump on your thread MrCharles, but I am having the same issue.

I am running 64 bit ultimate, and this is really doing my head in. I have been trying to resolve this for about a week now with no luck . I have tried disabling AVG internet security, disabling all non essential devices in the bios, removed the drivers for the on board NIC card and various other things.

Any suggestions would be greatly appreciated.

DeZ
My System SpecsSystem Spec
16 Mar 2010   #5
MrCharles

Windows 7 Ultimate
 
 

Wish I had ANY Ideas, I have absolutely no clue.

I've monitored running processes and memory, nothing out of the normal, I've turned off all gadgets, ive run registry cleaners along with defraging, even system restore, nothing seems to be helping.
My System SpecsSystem Spec
17 Mar 2010   #6
DeZ

Windows 7 Ultimate 64
 
 

I have now resolved this issue, for me anyway

I have an Asrock N7AD-SLI Motherboard that has a nForce 740i chipset. I used the latest drivers from nvidia.co.uk, the pack installed Ethernet Driver (v73.14+) WHQL that was causing the problem (thank christ for the spare wlan adapter i had lying).

So, uninstalled that driver and installed Ethernet Driver (v73.06) WHQL, now able to download at full speed with no system lag

DeZ
My System SpecsSystem Spec
17 Mar 2010   #7
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

MrCharles, if the computer is lagging it must be because some app or process is hogging cpu or ram. You need to identify which.
So, one way is to check in your Task manager when you are experiencing the lag.
You can also check your event viewer. Might be useful info there.
My System SpecsSystem Spec
20 Mar 2010   #8
DeZ

Windows 7 Ultimate 64
 
 

So, thought the problem was resolved but it still remains have gone and bought a new Ethernet card as well. I'm thinking you might be right path Bill2, when windows first starts up i can download fine for a few minutes, however the system gets laggy again. I'm beginning to think one of the system services are causing the problem, as i have disabled every device one by one checking dpclatency checker.
My System SpecsSystem Spec
20 Mar 2010   #9
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Let us know.
My System SpecsSystem Spec
20 Mar 2010   #10
MrCharles

Windows 7 Ultimate
 
 

Problem still going on, Whats going on here

My System SpecsSystem Spec
Reply

 downloads causing heavy PC lag




Thread Tools




Similar help and support threads
Thread Forum
BSOD during heavy use
I recently built a computer, and it was doing okay for a few days. It just started crashing a lot while playing video games (screen freezes and it makes a loud noise - particularly GW2, which I'm told is more CPU heavy). It also blue screens sometimes. After exiting out of a GPU benchmark program...
BSOD Help and Support
Heavy Bullets
Just picked this game up from the early access section on steam. its super colourful and fun, with not very demanding requirements! worth a look, has 25% off at a smidge under 6! http://www.youtube.com/watch?v=LXyPREL0Kr0
Gaming
Downloads FireFox only downloads partial files?!
The problem accured when I wanted to download some cool backgrounds from interfacelift, i would click the backgorund-->save image as... and choose desktop, it would only download 34kb of like 1mb of image (1080p-1920x1080) and is unable to view it in imageviewer too.... anybody know what would...
Performance & Maintenance
Heavy downloads
Hi i am considering signing up to virgin medias 50meg broadband I am quite a heavy downloader varying from streaming, gaming, downloading through steam etc, and also usenet. Now im curious is there any one out there that is on this plan that gets through over 500 gig in a week? If so did you get...
Network & Sharing
MSE is too heavy for my PC...
I'd like to install a GOOD anti virus which is also light on the RAM :) I'v heared about Panda Cloud... Is it anygood? Im seek of Avira and MSE...
System Security
What's causing heavy disk activity on USB drive?
I'm not sure if this was happening before, but today I noticed that when the system is in its monitor off mode (I have it set to go after 20 minutes of non-use) the activity light on my USB drive will be blinking like crazy. Moments after I move the mouse to get back into working mode it will stop....
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App