Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 6GB memory (2GB usable)

06 Apr 2010   #11
Lief

window 7 x64 bit
 
 

Quote   Quote: Originally Posted by whs View Post
Quote   Quote: Originally Posted by Lief View Post
Quote   Quote: Originally Posted by osholt View Post
Post a screenshot of resource manager when it says there is only 2GB available.

Oli
i can't get the screenshot of resource manager when it says there is only 2GB available, cause this weird thing only happens the next day when i turn on my computer. i shutdown and restarted my computer for a couple of time it still says 5.50GB usable, but it probably will turn to 2GB usable by tomorrow morning.
Well, no problem. We'll wait until tomorrow.
yeah, it turns to 2GB usable again, theres the screenshot.




Attached Thumbnails
6GB memory (2GB usable)-qq-2.png  
My System SpecsSystem Spec
.
06 Apr 2010   #12
Lief

window 7 x64 bit
 
 

Quote   Quote: Originally Posted by whs View Post
Quote   Quote: Originally Posted by Lief View Post
Quote   Quote: Originally Posted by osholt View Post
Post a screenshot of resource manager when it says there is only 2GB available.

Oli
i can't get the screenshot of resource manager when it says there is only 2GB available, cause this weird thing only happens the next day when i turn on my computer. i shutdown and restarted my computer for a couple of time it still says 5.50GB usable, but it probably will turn to 2GB usable by tomorrow morning.
Well, no problem. We'll wait until tomorrow.
it turns to 2GB usable again, there the screen shot,


Attached Thumbnails
6GB memory (2GB usable)-qq-2.png  
My System SpecsSystem Spec
06 Apr 2010   #13
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Well, the reporting is correct. But I wonder how your hardware could possibly use those 4GBs - that does not sound right. I would contact the PC manufacturer and ask them. One reason could be that there is something wrong with your BIOS and you need to flash a newer (or older) version.
My System SpecsSystem Spec
.

06 Apr 2010   #14
Lief

window 7 x64 bit
 
 

Quote   Quote: Originally Posted by whs View Post
Well, the reporting is correct. But I wonder how your hardware could possibly use those 4GBs - that does not sound right. I would contact the PC manufacturer and ask them. One reason could be that there is something wrong with your BIOS and you need to flash a newer (or older) version.
ok, thank you very much, and just let me know what should i do.
My System SpecsSystem Spec
06 Apr 2010   #15
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

As I suggested, call the manufacturer as a first step. Regarding BIOS issues they would know better than us.
My System SpecsSystem Spec
06 Apr 2010   #16
osholt

Windows 7 Profesional x86, Mac OS X 10.6 Snow Leopard
 
 

I just checked for possable BIOS updates for your mother board and found that the last BIOS update was release less than a month a go with the tag 'Enhanced memory compatibility' .

If you do need to flash your BIOS all the upgrade/downgrade firmware is available to download at GA-X58A-UD3R (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - BIOS.

Oli
My System SpecsSystem Spec
07 Apr 2010   #17
Scotteq

Windows 7 (x64)
 
 

Quote   Quote: Originally Posted by osholt View Post
I just checked for possable BIOS updates for your mother board and found that the last BIOS update was release less than a month a go with the tag 'Enhanced memory compatibility' .

If you do need to flash your BIOS all the upgrade/downgrade firmware is available to download at GA-X58A-UD3R (rev. 1.0) - GIGABYTE - Support&Download - Motherboard - BIOS.

Oli


Quick reminder concerning the above: If you've Overclocked and/or made significant changes to the system comfiguratin in the Bios, then ensure the Bios is cleared and re~set to the default configuration before proceeding with the Flash.
My System SpecsSystem Spec
07 Apr 2010   #18
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by Lief View Post
Quote   Quote: Originally Posted by osholt View Post
If it is staying at about 5.5GB available that sounds about right.

The missing half a Gigabyte is reserved for various pieces of Hardware to use.

Oli
yeah, the problem is that, it doesnt stay at 5.50GB. It always shows 6GB (2GB usable) after i turn on my comp, then i have to turn off my comp then give the memory a touch or a push and restart my comp, then the memory goes 5.50GB usable.
Ahhhh... so this is actually a hardware problem...

Take out your memory modules. On the strips themselves, clean the gold edge connectors with a soft pencil eraser... then brush with a paint brush to get the little rubber bits out. On the sockets... spray them with rubbing alcohol (aka contact cleaner) and clean gently with a soft toothbrush.

When you put your memory back in press very firmly to make sure the locking clips snap into place on both ends of each stick. Wiggle side to side slightly with your finger to make certain they are seated...

Now what do you get?
My System SpecsSystem Spec
07 Apr 2010   #19
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by whs View Post
Well, the reporting is correct. But I wonder how your hardware could possibly use those 4GBs - that does not sound right. I would contact the PC manufacturer and ask them. One reason could be that there is something wrong with your BIOS and you need to flash a newer (or older) version.
Most likely it's detecting all memory strips SPD but getting r/w errors during POST scanning so it flags it as unuseable.

From his description of how it comes back with a finger's touch, this sounds for all the world like a bad connection... probably just some dirt that got into the wrong places.
My System SpecsSystem Spec
07 Apr 2010   #20
Lief

window 7 x64 bit
 
 

Quote   Quote: Originally Posted by CommonTater View Post
Quote   Quote: Originally Posted by whs View Post
Well, the reporting is correct. But I wonder how your hardware could possibly use those 4GBs - that does not sound right. I would contact the PC manufacturer and ask them. One reason could be that there is something wrong with your BIOS and you need to flash a newer (or older) version.
Most likely it's detecting all memory strips SPD but getting r/w errors during POST scanning so it flags it as unuseable.

From his description of how it comes back with a finger's touch, this sounds for all the world like a bad connection... probably just some dirt that got into the wrong places.
ok, ill try that, thank you
My System SpecsSystem Spec
Reply

 6GB memory (2GB usable)




Thread Tools




Similar help and support threads
Thread Forum
4Gb memory (2.75 Gb usable) memory remapping in bios causes BSOD
I recently did a new install of Windows 7 64 bit. I noticed windows showed 4Gb of ram (2.75Gb usable). I read tons of articles after googling this and tried several options to free up some more ram. I have 2 options in bios to change memory remapping over 4GB. S/W and H/W. When I enable S/W...
BSOD Help and Support
Memory has only 2Gb usable
Hi everyone I just transported my rig back from collage and when i set it back up i noticed that i only had 2 Gb of ram being used. I have flashed bios and that didn't fix the problem. I have also tried to run a system repair for windows 7 and that came up with a Error code = 0x490 but couldn't...
Hardware & Devices
adding memory results in less usable memory
i have a new HP Z400 workstation. it has a new install of windows 7 enterprise 64bit with all updates. the pc came with 6gb of ram installed. i purchased 6gb of kingston memory that was specifically listed for this workstation. the ram is installed as 6 x 2gb modules. slot 1 factory module...
Hardware & Devices
Memory 6GB (2.0GB Usable)????
Hey, I've been having some issues with my computer recently in that the memory it seems to be capable of using has been capped at 2GB despite having 6GB installed. I have included a print screen to display the problem, any help is greatly appreciated. Cheers...
Hardware & Devices
4GB memory, only 2GB usable?
How is it that even on a Core 2 Duo with W7 64bit installed, only 2GB is usable out of the 4GB installed? Why? In msconfig, I set the advanced boot option to 2 CPU cores and 4096 memory. asusqhq.png at Pingy - Free Image Hosting
General Discussion
Installed Memory (Usable Memory)
Just as the topic looks, that's what I'm having an issue about right now. Now, lets begin by laying some different things out on the line. 1) I used search, 2) I used Google, 3) I even tested this on different machines (will explain below), and 4) I put this in the right forum... I hope.. :huh: ...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App