Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: General Low Performance (without gaming)

18 May 2010   #21
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by sherbieny View Post
What can I do about the drivers that is causing the problems ?
for example the Intel(R) ICH8 Family PCI Express Root Port 2 - 2841
the computer tells me that its up-to-date, so what can I do?

Good question, one I don't have an answer for.

It's related to your network adapters, have you used device manager and/or Windows update to update drivers for both your wireless and network adapters?

Download Intel(R) ICH8 Family PCI Express Root Port 2 - 2841 and Upgrade your Windows 7, Windows Vista, or Windows XP with the Latest Intel(R) ICH8 Family PCI Express Root Port 2 - 2841

These are for Vista but there's some good infor there.

Ap


My System SpecsSystem Spec
.
18 May 2010   #22
sherbieny

windows 7 ultimate, 32-bit
 
 

here are my processes now
truth to be told after I disabled and then enabled it yesterday I did notice the difference
but today (and I don't know why) the computer seems better even when my wireless is enabled
even the .flv videos seems normal, I still didn't try any heavy game (Like Assassins's Creed 2) which is more important to me than whatever OS I'm having

As every would notice there are many svchost running, what are they


Attached Thumbnails
General Low Performance (without gaming)-z.jpg  
My System SpecsSystem Spec
18 May 2010   #23
sherbieny

windows 7 ultimate, 32-bit
 
 

is this radar sync safe??
My System SpecsSystem Spec
.

18 May 2010   #24
sherbieny

windows 7 ultimate, 32-bit
 
 

this radarsync needs money which I won't pay
is there any other way
My System SpecsSystem Spec
18 May 2010   #25
CarlTR6

Windows 7 Ultimate 32 bit
 
 

This is normal. Each svchost is handling different processes and functions.
My System SpecsSystem Spec
18 May 2010   #26
sherbieny

windows 7 ultimate, 32-bit
 
 

where else can i find
Intel(R) ICH8 Family PCI Express Root Port 2 - 2841
update
My System SpecsSystem Spec
18 May 2010   #27
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by sherbieny View Post
where else can i find
Intel(R) ICH8 Family PCI Express Root Port 2 - 2841
update
I really wouldn't concentrate on that one item, the drivers you are looking for are Intel chipset drivers and will most likely be found on the Dell site.

I only posted the Radar site only for information purposes.

Ap
My System SpecsSystem Spec
19 May 2010   #28
sherbieny

windows 7 ultimate, 32-bit
 
 

should I download and install all the drivers there on the dell website for windows 7
My System SpecsSystem Spec
19 May 2010   #29
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by sherbieny View Post
should I download and install all the drivers there on the dell website for windows 7

It's hard to say, do they have a full set of Windows 7 drivers for your system?

I would venture to say yes.

Ap
My System SpecsSystem Spec
19 May 2010   #30
sherbieny

windows 7 ultimate, 32-bit
 
 

no they have vista drivers which i downloaded today and installed

seems that my problems ended when i installed the BIOS update

but I still didn't test for heavy games, I'll do it and see what happen
I think I must disable Aero theme before playing
My System SpecsSystem Spec
Reply

 General Low Performance (without gaming)




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 very slow start up and sluggish general performance
Hi all, My Lenovo G570 (i5, 4GB ram) running on Windows 7 Home Premium had been running great up until last night... It's now booting up really slowly and once it eventually has booted up it runs very slowly too (everything seems to be in slow motion i.e. if I click "computer" it opens up very...
Performance & Maintenance
PC performance in general
Hello SF Ive had my rig for just about 3 years now custom built by myself and its just not cutting it anymore. I think my specs are correct but they are M4A785TD-V Evo Mobo phenom ii 560 BE 3.30 8GB corsair RAM blah blah 500w PSU
General Discussion
BSOD while gaming in general
Hello everyone, Well I had this computer for about a year now and just recently had to replace the CPU and Motherboard. So for the past month I have been trying to deal with trying to figure out why these BSOD are occurring. I have ran prime95 once but I'm not to crazy good with computers and...
BSOD Help and Support
Very slow boot time, decreased general performance
Hi All. I used to run my PC on Vista Ultimate 64bit and was very happy ith its performance, but after seeing it forget the window layout for the umpteenth time, I decided to install Win7. Purchased a Win7 Home Premium 64bit Systembuilder package, formatted all my drives and installed it. ...
Performance & Maintenance
General Gaming/Graphics/System-Problem
Hi, I have a problem when gaming. Either one of two problems occur when playing a good portion of my games: 1st: When enabling Anisotrope Filtering or Antialising, the game freezes quickly (5-30 minutes). The video stops (still visible), sound keeps going, the game stops reacting but you can...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App