Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: windows 7 ultimate: lag issues

15 Jun 2010   #1
no one

windows 7
 
 
windows 7 ultimate: lag issues

A couple days ago, my computer started getting laggy when I use windows 7. The funny thing is, it only lags after a period of time after the windows starts (don't know exactly how long or if it's even consistent). It doesn't matter how many programs I was running at the time (well, it do lag a bit more when I open multiply programs) and this certainly isn't the hardware's fault (since it only happen lately while I have been using windows 7 for quite some time).

Any idea on how to fix this?

Oh yeah, my younger brother said around that time period (he didn't remember exactly when), he deleted a few folders and some of them contain dll files, don't know if that is related.


My System SpecsSystem Spec
.
15 Jun 2010   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Welcome

If due to changes, just do a system restore.

If that does not work, test thememory with memtest86

If still does not work Type cmd in search, then right click and run as administrator. In the cmd type sfc /scannow.
My System SpecsSystem Spec
15 Jun 2010   #3
no one

windows 7
 
 

Quote:
Welcome
Thanks. Look like I forgot the whole "hi, this is my first time, please be gentle" thing lol.

Quote:
If due to changes, just do a system restore.
I didn't make any restore point so it only get me back to the last time some important thing come up, which unfortunately is during the laggy period.

Quote:
If that does not work, test thememory with memtest86
Will test that tomorrow, I hate installing stuff.

Quote:
If still does not work Type cmd in search, then right click and run as administrator. In the cmd type sfc /scannow.

Why do I feel like I'm toasted even though the outcome seemed reassuring
My System SpecsSystem Spec
.

15 Jun 2010   #4
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

We will solve the problem. SFC just tested for corruption, lag seems to point to memory.
My System SpecsSystem Spec
16 Jun 2010   #5
no one

windows 7
 
 

Ok, I tried the memtest86 thing out. It gave me 3 errors (may have more but I shut it down when it reach 112%), I can only take screen shot of the last two since I accidentally press ok before I can see what the first's about:




So um... now what?
My System SpecsSystem Spec
16 Jun 2010   #6
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Sounds like bad ram to me. You may want to test, each stick and replace.

http://www.ghacks.net/2007/07/26/how...am-for-errors/

It would be my suggestion, if one stick is bad, replace them all. Ram is cheap and unless you have a perfect match especially with frequency, problems can occur
My System SpecsSystem Spec
16 Jun 2010   #7
no one

windows 7
 
 

So it was the hardware's fault? That's odd, I have been using the same RAM for almost 2 years now and only now it cause me trouble?
My System SpecsSystem Spec
16 Jun 2010   #8
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Ram can go bad over time. In addition, maybe not the ram but the slots. All we know is that according to the test you have a memory problem. If you like take it again to be sure.
My System SpecsSystem Spec
16 Jun 2010   #9
no one

windows 7
 
 

Ok, I'll get my RAM checked first thing in the morning. If that don't work, I'll reinstall the whole goddamn windows

Thanks for your help, bud.
My System SpecsSystem Spec
03 Aug 2010   #10
iGSam

Windows 7
 
 

I have the same issue. In programming terms I think what happens is that for some reason windows events start to lag, i.e. no processor overload, but windows (I mean literally windows) start to react slowly.
Log off/on solves the problem, but there's much simpler solution, it works for me - just move any window, i.e. push mouse down on the window header and move. And everything start to work as normal till the next lag in a while.
Hope that helps.

If someone will find what causes this and how to fix it, please post, help others!
My System SpecsSystem Spec
Reply

 windows 7 ultimate: lag issues




Thread Tools




Similar help and support threads
Thread Forum
BCD issues in Windows 7 Ultimate x64
I need to create a new system reserved partition on drive: 0 and delete the current one from drive 1: There was a thread on this some time back, explaining WHAT to do, but it was never clearly explained HOW to do it! Could someone please explain in DETAIL step-by-step how this is done?
Installation & Setup
Windows 7 Ultimate 32bit issues with desktop freezing/ other issues
Hi all, Going to try and make this brief, "try" being the operative word here.. I have a Gateway PC running Windows 7 Ultimate 32 bit 4 gigs of ram but obviously not all useable (yet) Dual core processor Nvidia 9800GT graphics Card Corsair 650 watt PSU HT Omega Striker 7.1 Souncard..
General Discussion
RAM issues Windows 7 Ultimate 64 Bit
Hello, OS: Windows 7 Ultimate 64bit I put together a computer for the first time and I'm having bother with the RAM. I have 12GB of Corsair Vengeance DDR3 Ram installed, I am using a Gigabyte GA-X58A-UD3R Intel X58 (Socket 1366) DDR3 8 Channel Audio ATX Motherboard. The motherboard...
Hardware & Devices
DNS issues windows 7 ultimate x64
Hi everyone. I know there are a lot of windows 7 experts here and I know this has been asked in other forums but I'm still at a loss of how to fix it after numerous google searches. I'm using windows 7 ultimate x64 and basically I'm connected by wireless on an asus pce-n13 network card to a...
Network & Sharing
Windows 7 Ultimate Connectivity Issues
Hi I am new and despirately seeking answer(s) to my question I recently installed Win 7 Ultimate on my dad's laptop (Acer 4720Z Intel premium dual cpu @1.73ghz,ram 2gb,32-bit operating system) all seemed fine until I tried conecting to my wireless router(belkin n+) it asks for the password...
Network & Sharing
VISTA Ultimate to Windows 7 ultimate issues.. wit gamin
Ok, Its either gotta be that Windows have may changes in the O/S for gaming or there just could be something wrong with my computer... I DON"T GET IT. First of all, I had windows vista, CPU over clocked playing all my games with out a drama, (steam, cs, tf2, l4d, COD4) the games started without...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App