Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: cannot find command promt , need to do sfc

08 Jul 2010   #11

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Quote   Quote: Originally Posted by mamumami View Post
Quote   Quote: Originally Posted by gregrocker View Post
You need to Run as Administrator.

Type CMD in Start search box.

Rightclick on Result, click Run as Administrator.

then type "sfc /scannow" without the quotes. Include the space.

Hope it helps.
when i type cmd in search , then command promt doesnt start, instead, the search result windows pops up, and tries to locate the file called "cmd", but does find much

Quote   Quote: Originally Posted by dre@ms View Post
Is cmd.exe available in the following location?


If yes, right click on it, run as administrator and then try sfc /scannow

As well as, you can pin cmd.exe to start or taskbar and check if it works.
nope, cmd.exe is not in c:/windows/system32,

Quote   Quote: Originally Posted by Bill2 View Post
Your system looks screwed up. Try a system restore.

If you dont have a suitable restore point, boot into the Advanced Boot menu by tapping F8 at startup, then navigate through to Repair your computer-system recovery options-command prompt. Try running sfc from there.

If that too doesnt work, other options can be discussed.
yea, i guess i have to try this, btw, cant anyone just give me the file cmd.exe
Here you go.

My System SpecsSystem Spec
08 Jul 2010   #12

windows 7 ultimate

thank for the support man, but i have windows 7 ultimate 32bit, so this file didnt work with mine, , im just going to install a fresh copy of windows all over.
My System SpecsSystem Spec
08 Jul 2010   #13


just in case u need it..copy of cmd for the win version u use..
My System SpecsSystem Spec

09 Jul 2010   #14

windows 7 ultimate

Quote   Quote: Originally Posted by dre@ms View Post
just in case u need it..copy of cmd for the win version u use..
just to let you guys know, this file worked great, im current doing the scan. maybe i wont have to reinstall afterall
My System SpecsSystem Spec
09 Jul 2010   #15


Whoa!!! Lucky you browsed this forum to know any updates. If not, you would have end up in a re-install. And glad it worked for you.
My System SpecsSystem Spec

 cannot find command promt , need to do sfc

Thread Tools

Similar help and support threads
Thread Forum
How can I find Windows 7 MyDocuments from command prompt?
Windows 7 will not start and I have been through the various repair and system restore processes with no success. Before doing a recovery, I have some files I would like to retrieve from the MyDocuments folder (pics, etc) but cannot find the directory from the command prompt. I have already...
BSOD Help and Support
find command no longer works on my win 7 machine
We have a script that installs an application on a user's box. It can run on XP, Vista, Win 7.... So it uses the ver command and find to figure out what the os is. It used to run on my win 7 box. It no longer does. The find command now gets an error. I tried substituting findstr and it...
General Discussion
Find Command, shading a Table
I have always loved the FIND command when working with rosters of names on a table for scheduling. This command still works in Office 2010 but I can't shade EVERY table box for the name I've found. AS an exam0ple, if I have "Susie" scheduled for an activity 9 times on the same table in random...
Microsoft Office
Network Password promt. doesn't want to fo away!!!
When I send and receive my mail there comes a box up and asks me the whole time for a password and then i have to type it in all the time. is there anyway I can disable this please, I have tried the registry edit trick but that didn't solved it. Thanks, hope someone can help me on this one...
Browsers & Mail
find command doesn't work
If I use the "find" command to search for a word in a Word document, it doesn't work. It comes up with "Word has finished searching the document. The search item was not found." Anyone know why this happens or how I can fix it? Thanks.
Microsoft Office
USB in Command Promt
How do I make my USB show up in command prompt? When I type diskpart then list disk the only thing that shows up is my hard drive, and my usb show up in my computer.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App