Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird RAM usage

18 Jul 2010   #11
Petey7

Windows 7 Professional SP1 64-bit
 
 

svchost.exe - Wikipedia, the free encyclopedia

Quote:
In the Windows NT family of operating systems, svchost.exe is a process and its associated image (executable file) for hosting services. These services are contained within dynamically-linked libraries (DLLs).
Basically, one svchost=~ten processes. Apparently, storing many services in one process is better than giving each one its own process. I'm not fully informed on why, but I think the OSs designers are, so I accept it as true.

Seems like a stupid question to ask, but you do check to make sure task manager still shows 4gigs of RAM, right?This is the only thing I can think of at the moment, but this seems like a serious issue so I'm going to look around and see if I can find anything out about this issue.


My System SpecsSystem Spec
.
18 Jul 2010   #12
Petey7

Windows 7 Professional SP1 64-bit
 
 

What anti-virus do you use? I couldn't see a process I recognized as one.
My System SpecsSystem Spec
18 Jul 2010   #13
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by mickey megabyte;850237
are you sure??? you have the 'show processes from all users' box ticked?

here's mine:
Thanks mickey that did it. I'm showing 11now for a total of 216,000K
52processes> CP Usage 0%. Physical memory 28%

I didn't add up astanar's it just looked like a lot.

My logic is that if you can shut down un-nessary start-ups, it should calm down your processes....Yes?....No?

EDIT:
I just finished counting the OP's processes, and it comes in under 156,000K so I'm probably wrong.
My System SpecsSystem Spec
.

18 Jul 2010   #14
mickey megabyte

ultimate 64 sp1
 
 

a lot of people would say not to touch your services - something may not work six months down the line, and you'll be scratching your head as to why.

personally, i can't stop myself, i've been a heavy tweaker for many years now, and i'm addicted.
My System SpecsSystem Spec
18 Jul 2010   #15
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by mickey megabyte View Post
a lot of people would say not to touch your services - something may not work six months down the line, and you'll be scratching your head as to why.

personally, i can't stop myself, i've been a heavy tweaker for many years now, and i'm addicted.
After Patch tues. the 13th I brought my XP box help and support back from a HCP rename. I did have reminder's though.
My System SpecsSystem Spec
18 Jul 2010   #16
astanar

windows 7 64
 
 

yea i mean you added all of them for 156 000k and i've got 4 gigs..something is wrong there. As for the anti virus I had AVG but turned it off to see if it was what was affecting my machine...turns out it wasnt.
My System SpecsSystem Spec
18 Jul 2010   #17
Petey7

Windows 7 Professional SP1 64-bit
 
 

Anak, if you disable automatic startup of unnecessary programs, you computer will start-up faster, have less RAM and CPU usage and be less annoyign overall.

astanar, all I can figure is that you have a virus causing the issue. I have looked and looked online for a solution and cannot even find someone with the same issue. Some people report certain programs starting multiple processes that aren't supposed to, and some report programs with memory leaks. I can find nothing like what you have shown us. Try opening up sysconfig, going to the startup tab, and look for anything that has a weird name or is a program you don't remember installing. Sometimes viruses have something in here that can be deselected. Uncheck that item, then restart. If I am right, then that should solve the issue. You will then have to find out what virus it is and remove it. If you are unsure about one or more of the programs you find in the startup tab, post the name of it here and will tell you if you can turn it off or not.

If you can't find anything, and you have a fully functioning AV, then I will begin my search again from where I left off.
My System SpecsSystem Spec
18 Jul 2010   #18
astanar

windows 7 64
 
 

thank you all for your help. I will post back once I get home in about 2h with more info on my system.
My System SpecsSystem Spec
19 Jul 2010   #19
astanar

windows 7 64
 
 

theres nothing in my startup that looks suspicious.. Did full scans with avg/spyboy/ccleaner and nothing came up. Anyone know of another good free antivirus software?
My System SpecsSystem Spec
19 Jul 2010   #20
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

SUPERAntiSpyware.com | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!

Malwarebytes

Are the two I use, usually malwarebytes.........Both free editions are good for x64

Edit:

Apologies, those are cleaners, I run Micrsoft Security Essentials (MSE), and It's already caught some trojans for me.

Avast, and avira are good.

Here's the MS compatability page:
http://www.microsoft.com/windows/ant...windows-7.aspx

Some have free editions, some not.

The only one's I've heard of that had less than stellar results would be, Mc Afee, AVG, and Zone alarm....YMMV.
My System SpecsSystem Spec
Reply

 Weird RAM usage




Thread Tools




Similar help and support threads
Thread Forum
Frequent unresponsiveness, 100% hardware disk usage, 0% software usage
Every 10-40 minutes, the application I'm currently working in becomes unresponsive, and after a minute or two, the window turns white, notifying me that it's not responding. This unresponsiveness quickly spreads to other open processes, rendering them frozen as well. I can still use the mouse, and...
Performance & Maintenance
Really weird 100% CPU usage issue by no particular process
Hi there! As you will see, English is not my first language (by far :p) Some days ago I noticed after a couple of minutes I start mi PC, my CPU usage goes to a constant 100% , so I checked for viruses and such but MSE gave me nothing and neither Malwarebytes. Here's the weird thing, I checked...
Performance & Maintenance
System Restore - Current usage exceeds Max Usage
In system protection, the current usage is at 405GB while max usage is defined at 279GB (30%). 1) How this can happen ? ,and 2) How can I set the Max Usage to be kept?
Backup and Restore
Weird system error after weird BSOD
Hello, Currently I have a big problem with my Computer, i can't run Windows in normal mode, and currently using Safe Mode I will describe the problem and Windows_NT6_BSOD_jcgriff2.zip DESCRIPTION My computer have some BSOD a few days before, but it's rare and after it restarts, Windows...
BSOD Help and Support
Weird RAM Usage
Hey guys, First of all, I have 2 Gbytes of RAM. In the past days, RAM usage on my PC was normal like 600-700mb at idle, 800-1500mb when used. Since yesterday, RAM usage became weird, like MSE v2 consuming like 70mb (see attached screenshot), Emsisoft Anti-Malware at around 30mb (before it was...
General Discussion
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App