Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird RAM usage

19 Jul 2010   #21
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

And astanar it would help if you could fill out your System Spec's. It does help.
We are talking 'bout your Internet experience, and we don't know what browser your using

If your unsure of what's inside the Box you can use these to find out:

Belarc Advisor - Free Personal PC Audit

Speccy - System Information - Free Download


My System SpecsSystem Spec
.
19 Jul 2010   #22
astanar

windows 7 64
 
 

hm yes that would be good idea

phenom II x4 955
4gig dual channel DDR3 7 7 7 20
M4A79XTD EVO motherboard
ati 4870 1gig
500gig raid 0
sb x-fi extreme audio
My System SpecsSystem Spec
19 Jul 2010   #23
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Not here in a post. Do this.....
  • Click on your name in the upper left corner of the post
  • Click on "View public profile"
  • To the far right of "Visitor messages"
  • Click on System Specs
  • Click on the pencil to edit
You've done it before, and we still don't know your browser.
My System SpecsSystem Spec
.

19 Jul 2010   #24
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

astanar I must apologize for my lack of manners, you being new here an all.
So let me set that straight!

Hi! astanar, welcome to W7F

You arenít the only one having problems:
memory leak on specific websites - Google Chrome Help

Can you check to see what version of Chrome you are running?
Is it 4.x. (beta), try upgrading to the newer 4.0.249.89 (38071)

This site reports his never upgraded automatically:
http://www.1stbyte.com/2010/02/11/google-chrome-slow-and-laggy/

Make sure Chrome is completely gone from your system before you upgrade or re-install your present version.

Watch your add-ons. Don't let them sit there, if you arn't using 'em get rid of 'em.

Disable user statistics.

Oh.....And thanks for fillin' out your system specs....
My System SpecsSystem Spec
19 Jul 2010   #25
astanar

windows 7 64
 
 

hey, thanks for the info on chrome! I have chrome 5.0.375.99. Also I have no add-ons at all.
My System SpecsSystem Spec
19 Jul 2010   #26
Petey7

Windows 7 Professional SP1 64-bit
 
 

I'll agree that chrome does have a mem leak issue from time to time, including the 5.0 versions, but you can still see the memory being used by it in task manager. I didn't think about this til now, but sometimes RAM is given to the memory card and other devices. I wonder is this is where some of it is going. I still don't think it should be 95% though. I must admit defeat on this one. I have no clue what could be causing your issue.
My System SpecsSystem Spec
19 Jul 2010   #27
astanar

windows 7 64
 
 

When it shows 95% and I try to move windows around it is slow and sometimes will have lag. And if it was a chrome memory leak it would show on the chrome proccess no?
My System SpecsSystem Spec
20 Jul 2010   #28
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by Petey7 View Post
I'll agree that chrome does have a mem leak issue from time to time, including the 5.0 versions, but you can still see the memory being used by it in task manager. I didn't think about this til now, but sometimes RAM is given to the memory card and other devices. I wonder is this is where some of it is going. I still don't think it should be 95% though. I must admit defeat on this one. I have no clue what could be causing your issue.
Thank you Petey7 for giving me a different approach.

Quote   Quote: Originally Posted by astanar View Post
When it shows 95% and I try to move windows around it is slow and sometimes will have lag. And if it was a chrome memory leak it would show on the chrome process no?
Yes. Memory leak - Wikipedia, the free encyclopedia

~~~ ~~~ ~~~

As I have been reserching I keep running into references that point to outdated drivers as a cause for the slowdowns (no matter what browser).

This link is, but one example: Windows 7 High ram usage after some time Any program that is poorly written can leak.

Have you ever used the Reliability Monitor? This link explains it in more detail. The part that stood out for me was when he described his slowdowns, and how it helped him figure out that his flash player needed updating. It will also show you how to use event viewer.
http://windowssecrets.com/comp/100304/

There is also a link here at W7F:
What's your Reliability index score?

Some other thought's..........

Do you keep your PC on continuously? If you do your not refreshing the memory sticks.

I hesitate to show this link because my web of trust shows a blue question mark. I did not get any red flags, but it does offer a work around:
Memory Hog Chrome Gets Slower and Slower: A Workaround

I'm using Clear mem (A MicroSoft product) on my XP machine It does a good job there, it's supposed to be good for all flavors of windows, but you can't find at their download center any more.
I do have a link though, for it, but I would hesitate to use it because everything is so different now.

Which brings me to paging file, and cache.
How do you have them set?

Do you periodically clean out your Temp files?

Now....I think I'm coming close to how Petey7 felt.........Later.......
My System SpecsSystem Spec
Reply

 Weird RAM usage




Thread Tools




Similar help and support threads
Thread Forum
Frequent unresponsiveness, 100% hardware disk usage, 0% software usage
Every 10-40 minutes, the application I'm currently working in becomes unresponsive, and after a minute or two, the window turns white, notifying me that it's not responding. This unresponsiveness quickly spreads to other open processes, rendering them frozen as well. I can still use the mouse, and...
Performance & Maintenance
Really weird 100% CPU usage issue by no particular process
Hi there! As you will see, English is not my first language (by far :p) Some days ago I noticed after a couple of minutes I start mi PC, my CPU usage goes to a constant 100% , so I checked for viruses and such but MSE gave me nothing and neither Malwarebytes. Here's the weird thing, I checked...
Performance & Maintenance
System Restore - Current usage exceeds Max Usage
In system protection, the current usage is at 405GB while max usage is defined at 279GB (30%). 1) How this can happen ? ,and 2) How can I set the Max Usage to be kept?
Backup and Restore
Weird system error after weird BSOD
Hello, Currently I have a big problem with my Computer, i can't run Windows in normal mode, and currently using Safe Mode I will describe the problem and Windows_NT6_BSOD_jcgriff2.zip DESCRIPTION My computer have some BSOD a few days before, but it's rare and after it restarts, Windows...
BSOD Help and Support
Weird RAM Usage
Hey guys, First of all, I have 2 Gbytes of RAM. In the past days, RAM usage on my PC was normal like 600-700mb at idle, 800-1500mb when used. Since yesterday, RAM usage became weird, like MSE v2 consuming like 70mb (see attached screenshot), Emsisoft Anti-Malware at around 30mb (before it was...
General Discussion
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App