Windows 7 Forums

Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: ppcit
Forum: Hardware & Devices 23 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
Slartybart, i already did the power off and...

Slartybart, i already did the power off and disconnect thing, still no luck but thanks
Forum: Hardware & Devices 23 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
well if that's the case, i'll try to go to the...

well if that's the case, i'll try to go to the pro..
thank you guys for helping
Forum: Hardware & Devices 23 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
i dont think it worked. is there anything else i...

i dont think it worked. is there anything else i could try? 302904

302905

if I go to professional, is it still possible to get my data back?
Forum: Hardware & Devices 20 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
Than you guys for replying Hi jumanji, The...

Than you guys for replying

Hi jumanji,
The error was occured long after the partition.
I think it started with bad sector, so everytime I opened one of the partitions, my windows explorer froze...
Forum: Hardware & Devices 17 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
thank you i'll give it a try :)

thank you
i'll give it a try :)
Forum: Hardware & Devices 16 Jan 2014
Replies: 14
Views: 18,395
Posted By ppcit
i/o device error external hard drive please help me anyone

can anyone please help me? I divided 1TB WB Element to 4 part but they're not showing up on 'my computer' but i can safely remove the hardware, still the partition doesn't show up as usual just...
Showing results 1 to 6 of 6

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App