Windows 7 Forums

Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: AllSystemsDown
Forum: Performance & Maintenance 03 Mar 2010
Replies: 9
Views: 10,306
Posted By AllSystemsDown
Wow...that's a lot of dust! I think I will take...

Wow...that's a lot of dust! I think I will take mine apart and give it a more thorough cleaning. I did check, and there is a new BIOS update from version A09 to A10 and that seems to be helping the...
Forum: Performance & Maintenance 02 Mar 2010
Replies: 9
Views: 10,306
Posted By AllSystemsDown
Well, I cleaned the fan area out with some...

Well, I cleaned the fan area out with some compressed air and it actually doesn't seem to be running as hot anymore. It's amazing how just a little dust makes quite an impact.

For the connectivity...
Forum: Performance & Maintenance 11 Feb 2010
Replies: 9
Views: 10,306
Posted By AllSystemsDown
Thank you, I'll try blowing out the fan area to...

Thank you, I'll try blowing out the fan area to see if that works. I've previously tried updating the drivers and the BIOS but those didn't fix the issue which brought me to these forums.

I'm...
Forum: Performance & Maintenance 08 Feb 2010
Replies: 9
Views: 10,306
Posted By AllSystemsDown
Latitude D820 - Running Very Hot

Hey everyone, I absolutely love Windows 7, but...

I've noticed two issues going on with my laptop that didn't happen with XP or Vista Ultimate. I've checked the forums and couldn't really find a...
Showing results 1 to 4 of 4

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App