Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Install error 1920 about winsxs merge modules

02 Sep 2010   #1

Windows 7 Professional x64
Install error 1920 about winsxs merge modules

Hi all,

When I try to insltall my msi package I get an error only in vista and 7. "Error 1920. Service ... (...) failed to start. Veryfy that you have sufficent privileges to start system services"

I get this error in vista or 7 if I build my setup with C++ 9 CRT Winsxs MSM merge module

If I use C and C++ 7 runtime libraries it doesn't problem
but with this I must build my exe with old versions of Ms Visual Studio.

Does anyone have idea how can I cope with that?

My System SpecsSystem Spec
03 Sep 2010   #2

Windows 7 Professional x64

Also, if I build my setup with C++ 9 CRT Winsxs MSM merge module and try it on xp it doesn't give error too. The problem may, during setup .dll files in merge module aren't written to winsxs.
My System SpecsSystem Spec

 Install error 1920 about winsxs merge modules

Thread Tools

Similar help and support threads
Thread Forum
Error 126: cannot start service - Windows Modules Installer
Hi All, I've been having a problem installing Windows updates and certain other software packages lately. It seems the Windows Module Installer Module cannot be started, as below - so I've taken the liberty to push diagnostics a bit further, all below as well. Apologies for the French, let me...
Windows Updates & Activation
Unable to install update kb2756921, problem with winsxs(corrupted)
I try to install update kb2756921 and can't do it. (from wu, manual, use kb947821) I have an error with .net 3.5.1 component and winsxs I start explore a problem and get this: after trying to update screenshot wu in attach (error 80073712) after sfc working (sorry, russian windows) ...
Windows Updates & Activation
Win 7 Install Size DOUBLES after SP1 & Sec. Updates?! Winsxs!!!!
Hello, I'm new here AND new to Windows 7. (I've been one of those XP hold-outs.) Here's an as-brief-as-possible description of my dilemma: I've just installed Windows 7 Ultimate Retail. The initial install size came in around 7.50 gb or so of data. (That's cool. Bigger than what I'm...
Performance & Maintenance
VMware Player 4 & Workstation 8 Error 1920 or MSI failed at install
Hi all I have been trying for the past couple of hours to install either VMware Player 4 or Workstation 8 and keep getting the same error on both of them. I've tried some of the stuff on the VMware website like regedit and deleted the temp folder and that but it doesn't seem to work for me. ...
Windows Modules Installer Error 1017
I can't start the Windows Modules Installer service. I'm getting an error saying: Error 1017: The system has attempted to load or restore a file into the registry, but the specified file is not in a registry file format. Could someone please help me get this started? Win7 Professional The...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:00.
Twitter Facebook Google+