Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Command Prompt - Path messed up

16 Sep 2010   #11
mjf

Windows 7x64 Home Premium SP1
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
I'd try with this:

GnuWin32 Packages

There should be setup info with each package.
I used to run some of the linux command ports. Many of the stand-alone exes will work from a regular command prompt but a lot of the scripting and other gizmos require running bash or another shell. You probably need to set up the bin folder in your path etc..

edit: ok I think I misread what mjf meant. He's saying even set up properly the linux stuff may not work in Vista or later... nevermind. :)
Not quite, If linux commands are important to the OP give MilesAhead's suggestions a go. For me personally they aren't that important in the Windows command shell.


My System SpecsSystem Spec
.
17 Sep 2010   #12
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

Quote   Quote: Originally Posted by cosmic50 View Post
I set it to the default which was given above. Here is the current path:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SystemRoot%\System32\WindowsPowerShel l\v1.0\

Here is a screenshot of the command prompt:



And yes, I photo-shopped out my user directory for privacy reasons. The black area should be \myAccountUsername
In the command prompt window type: set <enter> and post it here.

The “pwd” and the “ls” are Unix commands and are not part of Windows 7. You may have installed an IX command package and that added the software’s folder to your path.

Have you installed some IX package? If so what is the path to that software?
My System SpecsSystem Spec
18 Sep 2010   #13
cosmic50

Windows 7 Home Premium 64bit
 
 

I never intentionally installed something to do that. the only thing I can think of is virtualbox, which I ran ubuntu out of.
My System SpecsSystem Spec
.

18 Sep 2010   #14
MilesAhead

Windows 7 32 bit
 
 

Quote   Quote: Originally Posted by cosmic50 View Post
I never intentionally installed something to do that. the only thing I can think of is virtualbox, which I ran ubuntu out of.
So you put Ubuntu in a VM, then later removed Ubuntu, the VM or both?
My System SpecsSystem Spec
Reply

 Command Prompt - Path messed up




Thread Tools




Similar help and support threads
Thread Forum
Command Prompt command <ipconfig> not working
when I open up my command prompt and type 'ipconfig' without the ' and press enter it returns the line: 'ipconfig' is nto recognized as an internal or external command, operable program, or batch file I am trying to find out the information I need in order to set up a static IP Address for port...
Network & Sharing
Command Prompt: Repeat del command continuosly
Hi All, I'm running a program that parses .csv files and then changes them into ._OK files. This process takes longer when there are a large number of *.OK files in the folder where the files being converted are located. To remedy this I occasionally manually run this command: del *._OK ...
General Discussion
"Copy" command in command prompt generates 0x1a artifact?
Hello Everybody! I don't know if this is a real issue, or just one of those "What the . . . .!!" situations. You judge. Situation: I was working on a batch file that combines two .txt (ASCII?) files created in Notepad to create a composite file, and I noticed something really interesting. ...
Software
Windows Command Prompt says The System Cannot find the Path Specified
Whenever I launch the Command Prompt, It says "The system cannot find the path specified" under the Copyright Label on the Command Line. Can someone please tell me how to fix this?
General Discussion
Run administrative command prompt from command prompt
Ok So I got myself into a unique bind here. I was trying to install some custom system files (for a theme) and I did it wrong and now I cant open explorer.exe . I dont want to goto a backup because this is a easy fix. (in my view). So I need to know how to run command prompt with administrative...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App