Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: vb6 app does not work on win 7

26 Oct 2010   #31
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Quote   Quote: Originally Posted by Zeplash View Post
I think I'm done for the day..Still got some programming to do....MUCH L8A

Lol I was just teasing :P go code lol I know there is much work to do in a programs life....


My System SpecsSystem Spec
.
26 Oct 2010   #32
whiteadi

Windows 7 Entreprise x64
 
 

Quote   Quote: Originally Posted by mckillwashere View Post
Zeplash,
go grab some coffee you deserve a quick break.

whiteadi:

I need you to run ccleaner remove all temp files, clean the regristry and make sure there are no unneeded files in the startup. Place a shortcut to Event Viewer on your desktop as well as the installer. Check EV(event viewer) before you run the install so you know about were you stand. run the installer and put all of the new errors if any in a text doc for me please :)
Hi, I don't know if there is a point in running any registry cleaner app on a brand new PC build, I got this one THIS morning, fresh install on all stuff, win 7 and all app on it. To be honest I suggested this to the it ops guy but he was laughing and I kind of agree with him. the event viewer shows nothing new when run the app. And the app just gives the err 732 cannot load control ... a user control created by some dev, it is the initial control, that yes it has an imagelist control in it, I checked display settings and are on 32.

And as I say only
My System SpecsSystem Spec
26 Oct 2010   #33
MilesAhead

Windows 7 32 bit
 
 

Does the error msg way what the control is? Like MyListTree.ocx not found or something?
My System SpecsSystem Spec
.

27 Oct 2010   #34
whiteadi

Windows 7 Entreprise x64
 
 

the control that could not be loaded is the first imain window tries to load and is a user control, made by some developer, that includes the search criteria, first thing that you also usually do with the app, you search :)

the control has only text fields + a button + this ImageList control, I saw there could be this kind of issues with it and the solution would be to set the display depth to 32 bit, but that is the case so ...
My System SpecsSystem Spec
27 Oct 2010   #35
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Sorry when I made that last post I was ending the end of my day :P the main reason for the ccleaner was to make sure any previous files from the app were gone but since you said it was a fresh install that wouldn't really be needed.

Have you tried running it in XP compat mode?
My System SpecsSystem Spec
27 Oct 2010   #36
whiteadi

Windows 7 Entreprise x64
 
 

Quote   Quote: Originally Posted by mckillwashere View Post
Sorry when I made that last post I was ending the end of my day :P the main reason for the ccleaner was to make sure any previous files from the app were gone but since you said it was a fresh install that wouldn't really be needed.

Have you tried running it in XP compat mode?
yes, I tried that will all sp and as an administrator also, no luck

I started to copy all dlls that I saw it is using in XP and can not find them in Win 7, I still have ...124 to go :)
My System SpecsSystem Spec
27 Oct 2010   #37
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

:P I was going to suggest recompiling the source from a win 7 machine..... But god knows how long that could/would take
My System SpecsSystem Spec
27 Oct 2010   #38
MilesAhead

Windows 7 32 bit
 
 

Quote   Quote: Originally Posted by whiteadi View Post
the control that could not be loaded is the first imain window tries to load and is a user control, made by some developer, that includes the search criteria, first thing that you also usually do with the app, you search :)

the control has only text fields + a button + this ImageList control, I saw there could be this kind of issues with it and the solution would be to set the display depth to 32 bit, but that is the case so ...
The reason I'm asking is to determine if you know the filename or have a chance of getting it. It's not easy to figure that out from previous posts. It stands to reason if the control is the core of the app and you don't have it, you can't run it. I just seems kind of nebulous when you say "a control written by some developer."
My System SpecsSystem Spec
28 Oct 2010   #39
whiteadi

Windows 7 Entreprise x64
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
Quote   Quote: Originally Posted by whiteadi View Post
the control that could not be loaded is the first imain window tries to load and is a user control, made by some developer, that includes the search criteria, first thing that you also usually do with the app, you search :)

the control has only text fields + a button + this ImageList control, I saw there could be this kind of issues with it and the solution would be to set the display depth to 32 bit, but that is the case so ...
The reason I'm asking is to determine if you know the filename or have a chance of getting it. It's not easy to figure that out from previous posts. It stands to reason if the control is the core of the app and you don't have it, you can't run it. I just seems kind of nebulous when you say "a control written by some developer."
I see your point, and let me be more clear: the control is there and is bundled in the exe, is not outside in some ocx, I mean for half the installations is working.

And when I installed vb6 on one of the pc where was not working it start working, that, in my eyes, means there is some dll missing that comes with vb6.

I was hoping to have it also installed with runtime but not that lucky.

I also copied some they say are not present into win 7:
Support Statement for Visual Basic 6.0 on Windows Vista and Windows Server 2008 (Supported Runtime Files to Distribute with Your Application)

Still no luck, I have now prepared a bundle with less then a hundred of them I got from a list I made when I used Process Monitor to identify those used in XP by the app and not present in Win 7. Let see.
My System SpecsSystem Spec
28 Oct 2010   #40
MilesAhead

Windows 7 32 bit
 
 

I've only dabbled in VB6 and awhile ago. But is there a dependency checker that will track down the calls external to the app? As you say it must be some module that comes with VB6 install that provides some functions. Seems like there should be a way to detect external calls. If it's not in the run-time then you would think it would attempt to load a dll or something.
My System SpecsSystem Spec
Reply

 vb6 app does not work on win 7




Thread Tools




Similar help and support threads
Thread Forum
Keyboards no longer work on Windows 7, but the function keys work
Hi everyone, this is a really puzzling problem that I've never seen before or even heard of. Basically, my battery backup for my PC has recently conked out and there was a temporary power outage in my building. So the battery backup didn't kick in (my fault for not replacing it) and the PC was...
Hardware & Devices
Downloads Work Offline But Once Website Is Live they Dont Work
I have recently built a new website, i tried all links and they worked fine before making it live on Filezilla. I was wondering if anyone knows the reason for it or even better the fix for the solution. The files are DWG. which is a version of CAD. PDF's, Jpegs, ect. all work except DWG's. ...
General Discussion
acer aspire 4738' s bluetooth doesn't work but wifi work?
Acer aspire's Bluetooth doesn't work since I bought it I've installed drivers too but it doesn't work what should I do. In its specs it has Bluetooth . But there is no Bluetooth device found in device manager how to repair this. Please HELP!!
Hardware & Devices
Windows won't boot, startup won't work, safe mode dosent work
Today my laptop was working fine but then I shut it down and turned it on again, when I turned it back on, after the Starting Windows and windows logo disappear I get a blue screen for half a second then my computer try's to reboot, I've tried to use startup reapir but u just have a crusor with a...
General Discussion
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App