Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't install Solidworks 2010

27 Nov 2010   #1

Windows 7 Professional 32 bit
Can't install Solidworks 2010

I recently upgraded to Windows 7 from Vista. I couldn't access Solidworks after upgrading despite clicking on the icon, I have since deleted all SW files and re-downloaded it.
After downloading SW 2010 I'm unable to install after this message keeps appearing:

"The drive containing the Temp directory (D:\) is low on disk space (271 MB after installations).

Installations may fail with less than 393 MB of free space".

I changed the 'Installation location' to the C drive but still keep getting the same message.


Also, since upgrading, my default save location switched to the D (smaller) drive. After downloading 1GB+ worth of data onto the D drive I manually switched the save location on my browser settings to my C drive. I've tried deleting some of the recent files, which are dated after the upgrade but unable to do for some after needing "Permission", of which I am the administrator.
Which type of files am I able to delete?

My System SpecsSystem Spec
27 Nov 2010   #2

Windows 7 Enterprise

Hi Maoist, welcome to Sevenforums.

Is your TEMP or TMP evironment variables set to D:\ somewhere?
This is the location where most installers will extract the files to before installing.
You may need to either need to clear this out to free up some space, or change it to another drive.
My System SpecsSystem Spec
27 Nov 2010   #3

Windows 7 Professional 32 bit

Hi Xarden, thanks for the welcome.

All my Temp and TMP environment variables are set to the D drive along with other system variables. I've tried to move then delete the folder within the D drive but it won't allow me to delete it all. Also, there was originally 3+ Gb in there but what I deleted wasn't even close to that.
My System SpecsSystem Spec


 Can't install Solidworks 2010

Thread Tools

Similar help and support threads
Thread Forum
Blank Installation Manager Solidworks
Hey, i have recently formatted my laptop and now i have windows 7 x64, and since i have done that, i try to instal Solidworks and the istallation manager is blank, it does not start installation.. i know that everything is ok with the program because it works on my other computer. so i think...
driver for usb safety plug for solidworks 2007
Hello i have solidworks 2007 that work with safety plug ( connect to usb). I just upgrate my OS to win 7 X 64 . the safety plug that not recםgnize by windows. how can i get a driver for that plug ?? Thank you
BSOD occurs when using Solidworks
Hi there- Please forgive me if I do this wrong - I've tried to read all the tutorials but may have missed a step. First time posting, so bear with me. :-) Disclaimers out of the way, I'm getting random BSOD's, seemingly to always to coincide with my usage of Solidworks (ver.2009). Although,...
BSOD Help and Support
After uninstalling Office 2010 beta can't install 2010 trial help
My beta expired so I uninstalled the beta. I restarted and tried to install the trial but I get this error. I read then that I was to delete the following reg entries Problem is the bottom entry is not deleteable. If I try to delete it or a subfolder or the key I get
Microsoft Office
Install Help with Solidworks
Hi I'm a student trying to install Solidworks 2008-09 on my pc that we have just put Windows 7 on but it brings up an error message saying I can't install Solidworks with a 64-bit OS. Is there any way round this? I want to keep Windows 7 running rather than going back to XP if I can help it...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:43.
Twitter Facebook