Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with 7-Zip not working . . .

26 Jun 2009   #1

Problem with 7-Zip not working . . .

Okay, here's a strange one: I installed 7-Zip (64-bit) on my machine (GA-EX58-UD5, Ci7-920, 12GB, Win.7.7232.x64) from the main administrator account. I set the executables (all 3 of them) to be run as administrator for ALL users. I set the file associations. It works perfectly within the main administrator account -- ONLY!

When I log into my own account (with full administrator privileges), files whose extensions I associated with 7-Zip are properly icon'd. I can right-click and get the context menu.

But nothing works. No decompression. Nada. Zip. (Forgive the pun.)

Anyone got any ideas?

My System SpecsSystem Spec
26 Jun 2009   #2

Windows 7 Ultimate Vista Ultimate x64

Reinstall it on your standard account.
My System SpecsSystem Spec
26 Jun 2009   #3


I tried that. Doesn't work. If I return to the administrator account and UNinstall, I can then install on my own account. And it works. But then it doesn't work on other accounts. I'm baffled.
My System SpecsSystem Spec

26 Jun 2009   #4

Windows 7 Ultimate Vista Ultimate x64

Very strange, I just tried it on my guest account and it worked fine, using build 7232 x64
My System SpecsSystem Spec
26 Jun 2009   #5

Windows 7 Professional 64-bit

Log into administrator account and uninstall 7-zip.
Change to your account and reinstall the program.

Its a permissions issue because you as a user cannot view or use parts of the administrator install.
My System SpecsSystem Spec
26 Jun 2009   #6


I finally backed up several restore points ago, losing only a half a dozen things having been installed more recently, and started fresh. Now all appears to be well. I still don't understand what was wrong. I don't think I did anything differently -- just did it all again. Go figure.
My System SpecsSystem Spec
26 Jun 2009   #7

Win7, XP, Vista x64, Ubuntu 9.04

tried it via 32bit 7100 install without a problem
My System SpecsSystem Spec
26 Jun 2009   #8


I had installed it on previous versions of Win.7 with no problems, either. I don't know what happened. I had just downloaded the newest version of 7-Zip and installed it and all h-e-double-l broke loose.

I usually install pretty much everything in the "real" administrator account and then work from my regular user account. (I've got a second admin account as a back door, a total of 5 user accounts, and the guest account.)

Anyway, I retraced my steps to the restore point from just before I installed 7-Zip and then tried it again. Worked perfectly.

So, case closed with no explanation of why it went wrong.
My System SpecsSystem Spec
21 Dec 2009   #9


I have not as yet checked into win7 registry but for WinXP I didn't have the 7-Zip context menu items displayed but on another XP system they were there... Humm... Difference was on one computer I had the 'Send To" context menu item displayed but on the other NO. I went into the registry (I use Registrar Registry Manager by the way.. Its a very useful tool.) I did a search for Send To... I found:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To
I made a backup of the ContextMenuHandlers and the deleted the Send To. Because this was a change to the local machine, I rebooted and Vola,,, 7-Zip Context Menue items appeared. So Now if I selected a few files then right-click and select 7-zip I can select from the context menue to add to "xxx".zip or .7z or to have them compressed and emailed.

Perhaps others that are experience this missing 7-zip context menu items should first see if they have the Send To context menues then check the registry, back it up before making changes.

Another person figured out the problem using an explorer shell extension utility program called Fast Explorer 2008, which allows one to view all the active and inactive context menu handlers for all explorer shell extensions, and to selectively enable/disable individual context menu handlers.

Merry Christmas Seven Forums
My System SpecsSystem Spec

 Problem with 7-Zip not working . . .

Thread Tools

Similar help and support threads
Thread Forum
4 Port USB Problem Stopped Working
Hi Everyone I have recently discovered that my 4 USB port splitter has stopped working suddenly. It is about 4 years old and I am pretty sure it only supports USB devices up to 2.0 I am not exactly sure what caused it to stop working suddenly...
Hardware & Devices
Problem with Adobe Flash not working.
I have Win 7 and running Internet Explorer latest version. I have Flash 13 installed but when I go to a site that needs to use Flash Player, I get message that Flash Player is needed to operate this site. I have tried everything I know to correct this problem but nothing works. I think I...
Problem with USB ports working
I am new to this site so I may not ask the right questions. Basically I have a Compaq Presario CQ62 Laptop. I've had it for probably 4-5 years. I have put various softwares on it. At some point, I don't know when, all 3 USB ports started screwing up. The two on the left side don't work. The...
Hardware & Devices
Stereo Mix Problem. It's Not Working At All
I'm having difficulty getting Stereo Mix to work at all. I have searched a ton on Google and these boards, but nothing helped me. Specs: Windows 7 x64 Gigabyte GA-Z77-D3H mobo VIA high definition audio driver which includes Stereo Mix Intel Display Audio for HDMI (I believe) HDMI from...
Sound & Audio
Internet not working and ipconfig problem
Hi windows 7 said I am connected to the Internet but I have limited activity. I've tried tons of things and nothing seemed to work. I even tried to reset winsock, didn't work. I did tons of things and nothing so I decided to create a help thread to see if anyone can assist me. Help is needed and...
Network & Sharing
problem getting old printer working
Hi, My wife just got a gateway netbook with the windows 7 starter edition, and I dug out an old printer from about 2003, Dell A940 printer/scanner. I downloaded the necessary drivers I think. It'll scan but it will not print. Word reccognizes the printer by the way, but if I try to print I get...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App