Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Windows cannot find ''." Error.

23 Mar 2011   #1

Windows 7 Pro x64
"Windows cannot find ''." Error.

Hi All,

First time post, I hope that I have not repeated a topic or placed this in the wrong forum.

First some background:
Windows 7 Professional x64 - not a new install. Computer purchased in fall of 2009.
I have two types of accounts on my computer:
1. Admin account (only used for administrative purposes)
2. User accounts (limited users for general use)
I always log in and use the computer as a "user".

Whenever I need to run something that requires admin privileges I have to enter the admin password-and I like it this way.

Today I got the following message when I tried to run something that required privileges:

[after pressing right-click Computer, Manage]
Windows cannot find ''. Make sure you typed the name correctly, and then try again.

This occurs for any executable that I try and run with privileges. This is not what I used to seeing. These errors do not occur on the admin account.

Attempts to fix:
1. After a search online I came across some suggestions that the PATH variable was too long, so I shortened it to be shorter than 260 characters. After rebooting the machine there was no change.

2. I added my "user" to the administrators group and tried again - no errors at all with the "user" account now. When I removed "user" from the administrators group the errors resumed.

I have also tried another regular "user" account and the errors still occur.

The next step will be a system restore, but before I do that I would like to know if anyone has seen this behavior before, and if you were able to fix it?

Thanks for your time!


My System SpecsSystem Spec
03 Apr 2011   #2

Windows 7 Pro x64

I have an answer!

Since UAC was not working I thought I would disable so I could at least use my machine. Risky, but hey, I can be careful.
Logged in under admin account and tried to change the UAC settings but the dialogue box with the UAC slider would not open (Control Panel, User Accounts, Change User Account Control Settings).
The other thing that was happening was every time I logged in under the admin account it would warn me that my profile could not be loaded.

So as it turns out the reason for UAC not finding any executable on my system was that my admin account had problems or was damaged.
The fix:
I created a new admin account. Logged in as regular user and did an operation that required me to elevate privileges. The new admin account appeared in the list of accounts to authenticate, I entered the password and it worked!
So for anyone else who runs across this problem, obscure though it may be, ensure that your admin account is not damaged and if it is simply create a new one.

Also posted at "Windows cannot find ''." Error. UAC Problem
My System SpecsSystem Spec
04 Dec 2015   #3
JAB Creations

Windows 7 64 Bit

Just found out it was because Windows Explorer was still set to Quick Access in the Folder Options. In Windows Explorer in Windows 10 click on View, Options (far right) and the very first option you see in the General tab "Open File Explorer to:" and set to "This PC". You don't even need to sign off the Windows user account to fix this issue.
My System SpecsSystem Spec


 "Windows cannot find ''." Error.

Thread Tools

Similar help and support threads
Thread Forum
Command Prompt Error: "Cannot find directory "C:\Users\..."
Hello, I have basic knowledge of the command terminal, in that I only know how to navigate through directories. Currently I am trying to execute the following: java jar MRTBatch.jar d input_directory p parameter_directory\input_parameter_file o parameter_file_directory I have...
General Discussion
A "non-existent" Windows update ("KB3024777") even Google can't find
I'm not sure what this is in Windows Update , but how is it possible to have no results in Google on this KB that's in Windows Update? I also clicked on the "more information" for the Microsoft Knowledge Base, but nothing came up there either.
Windows Updates & Activation
Cant find "System Image" of 36 GB but its shows on "Manage Disc Space"
Dear Experts, I have created windows image on Drive F: but delete it after some time manually due to some space prob. But while backup shows about 40 GB only few GB space got free after deletion. When i try to again take the the backup using windows 7 backup & restore option, its still shows 35...
Backup and Restore
Windows cannot find "...". make sure you typed... error
Hi, I'm receiving this error when executing some executables: "Windows cannot find "". Make sure you typed the name correctly, and then try again". I may understand receiving such error if I were executing a "bad" shortcut, but in this case, I'm directly launching it from windows explorer....
General Discussion
"Windows cannot find program" Error
Hi guys, I have really enjoyed utilising this site over the last 6 months and thought I better sign up seeing I need your help this time, as I cannot find a solution on my own! I have been using this particular program since 2005, on XP, Vista and now Seven without a problem up until a few weeks...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:03.
Twitter Facebook Google+