Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Kodak Easyshare

10 Apr 2011   #11

Windows 7 Professional 32 bit


Right I've followed the suggestions above and re-loaded Easyshare, having first:
- run a virus scan and antimalware scan
- uninstalled Easyshare and then run the Clear utility
- rebooted and installed the latest version from the Kodak site

Sadly the behaviour is exactly the same. Once I've added approx 8-10 images to Easyshare, if I then browse those images within Easyshare, then it stops with the same error message as before.

Very clever of you, Anak to guess that I'm using a P850 photoframe. Not sure how you did that. I've completed my system specs as requested. Hope that you can see them from my profile.

Thanks for all your help so far. Do you think this software actually works under Win 7, or are we flogging a dead horse here?

My System SpecsSystem Spec
11 Apr 2011   #12

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by billingd View Post
Do you think this software actually works under Win 7, or are we flogging a dead horse here?
According to this Version 8.3 is good:
KODAK EASYSHARE Software - WINDOWS Operating Systems

However, there is a Firmware File download, which is said to improve performance (unless you have already downloaded, of course):
KODAK EASYSHARE P750/P850 Digital Frame Firmware
My System SpecsSystem Spec
11 Apr 2011   #13

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

Your welcome, we are not puttin' her out to pasture yet!

As far as picking the P-850, I could say it was my powers of keen observation Watson, but it was just a lucky guess.

System Specs are better, but I would like to know the Model# of the Dell, and whether or not your network is wired or wireless.
Is the PhotoFrame wired or wireless or USB?

Are these Images created by an easyshare camera?

I am beginning to think this could be a problem with the windows installer. Even though you may not have had problems with other installations before or have you?

#1.) I would like you to run Disk Check
Follow instructions from step #4 then go to step #8.
Then go to step #9 to start the diagnostic.

If the HDD is not in use it will proceed to run as in step #10.
If the HDD is in use you will see a message as in step #11 Follow prompts in step #11 to finish.

In either case:
Once the Disk Check scan starts, DO NOT STOP the scan to prevent possible damage to the data on your hard drive.
#2.) Then do a SFC /SCANNOW Command - System File Checker

#3.) Are there any .NET framework programs on your machine? There should be otherwise Easyshare would bark during installation. They should be version 3.5 or higher also report back what version is listed in the far right column.

Go to: Control Panel\All Control Panel Items\Programs and Features Scroll down to where you see them listed.
Left click on the first .NET line item and a repair or un-install box should appear, choose repair it may download from MS.
Finish, then go to the next one.

#4.) Please post back after each step.

#5.) If you did not download fresh software during my instructions in post #10 Do so now, and preform another clean/clear install of the software now. You could leave out the anti-virus scans.

There are a few other items we can try, but I want to do these first.
My System SpecsSystem Spec

25 Apr 2011   #14

Windows 7 Professional 32 bit
Kodak Easyshare - terminal crapware


Sorry that I have been unable to reply sooner. I have been having some problems with my installation, which resulted in me having to reload win 7 back on my PC. Anyway back online now with a fresh 32 bit Win 7 installation (re-installed from Win 7 DVD) on a Dell Inspiron 530. I thought I would try Easyshare one more time on this new installation. It still fails in exactly the same way which is:

Download and Install latest version from Kodak site
As I don't have a Kodak camera, choose to install only Easyshare from a windows admin account
Fire up Easyshare
Add pictures from a folder to a Easyshare album (just 8 in this case)
Open Easyshare album to browse photos. Get error that Easyshare has stopped working and windows is trying to find a solution (never does of course)

Anyway, I have come to the reluctant conclusion that despite what Kodak says, Easyshare is NOT Win 7 compliant.

Software now deleted from my system and never want it to darken my door ever again
Thank you everyone (apart from Kodak) for your help with this matter

My System SpecsSystem Spec
17 Sep 2012   #15

windows 7 64bit
Re-easyshare software

Does anyone have a copy of easyshare version 8.2 or know were you can get it as you are unable to download it from Kodak.
My System SpecsSystem Spec
18 Sep 2012   #16

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by Garyas View Post
Does anyone have a copy of easyshare version 8.2 or know were you can get it as you are unable to download it from Kodak.
You could try here:
Download Kodak EasyShare Software 8.2.0 Free - The simplest way to organize, print, share, and get creative - Softpedia
My System SpecsSystem Spec

 Kodak Easyshare

Thread Tools

Similar help and support threads
Thread Forum
How do I get Kodak EasyShare to sync and transfer automatically?
I just bought a new computer system (see attached screenshot for system specs, if you need them), and installed the Kodak EasyShare software (v 5.0.2 SKU87) that came with my Z700 digital camera. It ran fine when I was using Windows XP as the OS. Now I find I have to manually sync and transfer, it...
2203 Error - Kodak Easyshare Download
Help with this 2203 error.
Anyone got a Kodak Zi8?
Hi, today I bought a Kodak Zi8 camera and I'm just wondering if it is safe to use the attached USB on a PC. I wonder because the USB slots are off the ground and therefore when I plug the camera in it has its full weight resting on what seems a quite flimsy USB connection. In the manual it is...
Chillout Room
Help w/Kodak AiO Printer
I have a laptop running Windows 7 (64 bit) and I cannot get my Kodak 5100 AiO printer to work. I have downloaded the latest software from the kodak website and downloaded the latest firmware but programs such as notepad, paint or word will not print. The only thing I can get to print is a...
Hardware & Devices
Kodak All In One
Anyone using Kodak AIO Home Center? It loads fine, creates the printer and sets it as default. The Home Center seems to work well but doesn't actually print anything, printing from applications crashed explorer and/or the application. I've tried setting it up in compatibility mode.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:52.
Twitter Facebook Google+