Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Setup execution fails with Access Denied error

21 Apr 2011   #1

Setup execution fails with Access Denied error

I have four partitions on my hard drive, viz., C, E, F and G. Partitions C and G are NTFS whereas E and F are FAT32.

I downloaded wxRuby Setup to the partition E. When I tried to execute the Setup, Windows 7 displayed an error: "Unable to execute file in the temporary directory. Setup aborted. Error 5: Access is denied"

I tried to execute it as an administrator by right-clicking and selecting "Run as Administrator". It again displays the same error.

I brought the slider level of UAC to the lowest level to turn UAC off and restarted the PC, still I am getting the same error.

I have created Windows Temp folder in the partition E by changing the Environment Variables. I did this to avoid fragmentation on the partition that contains OS. I have even changed the path of the Windows page (swap) file. I right-clicked this Temp folder to check the rights. I changed the ownership and allowed all rights, still the problem is there.

I changed the Windows Temp folder location to Windows default and restarted the machine. I get the same error when I try to execute the Setup.

Here please note that I am logging in as an Administrator. It is not a Guest account.

How to get rid of this problem?

My System SpecsSystem Spec
21 Apr 2011   #2

Windows 10 Pro/ Windows 10 Pro Insider

Try this. With explorer navigate to the drive. Right click on it and choose properties, go to the sharing tab, it will probably say not shared, either click on the share button or the advanced sharing button, in the top space type everyone, click the permissions tab and select full control, click apply, apply again and OK. the partition should be shared now.
My System SpecsSystem Spec
21 Apr 2011   #3



It is still not working. Same error persists.
My System SpecsSystem Spec

22 Apr 2011   #4

Windows 10 Pro/ Windows 10 Pro Insider

Have you gone back into properties and made sure the partition is shared and the permissions are full control?

These tutorials are for vista but work the same in Windows 7. They may help you.
Take ownership
This tutorial See option 2 Take ownership
My System SpecsSystem Spec

 Setup execution fails with Access Denied error

Thread Tools

Similar help and support threads
Thread Forum
Error : Access denied
I installed a program to test with some class mates. but after a while. I couldn't remove it because when you wanted to remove it via control pannel > Programs it will ask for a code/password to remove and it is one that I dont know. So I decided to run msconfig to turn off the service on boot....
Access denied, error 5
Hello, I'm the sole user/administrator of this computer, therefore I should have the ownership of files, folders. However file access (i.e. installation) is always denied upon double-click, only the right-click run--> as administrator works. Double-click should work, too. Any suggestions?...
System Security
Error 5: Access is denied.
Hello, I have been getting Error 5: Access denied for a few days. I cannot install new programs; this error will always just pop up. I've scanned for viruses (a lot showed up, but were cleaned. My AV is Comodo.), tried a System Restore, but all my restore points are gone except for the ones...
General Discussion
Error- Access is Denied
I hope someone out there can help,as this is my last resort. Whenever I am attempting to install anything that I have downloaded, I receive this error message. "Error-Access is Denied" // (no error number) I have scoured the internet, and have tried everything that is out there. Turning...
General Discussion
Error 5;access denied
I'm running Windows 7 x64 bit and over the last couple of days every 15-20 minutes I get an Error 5:access denied message for visual basic command line compiler. how do i fix this problem? i'm not really good with computers so the easiest way of doing this would be much appreciated.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:12.
Twitter Facebook Google+