Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error 1935 Microsoft Visual C++ Redistributable

04 Jul 2011   #1

Windows 7 Home Premium 64 bit
Error 1935 Microsoft Visual C++ Redistributable


I am trying to install Autodesk Maya, a 3D graphics development program.

The first part of the installation gets hung up when it attempts to install Microsoft Visual C++ Redistributable.

I figured I would install it separately, and I got this error message with every version of the software (x64, x86, x32, etc...):

Error 1935.An error occurred during the installation of assembly
"Microsoft.VC80.ATL,type="win32",version="8.0.50727.42",publicKeyToken="1fc9b3b9a1e18e3b" ,processorArchitecture="x86" Please refer to Help and Support for more information

I searched for information about the error, and tried many methods.

First I tried the Microsoft Fixit for Windows Update (apparently problems with windows update can cause this error), but that fixit was, ironically, the only one from the list which DID NOT work. It says that the version is outdated and to search for a more current version.

Next I tried a windows repair install from disk, and the repair install got at far as "Copying Windows Files" when it told me that the installation could not be continued. It then told me to restart and check for current updated.

I even tried making a separate admin account, and this, too, failed.

On an added note, I USED to be able to run this software since when I first got my computer, I installed Maya 2010 which uses the same software. I wish I had never uninstalled it.

Does anyone have a clue what to do? Let me know! I am on my last leg!

My System SpecsSystem Spec
04 Jul 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

The only cause I know of for this is a registry problem, below is the only fix I know of if I diagnosed this correctly.

  1. In Windows, click Start > Run...
  2. In the Run window, type 'regedit'. In the Registry Editor window, navigate to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control.
  3. In the 'Registry Editor' dialog box, double-click on 'RegistrySizeLimit'. This opens the 'Edit DWORD Value' dialog box.
  4. In the 'Edit DWORD Value' dialog box, enter ffffffff as the 'Hexadecimal' value. Click on the 'Decimal' radio button, and enter 4294967295 as the 'Decimal' value. Click OK.
  5. Reboot the machine.
  6. Log in as an Administrator and open a Command Prompt and run 'SFC /SCANNOW'.
My System SpecsSystem Spec
04 Jul 2011   #3

Windows 7 Home Premium 64 bit

Thank you for the reply.

When I navigate to HKEY_LOCAL_MACHINE > SYSTEM > CURRENT CONTROL SET > CONTROL , there is no RegistrySizeLimit file.

The options I have available to me are:


The option "BootDriverFlags" does bring up a window titled: "edit DWORD (32-bit) value", so maybe this is the right one?

Let me know what I should do. Thanks!
My System SpecsSystem Spec

05 Jul 2011   #4

Windows 7 Pro x64

I have the same problem. I added RegistrySizeLimit myself, it did not help. If anything, it made matters worse (I did it before I even hit his problem, that is). So it won't help him. According to this KB entry it should not do anything anyway.

I have a ATI 5850, and the SyncMaster P2470, so at least in terms of GPU and monitor we match pretty well

Can we get into contact via some chat method or so?

I'll try it chronologically. I used the RC of IE9 and never upgraded to RTM. Eventually I figured I'd let Windows Update handle this, but the update failed. Trying to manually install the full version of IE9 via the installer MS provide on their website also failed. Weeks later I thought I could use Programs and Features to remove IE9 RC to let me install IE9 RTM, but it's empty (and so is the list of installed updates)! That's when I looked into this RegistrySizeLimit thing. A reboot later, Programs and Features still was empty, so RegistrySizeLimit did not help. A few hours of gaming later, I noticed that I couldn't start one game anymore, and when I tried to fix it I ran the vc 2005 redist it shipped with again and got the error you describe.
I tried the usual sfc /scannow:
C:\Windows\system32>sfc /scannow
Beginning system scan.  This process will take some time.
Windows Resource Protection could not perform the requested operation.
So that is broken too.

Besides a MS supportsperson saying to delete Windows\system32\Catroot2 and Windows\SoftwareDistribution, I didn't find anything helpful online. I didn't try deleting them because a knowledgeable pal told me it won't help restore my Features list or anything and that I should just do an repair install. And that repair install not working got me here, where I by chance stumbled over your post on the last page of the thread.

Windows Update also takes about 40 minutes to check for updates.

Uninstalling all my VC 2005 redist entries (I had a lot) let me reinstall one x86 version successfully (which by now due to further trial and error with other versions disappeared from my Programs and Features menu again...), but that didn't make the program I wanted to run work, and the x64 build also doesn't want to install.

The only entries Windows Update currently offers me, a Office 2010 SP1 patch and a VC 2008 redist update both fail to apply. Office does Code 78F as error, VC 2008 redist gives Code 643. The VC 2005 redist update I was offered before I removed my VC 2005 redists during troubleshooting attempts also failed; I don't remember the error.

Attempting an in-place repair gives me comparable feedback to what you reported:
Upgrading Windows will affect the following devices and/or programs:    

  • These devices might not work properly after the upgrade. Before upgrading, we recommend updating the drivers for these devices. Cancel the upgrade, open Control Panel and search for "update device drivers", or go to the device manufacturer's website to search for updated drivers.
    • Sound, video and game controllers: TechnoTrend TT-connect S2-3600 (BDA)
    • Storage controllers: AXFIVKBS IDE Controller
  • These programs might not work properly after the upgrade. We recommend uninstalling these programs before upgrading. Cancel the upgrade, open Control Panel, and search for "uninstall a program". (Note: Programs marked as * can be safely reinstalled after the upgrade.)
    • ATI CATALYST Install Manager *
    • ATI Catalyst Control Center *
    • Freedom Force

My System SpecsSystem Spec
06 Jul 2011   #5

Windows 7 Home Premium 64 bit

What a relief to find someone having the exact same problem. I thought a windows repair install would be a sure-fix, but I guess not since we both get the same error. I am currently on vacation right now, so I will try again when I get back. I will uninstall my graphics card drivers and Itunes (the two things which conflicted with the repair install for me).

The obvious alternative to all this is a reformat, but that is highly unappealing.

My other hope is that Microsoft updates their fixit program for windows update which is currently not working. I feel it must be some problem there, because my family has several other computers all running on the same operating system with somewhat similar specs, and they can install Visual C++ 2005 Redistributable with no problems.
My System SpecsSystem Spec
06 Jul 2011   #6

Windows 7 Pro x64

I ended up doing a new install, as nothing I tried helped
(Mainly uninstalling driver-involving software and the like)

I copied 95% of my programs and profile settings from Windows.old into the new OS install, now I just need to reinstall a good few of said programs into their folders to make them work :P

The Fixit for WU, MicrosoftFixit50202.msi, didn't do much for be besides killing my WU install history. I was able to install ATI/AMD drivers via WU after uninstalling them, so only the newest few updates or only Windows component updates as opposed to third party drivers were broken for me.
My System SpecsSystem Spec
16 Apr 2015   #7

Windows 7 pro 64bit SRP1

Just to say I have run into this, considering all the time that has elapsed you would think a fix was out there
My System SpecsSystem Spec
07 Jan 2017   #8

Windows 8 Professional x64

I'm having the same issue, but on a brand new copy of Windows 10 Home (x64)...

That is the x64 version of the redistributable package.
My System SpecsSystem Spec

 Error 1935 Microsoft Visual C++ Redistributable

Thread Tools

Similar help and support threads
Thread Forum
Error 1935, Microsoft Visual C++ 2008 Redistributable Package (x86)
I once had this before when I tried to download Age of Empires Online. I decided one game isn't worth the problem, and I'd avoid all "Games for Windows" games because of this issue. Now, I recently bought a Vita and now I can't download Content Manager Assistant because of this, so now it is...
Microsoft C++ redistributable 2005 won't install, Error 1935
Hey guys, when i'm installing Microsoft C++ redistributable 2005 I get error 1935. Help? :confused:
Error 1935 HRESULT: 0x80070003 when installing Microsoft Visual 2008
Hello, I was trying to install XNA 3.1 when I started receiving some VC90 errors. I uninstalled Microsoft Visual C++ 2008 32 and 64, but receive an error when reinstalling. Error 1935 HRESULT: 0x80070003. I ran SFC /SCANNOW. CBS came back OK. I ran the readiness tool. CheckSUR says I'm fine....
Performance & Maintenance
microsoft visual c++ 2005 redistributable (x64) error 1305
I have a problem installing microsoft visual c++ 2005 redistributable (x64). I have tried installing it as administrator, but that does not work.
Microsoft Visual C++ 2005 Redistributable Error 1935
Hello! I am getting a really infuriating problem that is preventing me from installing applications, such as Livestream Podcaster. Here is the error as displayed by Event Viewer: Product: Microsoft Visual C++ 2005 Redistributable -- Error 1935.An error occurred during the installation of...
Installation & Setup
Error 1935: Microsoft Visual C++ 2008 Redistributable x86 Install
I was trying to install Visual Studio 2010 and started encountering errors with the C++ distributable package during install, so I decided to install it by itself. Whenever I try and install it, it stops on Feature: FT_VC_Redist_openMP_x86 and I receive the following error message before it...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App