Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: NET framework 4 causing problem on other program

12 Jul 2011   #1

windows 7 Ultimate x64
NET framework 4 causing problem on other program

Hi all!

IŽve been using a software for trading stocks for a while now (like 3 years) and no problem whatsoever! the software is given by the broker and is a platform used by many.

the thing is that lately, since the last updates, it has been asking me to install .NET framework 4, otherwise it will stop working in 5 days!

I installed framework 4, everything goes smooth BUT the the trading software wonŽt launch! if I uninstall framework 4 it starts working again just fine! but still asks me to install framework 4 in the remaining 5 days!

after the deadline, I have to unintall the trading software and install it again. IŽve called the broker and they say that they havenŽt heard of such a problem! right...

I have this trading software running on three computers: two desktops running win7 x64 and a laptop running win7 x86.

on the laptop, wich is 32bits, I upgraded the framework 4 and it works fine, as good as before!

on the other two desktops, wich are 64 bits, this problem is hapenning!

I think I can conclude that the big connection here is "win7 x64 --- framework 4"

Can anyone help me? does anyone see a solution based on what I described?

Thanks, any answer will be apreciated!

My System SpecsSystem Spec
12 Jul 2011   #2


Maybe you can try the standalone installer instead of the online one? Here's a link to the download details page on MS' website: Download Details - Microsoft Download Center - Microsoft .NET Framework 4 (Standalone Installer)

P.S.> I had a related issue with a game recently requiring version 4 of the .NET framework, which required me to download an additional installer (XNA something). It seems game-related though so it may not apply to your situation but if you're running out of ideas I guess you could check it out:
My System SpecsSystem Spec
13 Jul 2011   #3

windows 7 Ultimate x64

Hi, Trucidation!

Actually iŽve tried the standalone installer with no luck but iŽll try it once again! maybe thereŽs an update or something that solves the issue...

iŽll also try that xna framework and and iŽll get back to you.

thanks for your reply
My System SpecsSystem Spec

13 Jul 2011   #4

windows 7 Ultimate x64

Got my problem solved... maybe not completely solved but is a workarround!

so I downloaded the file of the standalone installer, and noticed that i already had one in my "downloads" file... compared the two versions and confirmed they were the same (4.0.30319.1).

so i picked one and installed... no luck, trading software wouldnŽt start!

then tried the xna framework like Trucidation suggested... still no luck!

then, i donŽt know how, I stumbled in the "XML configuration File" of the trading software (notice that iŽm no computer expert), and opened it.

you could read this on a script:

supportedRuntimeversion="v4.0.30319"sku=".NETFramework,Version=v4.0" />

so i remembered that the version of the fw4 was 4.0.30319.1! there was the ".1" missing! I changed it and it started! YES!!! this was driving me nuts!

I said this might be a workaround because i donŽt really know wether i corrected the problem OR if i made the fw4 be ignored at startup...

I donŽt care as long as it works...

if anyone as any idea to add, youŽre welcome!

thank you again, trucidation...
My System SpecsSystem Spec

 NET framework 4 causing problem on other program

Thread Tools

Similar help and support threads
Thread Forum
Program is asking for a version of .NET Framework that I'm ahead of
I need to use a specific (no named) program to help create a mod for a game im playing, but the program is asking for an earlier version of .NET Framework. I tried searching to see if i could install an earlier version, but all i could find what that i couldn't.
File Corruption Causing Issues With Reformatting, .NET Framework, etc.
Hello, A few days ago I was trying to upgrade my .NET framework to play a game and noticed the download hangs and failed with the error code 0xc8000247. Upon numerous online research and supposed fixes, I could not get my system to download the file correctly. So, I went to my Windows Update...
General Discussion
.NET Framework 4 Client Profile causing Windows Update Error 0x8024402
Hi I'm running Windows 7 32bit. I performed a clean install on a new hard drive, I successfully ran a few updates with Windows update and eventually was offered the .NET Framework 4 Client Profile which i installed. When i tried to check for updates after that it failed with error 0x8024402f....
Windows Updates & Activation
.net framework 4 issue causing XNA framework 4 issues
Ok, sunk a couple hours into what the problem is, unfortunately I cannot work out how to fix it short of reinstalling my operating system (If I take it off, I refuse to put it back on, to many headaches already). Basically I needed to update to .net framework 4, and my system lied and said it...
Windows Updates & Activation
Problem with a program causing 7 (64) to crash
Hi - I am trying to use bookmarking demon: Social Bookmarking Software, Social Bookmarking Tool It is reported as working on windows 7 64 which I am using but when I run it I always see a message saying that it has stopped working and then that windows is checking for a solution. This happens...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:14.
Twitter Facebook Google+