Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error "Could Not Access Network %APPDATA%

06 Sep 2011   #1

Error "Could Not Access Network %APPDATA%

Error "Could Not Access Network %APPDATA%

This has been a pain. I have tried to install many programs & get this error.

Why don't Microsoft fix this error Or at least a method to correct it that takes a registry hack.

Now I can't use Nokia OVI suit because of the error. All my data on my cell phone is undownloadable!!!

What is the answer??

My System SpecsSystem Spec
06 Sep 2011   #2

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

A couple of questions first:
  • Have you tried to install your Nokia OVI program by right clicking the installer, and selecting 'Run as Administrator' ? If not try that.
  • And, can you tell me if you receive any numerical error code such as, 0x80070646, error code: 646, or error code: 1606?
Depending on your error code answer there can be up to three different registry fixes.

This could be a Services, and or a Registry problem, lets work on the Services first.

I need you to check the Network Location Awareness service (NLA) to see if it is set properly, i.e. Started >Automatic:
  • Copy/Paste Services into your Start >Search box.
  • You should see Services at the top of the results list, left click on that to open the Services window.
  • When it opens, scroll down to Network Location Awareness.
  • Check to make sure it is set to start Automatically, and is started.
  • Then double check its dependencies and make sure those are started and set to automatic.
To check, and or change the NLA, and its dependencies:
  • Right click on Network Location Awareness then move down, and left click on properties.
  • Properties will open to the General tab. If NLA needs to be changed, do it here.
  • Then left click on the Dependencies Tab.
  • For every dependency listed you have to find it listed in the Services window, and make sure they are set to started >automatic, this is done on that General tab.
  • For every change you do make, make sure you click on Apply, and then OK.

When you are satisfied that all Services are set properly reboot your machine, and try to install your Nokia OVI program by right clicking the installer, and selecting 'Run as Administrator'.

If that does not help, leave the Service settings as they are, and I walk you through the registry settings.

I realize that there are a lot of steps, and this is a long post/reply. So please remain calm and patient while you are going through the Service settings.

If you think this is bad, wait until we tackle the registry.....If we have to.
My System SpecsSystem Spec
07 Sep 2011   #3



I will try to follow your instructions!

My System SpecsSystem Spec

10 Sep 2011   #4


I checked the Services.


Under Network Awareness dependances 1 & 2 OK!

Number 3 Listed TCP/IP NetBios Helper.

That was not listed in the services.

TCP/IP Protocal Driver was & is set to automatic.

What now.

Sorry for the delay, but was in hospital.

My System SpecsSystem Spec
10 Sep 2011   #5

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

I am sad to hear of your recent medical condition. I trust it went well for you.
As in all situations of a personal matter it is best to take care of yourself, and your loved ones first, the material items can be fixed or replaced.

About those material items......Your %APPDATA% error was generated from a Windows Installer problem that is usually caused by incorrect Registry entries, but on some systems the Service settings can come into play, that is why I had you check those first.

Go to this site, and run the Fixit that is there:
You receive error code: 0x80070646, error code: 646, or error code: 1606 when you use Windows Update or Microsoft Update

I know.....When you read the KB article it deals specifically with MS Office products.

But, being that it is a problem with Windows Installer it can also affect other areas of updating, and program installation.

You can try fixing it yourself, but I would advise against that. If you are curious though, you could follow the 'Let me fix it myself' portion of the article just to see if there are any incorrect values in the registry.
There are three main areas to check:

If you do, again, be calm and patient in trying to find these keys as it is very easy to find yourself in the wrong area, that is why I advise to run the Fixit. In any event make sure you Backup the Registry! Using Method One.

Research Sources:

Off topic:
Just wanted to give you a heads up about Hurricane Katia. It should arrive, your location, early Monday morning with tropical force winds.
Error "Could Not Access Network %APPDATA%-1kat.jpg
We just went through T.S. Lee and received 13.5 inches of rain, and now we are waiting to see what Maria is going to do. Here is a similar thread: Storm Warnings for British Isles.

Take care

My System SpecsSystem Spec
11 Sep 2011   #6


I tried the FixIt ! No joy!

I also tried fixing it myself, everything matched except the last registry key

Every line in the "fix" had "common" in front of it. Mine didn't.

Is this the problem.

I don't like to "fiddle" with the registry.

It seems that Microsoft should be the one to come up with a real fix!

I have been a loyal user of Microsoft software, but now it is weakening.

I can't even use my cell phone software now because of the error.

This is not a recent error & I feel really let down by Microsoft & the computer community. Lots of advice but no solution.

My System SpecsSystem Spec
11 Sep 2011   #7

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

Quote   Quote: Originally Posted by Tullynally View Post
I also tried fixing it myself, everything matched except the last registry key

Every line in the "fix" had "common" in front of it. Mine didn't.
Please be more specific.

By 'last registry key' do you mean the one located at:
\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

If you do, you can see by the snip of my key at that location,

Error "Could Not Access Network %APPDATA%-1tully.jpg that indeed it does say Common.

Have you made the Backup of the Registry by creating a restore point?

To change it, right click on that 'AppData' key, move down to Rename, and add the word Common (notice the capitalization), with a space between Common and AppData, and touch Enter on your keyboard.
Also make sure the Key Type is REG_EXPAND_SZ, as a matter of fact all of these Keys in question are of that type.

Then try to install the Nokia OVI program.

The KB2258121 article does not say that you need to restart your machine after changing the key, but I usually do when making changes of this nature.

My System SpecsSystem Spec
12 Sep 2011   #8


I'm sorry, I went to that key again & it matches your snip.

I am so confused now that I am going back to my old, old Dell Laptop with Win XP.

All the programs that won't work on my hi-spec computer & win7 Home Premium

work perfectly on the old decreped, low spec, Dell!!

I feel that Microsoft has completely let me down & will think twice before buying MS again!!

There are 5 programs I cannot run after an update because of the "Can Not Locate Network Location %APPDATA%

Since 5 different programs, from 5 different sources won't work it is a MICROSOFT problem!

I really apreciate the time you have taken to help me try to solve the problem!

My System SpecsSystem Spec
12 Sep 2011   #9

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

Your welcome!

The AppData error does seem to be a tough nut to crack. What works for some users does not for others.

As you will be running XP, please make sure you have the latest service pack (SP3) that way you will continue to be eligible for support and receive updates until its official retirement on April 8, 2014.

Some XP sites of interest:
Preparing Windows XP for the long haul. Check the Lounge area of this site there is some good XP information there.

Windows XP Software Updates

Support for Windows XP technical problems and troubleshooting

Learn how to install Windows XP Service Pack 3 (SP3)
My System SpecsSystem Spec

 Error "Could Not Access Network %APPDATA%

Thread Tools

Similar help and support threads
Thread Forum
"Unable to access network" error with Google Chrome
For sometime now Google Chrome comes out with the "Unable to access network" error, it now appears more frequently. I have check windows fire wall and all seems OK, I have even removed Chrome and re-instated it with no effect. I tried to go to | Not For Everyone. and Chrome was unable...
Browsers & Mail
Error: "Could not access network location \Resources"
Hey everyone, I'm trying to install the 30day trial for WinAutomation WinAutomation Macro Recorder and Windows Automation Software but I keep getting this error and yesterday I searched for about 5 hours for the solution but nothing worked and today I'm getting close to match that. So far...
Network & Sharing
Cannot create file "c:\User\...\Appdata\Roaming...". Access is denied.
I'm not sure what's the cause for this, but I believe it has to do with a recent SweetIM malware attack. I tried to fix it. And also did a system restore. Malware is gone, but this thing came up. The error message comes up upon closing an app (NoteTab Light). It's trying to save some info, but...
General Discussion
Error 1606. Could not access network location %APPDATA%\.
Error 1606. Could not access network location %APPDATA%\. That is the message I received when I tried to install Microsoft Office 2010. I went to their website and used the Fixit tool, but it did not work. Any ideas? :geek:
Microsoft Office
Win7 C:AppData and D:AppData cant access
Hi all. I just built a new system with win764. I took my old hard drive which also had win764 and hooked it up to transfer all my files over to the new system. Problem is if I go to D:\Users\MYUSER\Application Data its showing me the contents of
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:12.
Twitter Facebook Google+