Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New file access problem

04 Nov 2011   #1

Windows 7 Professional SP1, x64
New file access problem


I have a problem with accessing newly created files.

When I create a new file and try to write some data right after it (i.e. Saving a modified image into a new file, moving file to another disk), i get the "Access denied" message, saying that another process is still using the file.

When I use the "Retry" option, it goes fine.

The problem appears randomly with about 1/3 chance.

This issue makes moving larger folders a nightmare, since I have to click the retry button all the time the files are copied.

Thanks for any help

My System SpecsSystem Spec
04 Nov 2011   #2

Win7 H.Prem. 32bit+SP1

Do you save the new files first.?
My System SpecsSystem Spec
04 Nov 2011   #3

Windows 7 Professional SP1, x64

I am not sure what the question means, therefore I give examples of the problem:

I have no file "hello.png". I open Paint, create an image, open the "Save as..." dialog, type in "hello.png" and click "Save". At this point, the file gets created, but instead of saving the content, the file stays empty and i get the "Permission denied" dialog. By clicking "Retry", the content is saved into the file and Savedialog closes.

Another example, I copy the whole folder from one disk to another. The folder contains about 1000 files, and during the process, I get about 300 times the same "Permission denied" dialog. Clicking "Retry" the process continues, but 300 times is a hell.

I use Intel Core2 Duo CPU @2.1 GHz.
My System SpecsSystem Spec

04 Nov 2011   #4

Windows 7 Professional SP1 32-bit

Do you have antivirus software installed? (OK, dumb question - you should )

It might notice your attempts to create new files and immediately try to scan them - thus interfering with their getting saved and locking them prematurely. I'd just turn that option off if it allows you to.
My System SpecsSystem Spec
04 Nov 2011   #5

Win7 H.Prem. 32bit+SP1

Can you open the 'Sample Pictures' folder in Libraries. ?
My System SpecsSystem Spec

 New file access problem

Thread Tools

Similar help and support threads
Thread Forum
Custom screensaver file read access right, network access
Hi, I've creates my own custom screensaver (in Visual Studio 12 using WPF), which need access to network for check an weather and email check. I've settings saved in two files. First one is NotifyScreensaver.scr.config, where I've only url to server, from which I take weather informations....
Themes and Styles
Got a big problem with a no access file would appreciate assistance.
Hi , i have a zip file thats on my external harddrive and i cant access it although it is mine. I have tried many types of unlocking tools aswell as instructions from the forum. I think it is a separate case and has to do with permissions and ownership. Even if i gain ownership and gain permissions...
General Discussion
Windows can't access file. May not have permission to access.
Hello, I am attempting to access an application.exe file on my desktop. Each time that I click on it the Windows message, "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." pops up. I am the system administrator so this...
General Discussion
Win7 x64 Crashes on Internet Access or File Access
Hi all, So i'm writing this from Safe Mode with Networking as that seems to be the only way to keep the system stable. I was working on my computer last night with zero problems. I shut it down and then today I have the following symptoms. Once i boot, i can open folders on the desktop and...
BSOD Help and Support
Help! File Access problem
Hello, After installing Win7 i ran takeown for all the files on one of my drives. Now i have reinstalled WinXP and of course I cannot access a single file. Is there anything I can do ? Thanks in advance
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App