Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: P2P programs

14 Jan 2009   #11
Gilbertpwns

Windows 7 64bit/Windows Vista Ultimate 64bit
 
 

and you guys didnt have to change anything? on W7?


My System SpecsSystem Spec
.
14 Jan 2009   #12
mansrm81

Windows 7 Ultimate x64/ Windows Vista Ultimate x64
 
 

Utorrent works perfect for me.
My System SpecsSystem Spec
14 Jan 2009   #13
Gilbertpwns

Windows 7 64bit/Windows Vista Ultimate 64bit
 
 

Definetely not my Antivirus software. Installed it both in Vista and W7. Even disabled it in W7. Still doesnt work.

By the way, the red/yellow/green icon on the bottom of utorrent means NOTHING. Mine is red right now for some reason and its STILL getting 200kb and up.
My System SpecsSystem Spec
.

14 Jan 2009   #14
renthor

Windows 7 Beta 1 b7000
 
 

That icon actually does mean something. It means uTorrent thinks you're behind a firewall, and it's not properly configured. I would really suggest making sure your port settings are correct, it is a hassle, yes, but it REALLY does matter, as it effects how many connections you're getting. It might allow one connection through, and you got lucky that one time and that user had a high speed connection, hence your high download rate.

If you do not want to rely on UPnP and whatnot, then set it manually yourself. I would really suggest reading this and this if you need help with that. Again, it is annoying at first, but you really only have to do it once. And I've been using UPnP etc with no problem, it should automatically setup Windows Firewall for you and you can check this by clicking the highlighted link in the attached picture (found in Control Panel...System and Security). You might see a few uTorrents listed, it makes a new entry for UDP, TCP, and the program/ports themselves.

Also, it couldn't hurt to check your router's settings, if you have one. It sounds like it should not be in your router as Vista is working fine, but it could also be that uTorrent in Vista is using a different port than uTorrent in 7. When you install uTorrent, it picks a random port. If you need assistance with that, we'll need to know what type of router you have.


Attached Thumbnails
P2P programs-utorrent2.png  
My System SpecsSystem Spec
14 Jan 2009   #15
Gilbertpwns

Windows 7 64bit/Windows Vista Ultimate 64bit
 
 

After a while it turned green :P. And yes its allowed through the firewall, on both OS.

I admit, networking is not my forte so yes I will need help with that, and almost everything else.

I have a Belkin N1 router.

These are my port settings

My System SpecsSystem Spec
14 Jan 2009   #16
renthor

Windows 7 Beta 1 b7000
 
 

And what happens when you test if the port is forwarded properly? Do you get this (see attached image)?

Also, it appears you've completely limited your upload to 0. The nature of torrents requires some sort of upload. So, if you don't upload, you're download will be severely limited. This is probably contributing to the problem, if not outright causing it. Try running the speed test, and then select your upload speed result (from the test) in that "Connection Type" drop down box.

Note: I do know that setting the upload to 0 in the advanced settings in uTorrent will set your upload rate as unlimited - I'm just not sure if it would display as 0.0 in this screen, or as "unlimited". This would also effect your download speed, as you're effectively devoting your entire connection to upload. Definitely set your upload speed result in that drop down box, uTorrent is pretty smart about configuring everything else from there. I wouldn't mess with the custom settings unless you know what you are doing.

No matter which way it's going, that 0.0 is a bad number.


Attached Images
P2P programs-ports.png 
My System SpecsSystem Spec
14 Jan 2009   #17
mansrm81

Windows 7 Ultimate x64/ Windows Vista Ultimate x64
 
 

You need to put your port number into your router in the firewall virtual servers and enter the last ip address the router has issued your computer.
My System SpecsSystem Spec
14 Jan 2009   #18
renthor

Windows 7 Beta 1 b7000
 
 

I'm pretty sure at this point that your problem is related to your upload/connection settings. Try my instructions and if that doesn't work, then we'll start messing with your ports and router/firewall. Though please, still let me know what the port test result is.
My System SpecsSystem Spec
14 Jan 2009   #19
Gilbertpwns

Windows 7 64bit/Windows Vista Ultimate 64bit
 
 

this is the result



And yes I typically have my upload set at unlimited because I do seed back....
My System SpecsSystem Spec
14 Jan 2009   #20
mansrm81

Windows 7 Ultimate x64/ Windows Vista Ultimate x64
 
 

Your router is blocking the port that is why your getting that error. Open IE or what ever browser your using and type in 192.168.2.1 then under firewall click on virtual servers enter your password if you have one then enter the port number in all of the inbound and outbound areas for type select both and enter the last digits of your ip address then click apply and then recheck to see if your port is opened.
My System SpecsSystem Spec
Reply

 P2P programs




Thread Tools




Similar help and support threads
Thread Forum
programs missing from programs and features, recovery failed 0xc000002
I recently opened up my uninstall list and a lot of my programs are missing i tried restoring my computer to before i downloaded quick time (which i think is what the issue was) but the restore came up with an error 0xc0000022 saying it failed to restore, i tried an sfc scan and it came up with...
General Discussion
Remove entries in Programs and Features" without uninstalling programs
Is there a way to remove entries from "Programs and Features"? The screenshot shows many entries for MegaSceneryEarth, can I get rid of all these entries someway? I do not want to uninstall the program, I just do not want all this crap showing up under "Programs and Features".
Software
Question about Windows 7 Control Panel\Programs\Programs and Features
I have Windows 7 Prof x64. My question is, when displaing all software installed and choosing more columns of information to display, they don't stay. For example, choosing Location column. Getting out of the installed programs list and then returning to it, the Location column is gone. Is...
General Discussion
Can't Switch Programs On Screen Via Programs Pinned to Taskbar
An example: I open Firefox full-screen. If I try to switch to Outlook, which is open and showing in the taskbar, it wont let me. I am forced to minimize Firefox Same thing happens when Outlook is full screen.
General Discussion
Lost Programs and Folder from Start-Up All Programs Menu
Hello to all, Have no idea how I did it, must have been during an upgrade, but I've lost my Revo Unistaller Folder and programs from the ALL Program List. Can anyone advise how to get it back there? Thanks in advance. Glenn
General Discussion
Icons in Control Panel\Programs\Default Programs\Set Default Programs
Hi, I went to set a program as a default and I saw these 2 browsers icons I had but I uninstalled them and the shortcuts are still there so how can I remove them? Thanks in advanced :)
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App