Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VDS Basic Provider error (code: 490@01010004)

01 Feb 2011   #21

Windows 7 Ultimate x64
VDS Basic Provider Error

You lucky guys!
You talk errors, I got BLUESCREENs, not one, but several a day.
My (unprofessional) understanding: My brand new Win 7 Dell PC just needed a running-in period.
I received patches from Dell support and from Microsoft.
This means I still trust them!

My System SpecsSystem Spec
02 Feb 2011   #22

Windows 7 x64
VDS Error

Here is what I found out about this VDS Basic Provider Error. It only seems to occur when Computer Management is opened. Microsoft says that it is an acceptable error and thare is no fix. It is caused by a virtual drive, for me that is Damien Tools. You can look in Event Viewer and see that the error is not present. If you then open Computer Management you'll notice that the VDS error is there in the last hour. That's because CM caused the error by virtue of merely being opened and detecting your virtual drives. Now for when there is a serious effect of the error like Screen flickering and blue screens I was able to fix that by uninstalling then reinstalling my AntiVirus software. In my case AVG but it occurs with others as well. Open Computer Management and then Disk Management. Then click open any of the Tools above and see if the screen flickers. If so that is most likely your AntiVirus software.
My System SpecsSystem Spec
04 Apr 2011   #23

windows 7 ultimate x64bit

It seems that this problem happens when using any virtual dvd such as alcohol or virtual clon. I use virtual clon and I have the event as well.
I am trrying to find a root cause of this.
My System SpecsSystem Spec

08 Apr 2011   #24

Windows 7 Enterprise x64
Same error, but with a thumb drive not showing up

Hey guys,

It's good to see MS can say its an error we can not worry about, but in my case i put in a 4GB thumb drive (AKA USB sticks) and my PC does not see it. It will not show up in "My PC".

Looking in device manager and disk management it shows up there, but when i right click on the drive to format it, I get that error.

I am running Daemon tools lite but this problem has only now cough my attention. I'm sure I've used this thumb drive before. It still works without any problem on my laptop (Vista32bit) and other PC's.
My System SpecsSystem Spec
09 Apr 2011   #25

Windows 7 x64

See if it shows up in Devices and Printers. If it does you can right and then choose Troubleshooting. Also, in Device Manager under view click Show hidden devices to see if anything is flagged. Also in Device Manager click open Disk Drives to see if is there. You said the thumb drive shows up in Device Manager so you can right click it's icon there to update it and if not just uninstall it from the same menu. Restart the PC and see if Windows installs if automatically. It doesn't sound like the VDS error has anything to do with it even though the error you get says so. I've had it happen from a USB error as well. So try running that troubleshooter. Why are you trying to format it? That should'nt be neccessary and can delete the internal software required to run the device. Hope it helps. fredrock
My System SpecsSystem Spec
25 May 2011   #26

Windows 7 Home Premium x64
Try reinstalling image mounting software

I just ran into this problem. It made my DVD drive not detect discs in the drive. I solved it easily by reinstalling Virtual Clone drive. No reboot needed.

I think something in the software broke when I updated the Intel AHCI Storage Driver. Problem solved for me.
My System SpecsSystem Spec
03 Oct 2011   #27

Windows 2008 R2
It interrupts the backup process for me

If I run the backup process for the first time (there's no Windows Image Back folder at the destination) everything works fine.

Running it subsequently, will make this error appear. The problem is, the Windows Backup reports success at 66%. Although it reported success...the just backed up version in the VHD has 44% of data "corrupted" aka innaccesible.

When the Windows Backup reaches 66%, that error appears also, making me suspect they are related.

I have Alcohol 120% updated to latest version and Starburn.

I also have a mountpoint on the beeing backed-up volume to an Alcohol virtual drive.

Error is:
VDS Basic Provider
Unexpected failure. Error code: 490@01010004
My System SpecsSystem Spec
03 Oct 2011   #28

Windows 7 x64 Ultimate

You can try downloading the latest SPTD driver (it was supposed to fix these errors a long while ago), but for me, it didn't do any good.
DuplexSecure - Downloads
My System SpecsSystem Spec
04 Jan 2013   #29

Windows 7 Ultimate x64

I am experiencing this same error:

Log Name: System
Source: VDS Basic Provider
Date: 1/4/2013 12:24:15 AM
Event ID: 1
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: Edward
Unexpected failure. Error code: 490@01010004

I cannot complete a backup because of it, every time I attempt to complete a backup with windows backup I get this error followed by another error 1-2 hrs later:

- System
- Provider
[ Name] Windows Backup
- EventID 4104
[ Qualifiers] 0
Level 2
Task 0
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2013-01-04T07:21:31.000000000Z
EventRecordID 5396
Channel Application
Computer Edward
- EventData
The process cannot access the file because it is being used by another process. (0x80070020).

I have virtual clone drive installed, I have MS Security essentials, real time protection disabled. Im about to try this updated driver, and if that doesnt work...uninstall virtual clone drive I suppose
My System SpecsSystem Spec
06 Jan 2013   #30

Windows 7 x64

It's been a long while since I had this problem but I will try and help. The error can occur for several reasons but first look at the post above yours in this catagory by Toneloc82. Since you both use virtual clone drive and reinstalling fixed the problem for him I would start there.

If not look at the item below that I quoted from your Event log.
"- EventData
The process cannot access the file because it is being used by another process. (0x80070020)."

Use Task Manager to determine if there are programs and/or services running that you are unaware of. If there are close them.
Check also if there are any programs set to start with Windows that are not neccessary. Disable them in your startup menu. Post back if this does not help and I'll help you narrow it down.
My System SpecsSystem Spec

 VDS Basic Provider error (code: 490@01010004)

Thread Tools

Similar help and support threads
Thread Forum
Windows Update Error, Error Code 80070643, Code 9C57
Computer model: Panasonic Toughbook CF-31 OS: Windows 7 SP1 Processor: Intel Core i5-2540M CPU @ 2.60GHz 2.60GHz RAM: 4 GB (3.89 GB usable) System type: 64-bit CBS Log - Google Drive I ran the SURT tool Windows6.1-KB947821-v34-x64.msu.
Windows Updates & Activation
Visual Basic - Learning to Code
Learning to Code in Visual Basic I will be using various terms during this tutorial here is a small reference centre for you: VB/VB200 8 = Visual Basic 2008 GUI = Graphical User Interface Form = Application with a GUI Downloading
Started with error code 0xC0000006 and now I have Error Code: 0x803002
This is a desktop PC with Windows 7 Ultimate 64 bit installed. I'm trying to repair with the disk it was installed with originally. The reason for attempting the repair is that the System File Checker says there are files that it could not repair when I ran it. I ran it originally because I...
General Discussion
random BSODs error 0x000000b8/490@01010004
Hello, I am experiencing some BSODs on my ASUS G75VW. It's not happening at specific times, but every now and then, within 1-2 days, and that is completely random. I thought it was initially from some Adobe applications because it happened mostly when I was linking projects between the apps, but...
BSOD Help and Support
Win7 Firewall won't turn on error code 0x6D9 and error code 0x80070424
Ok - I'm trying to fix my friends' computer - Toshiba Satellite L455-S5975 running Windows 7 32-bit Windows firewall is off and I need to "Update Firewall Settings". When I click use recommended settings, I get a message that says it "can't change some of your settings. Error code 0x80070424" I...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:50.
Twitter Facebook Google+