Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VDS Basic Provider error (code: [email protected])

11 Aug 2009   #1

Windows 7 x64 Ultimate
VDS Basic Provider error (code: [email protected])


I have problems with this error, seems to appear when I mess around properties of the hardisk/volumes.
Both C, D volumes are healthy/no bad sectors.
There is a 2 MB unallocated space at the end of the drive though that people around the net seem to agree it's natural - it is seen only in Acronis True Image and in the hardrive properties.

Thank you for your help.

Attached Images
VDS Basic Provider error (code: 490@01010004)-vds-error.png 
My System SpecsSystem Spec
26 Aug 2009   #2

Windows 7 x64 7600
VDS Basic Provider [email protected]


i have the same error on a w7 x64 os, any ideas what might be causing it? google directed me here... :)
My System SpecsSystem Spec
26 Aug 2009   #3

Windows 7 x64 Ultimate


All I found out is that it appears when I check disk/volume properties. Posted in other places too, but didn't find anyone knowing the system well enough to troubleshoot it.
Maybe you should fill other details about your system, they usually help a lot.
My System SpecsSystem Spec

27 Aug 2009   #4

Windows 7 x64 7600

Gigabyte EX58-UD5, Core i7 920, Windows 7 x64 7600 RTM, 4HDDs: Velociraptor 300GB, WD6400AAKS, Seagate 640GB, Samsung 250GB.

I also have an assortment of partitions and even assigned letter B: to one of them (the DVD-RW is letter A:). I also have a dedicated SWAP partition placed before the system partition and I have assigned letter Z: to it.

Disk Management showed a gap of a couple of unallocated megs between two logical drives on a logical partition, but I have removed that by deleting the closest partition and then recreating it, including the previously unallocated space.

I will check if it appears when I check the properties of a partition or HDD, however it is very annoying the message does not include more details.
My System SpecsSystem Spec
27 Aug 2009   #5

Windows 7 x64 Ultimate

I'm not sure the unallocated space should cause any errors. I read on the net (I'll try getting back with some Google search results when I get back home) that the space is normal, as it is needed if you later decide to convert your drive from Basic to a Dynamic Disk. As I never had more than one HDD in my system, I'm surely not the one to explain these things, they seem to be related to RAID and multi-hdd configs.
The unallocated space should be positioned at the end of the drive (I remember I read that somewhere). As Windows sees that as a natural condition, it doesn't appear in normal Disk Management as you can see in the picture.
Are you also getting Volsnap (in the second picture) event?

Attached Thumbnails
VDS Basic Provider error (code: 490@01010004)-unallocated-space.png  
Attached Images
VDS Basic Provider error (code: 490@01010004)-volsnap.png 
My System SpecsSystem Spec
31 Aug 2009   #6

Windows 7 x64 Ultimate
VDS error replicated, Alcohol 120% to blame

OK, I have managed to replicate (not repair) the VDS Basic Provider error (code: [email protected]). It starts to appear exactly when you install Alcohol 120% virtual drive. I'll attach the look of a Alcohol 120% installation below. The VSS error is Alcohol's too.
I am using Alcohol, last version ATM.

Attached Images
VDS Basic Provider error (code: 490@01010004)-alcohol-120-errors.png 
My System SpecsSystem Spec
01 Sep 2009   #7

Windows 7 x64 Ultimate

Same error appears in the Event log by using Virtual CloneDrive software (is this using sptd, too?). There is something with Windows 7 and image mounting software, maybe that infamous sptd driver, maybe not, maybe someone has qualified opinions on the subject?
SPTD=SCSI Pass Through Direct (usually abbreviated as SPTD, filename "sptd.sys") is a device driver developed by Duplex Secure Ltd. that provides a new method of access to storage devices. The SPTD API is not open to the public.
The 1.60 version available on their site is not having Windows 7 compatibility.
Maybe someone can dig more on this.
My System SpecsSystem Spec
05 Jan 2010   #8
Plastic Spoon

Windows 7 Ultimate

OK I have the same problem too. Some parallels with other posters: I too run Win7 X64 Ultimate (it seems to be affecting X64) and I too have Virtual Clonedrive installed. In my case, there are two versions of the same error, one says [email protected] and the other [email protected] My disk configuration is 500GB Seagate 7200RPM C: and 500GB 5400RPM Western Digital D: on Acer Aspire 6930G laptop (one of the few 16" laptops that take two physical drives). Machine newly formatted and built about 10 days ago.
I get another error as well, as follows: Unexpected provider failure. Restarting the service may fix the problem. Error code: [email protected]
Just adding this info as it may help establish a pattern.
I don't have the Alcohol 120 software that toyo describes - never used it.
My System SpecsSystem Spec
05 Jan 2010   #9

Windows 7 x64 Ultimate

The culprit is the sptd driver, now at version 1.62 - some of the virtual disk apps like Alcohol 120% and Virtual Clonedrive install it. It is described on their forums too, feel free to check out their site, maybe download the last version, for x64 (I did just that, updated the driver correctly - they have some special procedure, but the errors keep on being logged).

However, the system seem to work just fine, it's just the damn logs... and who knows what other unseen failures, due to sptd. I'm waiting for version 1.63, but I don't have high hopes...
My System SpecsSystem Spec
16 Jan 2010   #10

Windows 7 Pro (x64)

The error also occurs when you uninstall a virtual drive app, such as Virtual Clone drive.
My System SpecsSystem Spec

 VDS Basic Provider error (code: [email protected])

Thread Tools

Similar help and support threads
Thread Forum
Windows Update Error, Error Code 80070643, Code 9C57
Computer model: Panasonic Toughbook CF-31 OS: Windows 7 SP1 Processor: Intel Core i5-2540M CPU @ 2.60GHz 2.60GHz RAM: 4 GB (3.89 GB usable) System type: 64-bit CBS Log - Google Drive I ran the SURT tool Windows6.1-KB947821-v34-x64.msu.
Windows Updates & Activation
Visual Basic - Learning to Code
Learning to Code in Visual Basic I will be using various terms during this tutorial here is a small reference centre for you: VB/VB200 8 = Visual Basic 2008 GUI = Graphical User Interface Form = Application with a GUI Downloading
Started with error code 0xC0000006 and now I have Error Code: 0x803002
This is a desktop PC with Windows 7 Ultimate 64 bit installed. I'm trying to repair with the disk it was installed with originally. The reason for attempting the repair is that the System File Checker says there are files that it could not repair when I ran it. I ran it originally because I...
General Discussion
random BSODs error 0x000000b8/[email protected]
Hello, I am experiencing some BSODs on my ASUS G75VW. It's not happening at specific times, but every now and then, within 1-2 days, and that is completely random. I thought it was initially from some Adobe applications because it happened mostly when I was linking projects between the apps, but...
BSOD Help and Support
Win7 Firewall won't turn on error code 0x6D9 and error code 0x80070424
Ok - I'm trying to fix my friends' computer - Toshiba Satellite L455-S5975 running Windows 7 32-bit Windows firewall is off and I need to "Update Firewall Settings". When I click use recommended settings, I get a message that says it "can't change some of your settings. Error code 0x80070424" I...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:55.
Twitter Facebook