Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Uninstall Powershell 1.0

14 Aug 2009   #1

Windows 7 build 7260
Uninstall Powershell 1.0

Anyone here know how to uninstall Powershell 1.0?

I would like to install 2.0 CTP3 and I can't do that till v1.0 is uninstalled.

My System SpecsSystem Spec
14 Aug 2009   #2

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64

Is it not in Add/Remove Programs?
My System SpecsSystem Spec
14 Aug 2009   #3

Windows 7 Ultimate x64

According to the Powershell Blog website what is installed on Win7 RTM is v2 CTP3.
Windows PowerShell Blog
My System SpecsSystem Spec

08 Feb 2010   #4


My version of Win7 has powershell v1, not v2. There is no uninstall routine and nothing documented as far as I can tell.

I searched Windows PowerShell Blog and found many others looking for a way to uninstall powershell, but no answers.

There's nothing inPrograms/Features... it's not in Installed Updates... and there's no Feature that can be disabled. I've heard hacking the registry can be done in some cases, but apparently this is dangerous--I read one story where someone had to reinstall after trying this.

Still looking for a way to get powershell 1 off Win7...
My System SpecsSystem Spec
25 Feb 2010   #5

Windows 7 Enterprise
Still looking for solution to installing PS v2 on Win7

I also have the same problem. Cannot install Powershell v2 on Win7x64, but cannot find how to "uninstall previous version".

Has anyone made any progress on this?
My System SpecsSystem Spec
25 Feb 2010   #6

Windows 10 Pro (x64)

Why do you think you have a version less then 2? The directory it is in? Unimportant.
While in powershell type "get-host" to get version information.
My System SpecsSystem Spec
26 Feb 2010   #7


Thanks, logicearth.

PS C:\Windows\System32\WindowsPowerShell\v1.0> get-host

Name             : ConsoleHost
Version          : 2.0
InstanceId       : cee3ea88-5df9-42a0-b0d2-b32b6fd0f7fb
UI               : System.Management.Automation.Internal.Host.InternalHostUserI
CurrentCulture   : en-US
CurrentUICulture : en-US
PrivateData      : Microsoft.PowerShell.ConsoleHost+ConsoleColorProxy
IsRunspacePushed : False
Runspace         : System.Management.Automation.Runspaces.LocalRunspace
Still, as Microsoft software, it's not too much to ask for it to install/uninstall from Control Panel\Programs and Features. Perhaps next year...
My System SpecsSystem Spec
26 Feb 2010   #8

Windows 10 Pro (x64)

You have version 2 making your problem not a problem.
My System SpecsSystem Spec
26 Feb 2010   #9


Well, the problem turned out to be confusion due to misleading install directory and no entry in Programs/Features.

I tried renaming the install directory. Didn't work. Powershell could not load a slew of libraries, even after I changed registry entry.

The easiest thing to do is change shortcut properties "Start in:" entry to:

instead of:

My System SpecsSystem Spec
27 Feb 2010   #10

Windows 7 Enterprise

Well I will be darned. I guess I do have version 2.0 already.
Confusion was created when I tried to install Powershell V2 CTP3, without realizing that it was already in Windows 7, and Powershell does not show itself in either the "Installed Programs" or Windows Components.
Also, I did not see it in All Programs untill I found it under "Accessories".
Thanks everyone.
My System SpecsSystem Spec

 Uninstall Powershell 1.0

Thread Tools

Similar help and support threads
Thread Forum
I was running a script on my 32bit OS that opened up IE and logged me onto my company's vpn. I am now using 64bit OS and My company's vpn does not like 64bit IE. (firefox and chrome are also iffy with our vpn, IE is the only 'official one they support'). When the script runs now on my 64bit os....
General Discussion
PowerShell 3.0 for Win 7 now available
Download: WMF 3.0 - Microsoft Download Center - Download Details You will notice in the requirements that Service Pack 1 must be installed. You will be downloading: Windows Management Framework 3.0 which includes: PowerShell 3.0, WMI & WinRM
Powershell get-acl help
Hi, I was thinking of making a script for powershell, but it was harder than i thought. I'am a beginner of the beginners when it comes to powershell, so i was wondering if any of you could help me (or maybe make me one) with making one. This is what i was thinking of(not sure if this is even...
powershell 1 or 2?
i thought windows 7 pro comes with powershell 2 installed.... when i look in sys32 folder it shows powershell 1... also when powershell is activated it is version 1.... is this correct or what is going on... system is fully updated... win 7 pro 64 bit thanks :(
General Discussion
do you use powershell?
do you use and/or have any cmdlets ?? such as: Get-counter Get-counter -Counter "\Processor(_Total)\% Processor Time" -SampleInterval 2 -MaxSamples 10
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App