Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to register the library

06 Feb 2012   #1
Manu MJ

Microsoft Windows 7 Professional 64-bit
Unable to register the library


I have developed a S/W which works fine in windows XP environment but not in win 07.

I am getting below error.

Unable to register the library c:\windows\system32\stdole2.lib

Error accessing the OLE register.

I tried to register the library in many ways

1) Downloaded VBRegTLB6.exe to register the library.

2)Downloaded process monitor to find the Error's in the process
3) Downloaded subinacl.msi to solve problems during setup
4) Run with "Run with Administration"
5) Tried to run in comparability mode

Please tell me if there any other way.

How to handle this exception?



Manu M

My System SpecsSystem Spec
06 Feb 2012   #2

Windows 7 Home Premium 64Bit

Did you try to run your program in compatibility mode under Windows 7? Try that and see if it works. I think it'll work.
My System SpecsSystem Spec
06 Feb 2012   #3
Manu MJ

Microsoft Windows 7 Professional 64-bit

yes. But still not working.
My System SpecsSystem Spec


 Unable to register the library

Thread Tools

Similar help and support threads
Thread Forum
Unable to create the file "New
Try to create new library. Get "Unable to create the file "New" Access is denied. Found: "Unable to create the file 'New Library.library-ms' File System error (16389) The error 16389 (0x4005) is a trucation of a E_FAIL error (0x80004005)." New library commands raise...
General Discussion
Unable to add a Library shortcut
Hi! I once removed my Documents shortcut from Libraries shortcuts in Windows Explorer but now, I want it back. I can't really explain it good, so see this picture: So, is there a way, to get shortcut to Documents back there...
General Discussion
Unable to save to the library folders
Hi, I just joined the forum. I have a query regarding being unable to save into the folders in my libraries. I'm not sure where I should post it. Can someone point me to the right forum please? Thank you :)
General Discussion
unable to access/create Library
We recently installed Yahoo messenger and suddenly the Library folder isn't showing any folders/files under the Administrator account. When I go to create a new Library it reads the following error message: "Unable to create the new file 'New Library.library-ms' File System Error: (16389)." Not...
General Discussion
Unable to register product
I bought windows 7 upgrade, 32 bit, and loaded it onto my home pc and laptop, the home computer is working great but the laptop has a black screen and insists that it is operating with an illegal copy and keeps asking to register the product key, which in turn is rejected by Microsoft - Can anyone...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App