Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Odd behaviour: Certain software not loading on first try.

15 Feb 2012   #1

Windows 7 Professional 32-bit
Odd behaviour: Certain software not loading on first try.

Morning all!

I have been having some issues with certain pieces of software on Windows 7...

Namely, in the first attempt to open software files, I receive (after a certain amount of time) the error "There was a problem sending the command to the program."

The software opens, but the file does not with Corel. Inside Task Manager with Diamond, which doesn't open at all on the first try, I notice the .exe file has appeared in the Processes tab utilizing a small amount of memory.

The second attempt to open the software file of interest works (whether I delete the Task Manager process or not). Anyone have any idea what is causing this behaviour?
I'll put some extra info below!

Thanks, Bryan

-Happens with CorelDraw x5, CrystalImpact Diamond 3, (at least). Both have had previous versions on the computer, but Corel does NOT have two icons that appear the same under "Open With..." though Diamond does.
-With Diamond at least, it also seems to mess up the right click function: pressing any command button in the software leaves a ghost image of that button on Windows until I right click somewhere else).
-The error does occur on my two separate computers, both with the same software/OS
My System SpecsSystem Spec
15 Feb 2012   #2

Windows 7 x64 Ultimate

ANy AV software running?

A real time AV scan when you launch the program may slow down the launch of the program to the point that Windows finally gives up trying to DDE the OpenDocument command from the shell and gives you that error.

There could be some issue with getting the program to load off the disk the first time as well, like something wrong with the disk or the formatting maybe? Had any sudden power outages while running Corel recently?
My System SpecsSystem Spec
15 Feb 2012   #3

Windows 7 Professional 32-bit

Hmm.. well AVG is working in the background but not always. I'll keep an eye on that next time I open the programs for the "first" time!

As for the second point, since it's on two separate computers on two separate disks (work and home), I doubt that could be the cause - though I understand what you're getting at!


PS - I will reply after trying with no other programs running at the same time.
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
eaccessviolation error when loading software
I am receiving an error when loading parts of DipTrace as follows - "Exception EAccessViolation in module Schematic.exe" then a lot of numbers and memory address. I have tried everything I can find but no fix. I upgraded to Windows 10 pro but I had the same error as with Windows 7 pro. I am now...
websites not loading, or loading only text
Hello, I have an odd problem. I restarted my desktop computer this morning, and something has gotten completely messed up since. Going to any website just loads a white blank page, or a page with no graphics and all test, and the structure of the website is completely messed up, like it didn't...
Browsers & Mail
Windows not Loading after update, hangs on "Loading operating system."
During a recent windows update my pc froze, (mid-update) and I restarted my machine. Now windows gets stuck at the black" Loading operating system..."screen. After a long wait it will eventually display .........boot from cd/. When I boot from my windows dvd my os is not shown in system recovery....
General Discussion
Software loading problem
Hello all I have just joined the forum. Firstly I am 80 year old and have just learnt to use my laptop and now I need some help. My grandson has bought me a 'Integral USB 2.0 Secure 360 flash drive for me to keep private stuff in it. I have gone to there website to down load the software to be...
Odd MD-5 behaviour
I d/l 7127 MD-5 & CRC are perfect. I make a copy of 'known good' ISO. I rerun hash check and it fails on the copied version. Doesn't matter if the copy goes to the same partition or a different physical hd. (all to local pc network copying) I repeat steps 1-4 and MD-5 & CRC a perfect...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:00.
Twitter Facebook