Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Random App Crashes on new Install of Windows 7 Ultimate 64Bit

15 Aug 2012   #1

Windows 7 Ultimate 64 Bit
Random App Crashes on new Install of Windows 7 Ultimate 64Bit

Problems started happening last night just after I installed the new CS:GO Beta, which I think is unrelated.

Anyway I opened up chrome, but wasn't able to open it up. It just wouldn't load whenever I tried to open it. I uninstalled and reinstalled and was fine. Then it happened when I tried to open up Windows Media Player. Eventually I got a BSOD.

Windows then refused to reboot and I went through with the startup checker on the install DVD and it said it fixed it. But then when rebooting it gets past the windows 7 logo, and then a blank black screen. I can't do anything.

I then decide to reinstall Windows 7 (BIOS or hardware setting remains unchanged since 4 months ago). During installation wizard I get a cannot access C:\Boot error just after setting the windows update wizard, apparently my BCD was corrupted? And when running windows for the first time I get the BCD error again.

So This gets fixed by BOOTREC /REBUILDBCD

So I reinstall once again and this time I get no BCD errors. But whenever I try to open some programs be it IE, Device Manager it just has mouse busy symbol then windows acts as if i never clicked it. Eventually restarting Explorer.exe does this as well.

I figure my Memory might be at fault so I run MEMTEST86+ for around 16 hours getting 8 passes and no errors. So RAM is fine.

Figure I need to update my BIOS, so I do that and I reset my Motherboard settings to default, and reinstall Windows.

However I still keep getting errors with opening random programs. This time I managed to get an error (Haven't installed GPU drivers yet so bad res)

So honestly I'm at a loss now.

The only thing I can think of is my SSD (Primary OS) disk has gone bad, but checking SSDLife it says its fine.

Perhaps its the Marvell SATA3 Controller PCI-e I'm using which is at fault?

My motherboard is only SATA2 so I connected the spinning HDDs to it, while I connected my SSD to the SATA3 controller.

Anything I can do?


System Manufacturer/Model Number Custom
OS Windows 7 Ultimate 64 Bit
CPU AMD Phenon X2 550
Motherboard ASUS Crosshair iii
Memory 8GB 1600
Graphics Card(s) ATI 5770
Sound Card Motherboard
Monitor(s) Displays LG Monitor
Hard Drives Marvell SATA3 Controller PCI-e:

Motherboard SATA2:

My System SpecsSystem Spec
15 Aug 2012   #2
Layback Bear

Windows 7 Pro. 64/SP-1

I would not use Marvell unless you have to. It's nothing but a bag of worms. At least on my Intel system. In my case it is no faster than 2.0 Intel SATA.
My System SpecsSystem Spec
15 Aug 2012   #3

Windows 7 Ultimate 64 Bit

Looks like it might be the Marvell controller. I did an actual speed test and it shows it at 250MB/s max. I was def able to get higher speeds when I first used the controller. So maybe its been effected?

I'll try to remove the controller and see if that helps.
My System SpecsSystem Spec

15 Aug 2012   #4
Layback Bear

Windows 7 Pro. 64/SP-1

You don't have to remove any thing. Just unplug your SSD from SATA 3 port and plug into the SATA 2 port. Make sure the boot order is correct in bios. Your SATA ports should be marked and color coded. Check your motherboard manual.
My System SpecsSystem Spec
15 Aug 2012   #5

Windows 7 Ultimate 64 Bit

Ok just did a reinstall of everything without the controller. Yep it def was the Marvell Controller. What a pain.

I really don't understand how my Read speed went from 500ish speeds down to 300MB/S with the controller. Are Marvell controllers known to drop speed like that?
My System SpecsSystem Spec
16 Aug 2012   #6
Layback Bear

Windows 7 Pro. 64/SP-1

Marvell is a great idea that doesn't work. They are known to do all kinds of goofy things including many BSOD from my end. It is good things are working for you.
My System SpecsSystem Spec

 Random App Crashes on new Install of Windows 7 Ultimate 64Bit

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Ultimate 64bit : BSOD at random moments.
Here's my spec: Windows 7 Ultimate 64bit (original version from this system) Yes, this is an original OEM version from (I did reformated it + updates once i got the PC) My system is brand new for the upcoming 2011-2012 games. I re-installed my OS 2 days ago (July 30th) I...
BSOD Help and Support
Random Freezes in Windows 7 ultimate 64bit
Hallo all, Immeditly after installing windows 7 on a new computer i get random freezes, there is no BSOD or any error: the screen freezes and starts to flicker, the led of the mouse turns off and the sound jams. I believe i have updated all drivers. I have run the Windows 7 Memory tester and...
BSOD Help and Support
random BSOD brand new g73jw win 7 ultimate 64bit fresh install
i have only had the asus g73jw for 3 days now. i have gotten 2 BSOD since yesterday. first when i tried to rotate display (as soon as i clicked apply) then today when i was just browsing. im kind of worried now. attached are the dump file and xml file with the logs. below is what windows says...
BSOD Help and Support
Windows 7 (64bit) random system crashes
Hi guys, new to the forum - appears to be a very helpful place! Hopefully someone could help me find out what's causing my random system crashes. Every so often, my system will freeze totally, can't move the mouse, ctrl+alt+del or anything, totally freezes up on me. I have to use the reset...
BSOD Help and Support
Windows 7 64bit random crashes
Normally I don't get a BSOD it just freezes and I have to hold the power button in. This is a brand new system with a fresh install so I'm at a loss as to what could be wrong with it. Pentium i5 Radeon 4870 Gigabyte GA P55 UD3R motherboard 4 gigs of ddr3 ram Please help, it's driving me...
BSOD Help and Support
WINDOWS 7 64bit ultimate RTM 7600 RANDOM LOCK UPS:( when it locks up i cant even do a ctrl alt del i have to hold power button down for 10 sec to shutdown errrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr i wanna buy it when it comes out but this is not looking good maybe ill have to get a evga...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App