Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error: This program requires flash.ocx, which is no longer included...

18 Oct 2012   #1

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
Error: This program requires flash.ocx, which is no longer included...


I have Windows 7 (32-bit).

I recently uninstalled and re-installed two programs of mine which use Flash (IWisoft SWF to Video Converter and Moyea SWF to Video Converter Pro). I've used these programs in the past with no problems.

When I now try and open them I get the following error message:

"This program requires flash.ocx, which is no longer included in this version of Windows".

A popular solution is to change an .ocx file in WINDOWS/SYSTEM32/MACROMEDIA/FLASH to "flash.ocx". This doesn't work for me.

I use Firefox and have the latest version of Flash installed. I've also uninstalled and re-installed Flash, but to no avail.

Any help is appreciated!

My System SpecsSystem Spec
18 Oct 2012   #2

win 7 X64 Ultimate SP1

Here is a good read on your error message.

Download Flash.ocx download and how to fix the 'Cannot find the file flash.ocx' error Windows Tips - Software Patch.

One solution is a reinstall. Which you have already tried. Bit prior to the install after uninstalling you should get the uninstall file from the flash site.
My System SpecsSystem Spec
19 Oct 2012   #3

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1

Thanks for the advice, but I still haven't found any solutions to my problem. I continue to get the error, I really don't know what to do anymore...
My System SpecsSystem Spec

20 Oct 2012   #4

Windows 7 Ultimate x64

try installing the latest version of Flash for IE, which uses the ActiveX version of Flash (the missing OCX file) instead of what all other real browsers use.
My System SpecsSystem Spec
21 Oct 2012   #5
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

After changing the file name, did you also register the file?

Start> In search box type run> Enter> in run box type regsvr32 flash.ocx> Enter

You should get a success message.

If no help you might try to Download the Windows Flash Player 11.4 ActiveX control content debugger (for IE)

Adobe Flash Player - Downloads

Download the Download the Windows Flash Player 11.4 Plugin content debugger (for Netscape-compatible browsers) for other browsers.

A Guy
My System SpecsSystem Spec
21 Oct 2012   #6

Win7 Ultimate x64 7601

How odd,
I had a post here that has mysteriously vanished.
My System SpecsSystem Spec

 Error: This program requires flash.ocx, which is no longer included...

Thread Tools

Similar help and support threads
Thread Forum
Program installed in Program Files requires elevation?
I have a program that wanted to install in a document folder :mad: I have installed it in Program Files, but it requires elevation or it produces errors when running. I know I can tick the Run As ... box in the shortcut, but is there a better way, such as taking ownership of the install folder?
System Security
Error Msg:-Program requires that Microsoft Windows Script be installed
Hi, I've got a CAD program called 3D Canvas 7 - I've used it in the past but recently when I try to run the program it refuses to start and I get the error message:- 3D Canvas requires that Microsoft Windows Script be installed As far as I can see Windows Script is installed as part of...
General Discussion
My Volume icon no longer shows on my taskbar, ( Picture included )
hello i did something by mistake with my mouse and i dunno what happened, my volume icon no longer shows up, i tried to activate it back but i cannot. this picture might explain it. i try to turn it on but i cannot even click it picture in attachment please help me, Thanks
Sound & Audio
Flash no longer works
It seems my Flash no longer works. When I go to a site that uses Flash, there is a blank screen where the Flash player is located. I am using IE8 (32 bit). When I go to download Flash from the Adobe site, I get an error that there was a GUI error. Any ideas what is happening? BTW, I assumed...
Browsers & Mail
Flash no longer works in any browser
I just got this new computer, running 64-bit Windows 7 Home Premium. Everything was working fine at first, but then it automatically updated some things. Now, Flash doesn't work online anymore, in any browser. The content starts to load, then the browser freezes, and I have to force quit it. I...
Browsers & Mail
Program shortcut requires UAC permission?
I have a desktop icon for opening CorelPaint Shop Pro Photo XI that has a yellow security sheild on it (not the case for 10 other program shortcuts). Executing the shortcut brings up an "Unknown Publisher" UAC warning. Not a show stopper but annoying as all get out. I have been playing with the...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App