Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: directx fails to install after win 7 repair install

09 Nov 2012   #1

Win 7 x64 Ultimate
directx fails to install after win 7 repair install


I ran an install over my current win 7 x64 image. I now cannot update directx. I get the following error: An Internal system error occurred.

This all started because I'm getting errors when trying to launch games from steam. One of the first things suggested to try is to reinstall DX.

The only thing I tried so far is changing the version of DX in Regedit just in case if it was a version conflict.

I've attached both logs the error referred to.

any suggestions?

Attached Files
File Type: log DirectX.log (297.6 KB, 18 views)
File Type: log DXError.log (8.2 KB, 12 views)
My System SpecsSystem Spec
09 Nov 2012   #2

Windows 7 Pro X64 SP1

This doesn't explain your problem, but I suggest trying the standalone DirectX installer:

Download DirectX Redist (June 2010) from Official Microsoft Download Center

(96 MB download, unfortunately for those with slow connections). It seems to be a lot more robust than the Web-based install.
My System SpecsSystem Spec
10 Nov 2012   #3

Win 7 x64 Ultimate

I tried that install package but got the above error& logs.
My System SpecsSystem Spec

11 Nov 2012   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 10 Home x64

Make sure your Cryptographic services is set to automatic and started. Also make sure it's dependencies are started and set to automatic

Start> In search box type services.msc> Enter> Scroll down to Cryptographic services and confirm it is Started and set to Automatic

directx fails to install after win 7 repair install-dependencies.jpg

If these services are set correctly, your error log seems to point towards your download being corrupted. Was this the web setup of DirectX. You might try the full installer. It's a larger download (96MB), but does not connect to the internet to download the rest as the web installer does.

DirectX 9.0c Download Full Package - Windows Drivers.

This is a clean, safe download. I just downloaded myself and scanned with Avast, Avira, Malwarebytes, and SAS. I have downloaded from this site before, but made sure before suggesting it to you. A Guy

My System SpecsSystem Spec

 directx fails to install after win 7 repair install

Thread Tools

Similar help and support threads
Thread Forum
System Issues and Repair Install Fails
I noticed that my windows update fails. I have tried several fixes to no avail. Windows update reports I have no installed updates as well. I tried to run sfc /scannow and it fails. I tried to do a repair install and during the process it fails and suggests that I run windows update and of course I...
Installation & Setup
Windows 7 Pro 64 bit repair install fails
After having tried for a long time to fix a number of problems (see Not Running Genuine Windows Error 0x8004fe21 for the details), I've tried to do a repair install. This fails however during the "compatibility check" with the following error message: "The following issues are preventing Windows...
Installation & Setup
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
USB devices won't install - SFC fails to repair
I noticed recently that USB devices won't install on this PC. I keep getting "Windows requires an interactive Window session" when trying to install devices, but when I plug them into another PC running the same exact OS (on different hardware) it installs fine. The most recent device is a...
Hardware & Devices
DirectX install fails... something about a cabinet file.
I've been trying to install Company of Heroes on my new laptop. And it prompts me for a DirectX update. At first I thought it was the game itself crashing, but it's the DirectX update itself that's not getting installed properly on my computer. As I've tried just using the DirectX webupdate. ...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:53.
Twitter Facebook