Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HeapAlloc not working in a 64-bit program

25 Mar 2013   #1

windows 7 Pro 64 bit
HeapAlloc not working in a 64-bit program

Thanks for any help.
Running Windows 7 64-bit pro with all the goodies.
Hp Pavilion

For a 64-bit program written in GoAsm 64-bit.
The value in HeapAlloc is a variable number.
GetProcessHeap executed without an error.
HeapAlloc fails and gives a blue screen with
Microsofts "AppCrash" message in the details.
The other HeapAlloc return values did not appear.
My testmsg3 never gets executed.

PtrMem dq 0
HeapHandle dq 0
testmsg3 db 'after HeapAlloc',0


;other code

invoke GetProcessHeap
mov [HeapHandle],rax
invoke HeapAlloc [HeapHandle],HEAP_GENERATE_EXCEPTIONS,120000
mov [PtrMem],rax

;test code begin
invoke MessageBox, [hWnd], addr testmsg3, addr testmsg3, MB_OK ;true
; test code end

;other code

My System SpecsSystem Spec
26 Mar 2013   #2

windows 7 Pro 64 bit

I might have found the culprit.
When the blue screen appears and a window to cancel the program appears, under details,
lots of stuff is listed. Under Fault Module Name is "ntdll.dll"
I am running windows 7 pro 64-bit with all the updates.

Since I have no control over this module I am at a loss as to how to proceed.
Sure could use some guidance.
My System SpecsSystem Spec

 HeapAlloc not working in a 64-bit program

Thread Tools

Similar help and support threads
Thread Forum
Program no more working
Hello Hopefully am posting in the right section. I downloaded "Stellar Phoenix Windows Data Recovery" which has a trial period and after installation the program ran smoothly but when I tried 2 open it again it did nothing but freezing the whole computer forcing me to restart, which only happens...
Control + W not working in any program.
My control and w keys work perfectly fine seperately, but together it doesn't work. I know it has the default function similar to alt+f4 but it's also a commonly used combination in games. When I have W pressed, and press control, it works, for example to crouch while already moving in counter...
Hardware & Devices
How to check if a program is working?
Here's the situation. I'm using an account with admin rights (not the built in admin account) and I've heard that it's not a good idea to run browsers and the like using an admin account. Anyway I'm trying SrtipMyRights: StripMyRights - Based on DropMyRights Instructions state to run a...
General Discussion
Every Program Stopped working
So, this problem really distrub me, when i wanted to play games there's "X has stopped working", it occured when in the middle of the game or when the game launch. It was also occured with my Chrome, Modem, and even my anti virus. I've tried to config the DEP but, it's still not working. And for...
BSOD Help and Support
virtual CD program not working
I've just setup/installed Windows 7 32-Bit and looks like everything is OK but I installed a virtual CD program/s (i.e. Daemon Tools, PowerISO and or MagicISO) my system is not detecting the virtual CD's that Daemon Tools, PowerISO and or MagicISO have created. can you suggest any procedures for...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:19.
Twitter Facebook Google+