Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: error loading python DLL

10 Apr 2013   #1

windows 7 Professional x64
error loading python DLL

wasn't sure where to post... please move it if this is not the right place

At the start of windows an error window appear saying:
"Error loading Python DLL: c:\use\admin\appdata\local\temp\_mei42443\python27.dll
(error code 5)"
Also when ever i want to install something a similar error appera and the installation is shut down.

I found people asking about similar problems but their solutions never worked for my case.
Thanks for helping

My System SpecsSystem Spec
10 Apr 2013   #2
Sub Styler

Windows 7 Ultimate x64

Loading Python DLL from a temp folder is not normal. I would type MSCONFIG into the start menu and disable anything that looks suspicious. Then restart and use a Malwate scanner e.g. Malware Bytes Anti Malware (Free)
My System SpecsSystem Spec
10 Apr 2013   #3

windows 7 Professional x64

not sure what you mean by suspicious... anyway i can't install a a Malwate scanner an error message appear: "Can't run file in a temporary folder. Installation cancelled. Error: 5" (this is my translation from italian)
My System SpecsSystem Spec

10 Apr 2013   #4
Sub Styler

Windows 7 Ultimate x64

Try starting in Safe Mode (press F8 at startup before/as the windows logo would appear) and installing it from there.
My System SpecsSystem Spec
14 Apr 2013   #5
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Welcome to Seven Forums leonardo28. You might see if Malwarebytes Chameleon will work

Malwarebytes : Chameleon

Also ADWCleaner

AdwCleaner Download

See Jacee's instructions here

Help! Mocaflix virus

I'd also try a clean start to see if there is a conflict.

Troubleshoot Application Conflicts by Performing a Clean Startup

A Guy
My System SpecsSystem Spec
14 Apr 2013   #6

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1

Another method is get into safe mode and use regedit (Start button, run box: regedit) and search (F3) on python27.dll and clear it when it is when found, keep hitting F3 until no more are found, then reboot.

You can do a backup of the registry beforehand also, inside regedit, do FILE | Export then click the box for ALL at the bottom, then save it as a .reg where u please, just remember location.
My System SpecsSystem Spec
24 Aug 2013   #7

Win 8 Enteprise 64 bit - Win 7 Ultimate 64 bit

Ehm, I know it's a old discussion, however I found a solution by myself. It works on Win8 but I think it's the same.
It's a problem with user permissions over the folder "C:\users\xxx\appdata\local\temp", since you don't have enough permission to access the folder when computer starts and try to load googledrive. So what I've done was to take ownership of the folder and then to add my user into "security" properties", making it having full control. Then it worked.
If you don't know what I am saying write here and I'll explain you step-by-step.
Sorry for my poor English.
My System SpecsSystem Spec
08 Mar 2014   #8

Windows 7 x64
I love you bro !

I had problem with my computer, with a major kernel32.dll error and lots of error related to dll's and temp folder.
I gave my account full control to the temp folder in the appdata folder and everything is back to normal.
Hope this solution will help some other people !!
My System SpecsSystem Spec
07 Jul 2014   #9

W7 Pro x64
try easy way...

Just close all apps. Open \AppData\Local\Temp folder, select all files and folders inside a delete it. Then restart.
My System SpecsSystem Spec

 error loading python DLL

Thread Tools

Similar help and support threads
Thread Forum
Different python is executed in cmd and win+R
Hi, I have two versions of python installed: c:\Python26_x64 c:\Python27_x64 The c:\Python27_x64 is in %path% and there's nothing in the 'set' command that mentions 26. When I run python from cmd.exe the 27 version is executed as expected. On the other hand, when I run python from win+R...
General Discussion
BSOD Using Python 2.7, error 0x000000f4
Hello sevenforums, I have been having a BSOD problem on my Asus laptop running Windows 7, processor is core-i5. The BSOD occurs somewhat randomly when attempting to run python scripts using VIDLE for Python 2.7. The problem usually occurs after around 2 - 10 times of running a script, and it...
BSOD Help and Support
Python sytax error problem
Hi, i have a problem with this python file. Its f-secure's ASCII World map. I dont know how to fix it. The part that has error is this: formats = Attached file below.
Python and Blender
I'm having a problem installing python and blender. I install python for windows through the MSI file provided by (2.6.1 and 3.0). I then install Blender (2.48). When i fire up blender it gives me this mesege. Checking for installed Python... No installed Python Found. Only...
Monty Python
Who likes "Monty Python" Nudge nudge wink wink, say no more....... ;) Oh I just remembered, I'm English. Didn't tell anyone that.........I didn't just remember I'm English, but you know what I
Chillout Room

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:15.
Twitter Facebook Google+