Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Shortcut failed "Windows alert", after PC boot

20 Apr 2013   #1

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)
Shortcut failed "Windows alert", after PC boot

Cold booted PC after overnight shutdown.
My one and only custom Windows shortcut (Ctrl+Alt+C) on Start menu, opened.
While I moved the mouse (no clicking), the window closed and windows alert appeared.
Shortcut failed "Windows alert", after PC boot-clipx-shortcut-broken-alert.png
Rebooted -- now the shortcut has failed.
App is ClipX (clipboard tool). Normally ClipX assigns each clip entry to a list. But the list is empty.
ClipX settings are unchanged

I have done a Bitdefender "Quick Scan" all is OK. (I have not done a malware check, yet!)

Q1: How could the Win shortcut work once (it shows the ClipX configuration window) and then fail as outlined above?

Q2: Any ideas ?

Its 7:30am here I have a big day ahead of me here, I need ClipX.
While typing this thread a very quick flash on the screen (a tiny dialog) disappeared as quickly as it appeared.

Computer Type:= Laptop
Manufacturer:= Toshiba Satellite C665
OS:= Windows 7 Home Premium, sp1 (Build 7601)
CPU:= Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Motherboard:= TOSHIBA Portable PC
Memory:= 2,806 MB
Graphics:= NVIDIA GeForce 315M *
Sound Card:= Speakers (Conexant SmartAudio H |
Monitors:= x1, Generic PnP
Screen Resolution:= 1366 X 768 - 32 bit
Hard Drives:= C: 585.4GB
Case:= Toshiba Satellite
Cooling:= default fan
Keyboard:= default + Logitech K260
Mouse:= default pad + Logitech M210
Internet Speed:= ADSL2
Antivirus:= Bitdefender Internet Security 2013
Browser:= IE-9.10, PaleMoon, Firefox 20.0
Others:= USB Safely Remove, Metapad, ClipX,
7Zip, Classic Shell Start, Explorer++, FileSearchEX, KeyboardLEDS, CapsLock,
MalwareBytes, MyDefrag, PostBox, ClipX

My System SpecsSystem Spec
20 Apr 2013   #2

64-bit Windows 10 Pro

Hello Russell,

Is the ClipX.exe file still where it was installed at?

If so, you could either create a new shortcut from the .exe file, or change the broken shortcut's "Target" to be the full path of where the .exe file is as.

Hope this helps for now, :)
My System SpecsSystem Spec
21 Apr 2013   #3

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)
Missing EXE file

Hi "Brink" thank you for your help,
The short answer is -- ClipX.exe was missing -- BUT ...

I dont understand how the EXE file was missing when all other support files and folders were intact,
including the clipx.ini, uninstall.exe, Plugins folder (and its "stickies.wac" file), and my custom VBS file that upgrades three keys in the clipx.ini file.
This setup has worked without a hitch for the last 6-7 years in WinXP on two PCs.

If "uninstall.exe" had been run the entire "C:\Programs2\ClipX" folder would be removed.
So I am at a loss how only the clipx.exe file was deleted.

One quirk was the Start-menu > ClipX.exe (shortcut) -- alert "cannot find clipx.exe ... etc", after the cold boot ?? How can a shortcut be working one day and fall over the next day after first cold boot
Another clue, maybe -- I deleted the corrupt shortcut (but only the shortcut)

Ultimate solution was to clean re-install ClipX

I used Starter v5.6.2.9 by "CodeStuff" to insert shortcut in startup to start ClipX.

Q: Is it worth pursuing how the exe file disappeared or should I just get a life ?
My System SpecsSystem Spec

21 Apr 2013   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

It's possible one of your security programs has quarantined, or removed the ClipX.exe thinking it was malicious. It's very nature makes it do things that a behavior detection software may consider malicious. A Guy
My System SpecsSystem Spec
21 Apr 2013   #5

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)
Good idea

@ A Guy

Quarantine is empty
But to be on the safe side I have added ClipX folder as an exclusion because 3 files are active.
clipx.exe, clipx.ini and the VBS file that modifies the INI file then runs the exe file.

Thank you for your input :)

Bitdefender Internet Security 2013
My System SpecsSystem Spec
21 Apr 2013   #6

64-bit Windows 10 Pro

Glad to hear you got it sorted GrayGhost. :)

It was most likely removed by your AV or some other means by mistake.
My System SpecsSystem Spec
21 Apr 2013   #7

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)
AV had deleted the EXE file

Finally found the cause of "ClipX" app failure -- 24 hours after the exe file disappeared.

My AV "Bitdefender Internet Security 2013" (BIS) -- is updated manually every morning.
Today after a cold boot (and during the morning ritual of updating) an "issue" icon was displayed over BIS "Anti Virus" icon and "Events" icon -- on Bitdefender home page
Following the long trail of issue-icons I found the BIS log entry buried in the bowels of Bitdefender.
ie, Bitdefender (home window) > Events (icon) > Events Overview (window) > Antivirus (icon) > Antivirus Events (window) > Active Virus Control (tab) ... and one listed item Potentially malicious application detected.
Selected the loan "malicious item" and all was revealed -- by the time stamp the "capture" was made when the PC was cold booted for the day.
(At no time yesterday did Bitdefender show a message/alert warning me of "a problem".)

Illogically, from Bitdefender home-page > Antivirus (icon) ... nothing is revealed.
Quarantine list was (and still is) empty
I wonder how many other newbies get caught this way. The clue is in "Events" not "Antvirus" icon on the home page.
In fairness to Bitdefender it has saved my bacon about 4 times in the last 4 months, but its over zealous deletion of an unsigned EXE file is irritating. And why now, BIS has been on guard for the last 10 weeks, and ClipX has always been in startup.

Between Win7 security and more complex AV apps life is getting more complicated.
I think I will go and live on a deserted tropical island -- but will I get good cell-phone reception ?
My System SpecsSystem Spec
21 Apr 2013   #8
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Yeah, you'd hope it would warn you, and let you decide if it's malicious or not. I figured that was the case. Things that try to access windows in such a way they appear dangerous trigger these behavior guards. A Guy
My System SpecsSystem Spec
21 Apr 2013   #9

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)
Over zealous AV

Hi "A Guy", thanks for your interest and help. :)

I have posted a new Thread with Bitdefender but their track record for a timely response leaves a lot to be desired.

I cannot find any setting in Bitdefender to give "me" an option of actions.
Other AVs I have used over the years offered options but they were not reliable guardians.
I want protection, not pretty pictures nor boys-toy-complexity, but everything seems to be going the way of dumbing down.
My System SpecsSystem Spec

 Shortcut failed "Windows alert", after PC boot

Thread Tools

Similar help and support threads
Thread Forum
Intermittent BSOD, "Windows Failed to Start" upon boot
Hi guys, For the last few weeks, I've been getting the "Windows Failed to Start" error screen intermittently when I try to boot my computer. This does not always happen, but several times on occasion. I then proceed to run Startup Repair (with a system restore), and then I am able to launch...
BSOD Help and Support
Todays updates failed - Now stuck in a "boot loop?"
This morning my computer did windows update. After the reboot it got to the welcome screen and the monitor went black. Upon reboot I had one long 3 short beeps. I restart again and am stuck in a boot up loop of "failure configuring windows updates - Reverting changes - Do not turn off your ...
Windows Updates & Activation
Error 0xc000000e "Boot Selection failed- Required device Inaccessible"
Hello, Last night i was trying to update my AMD SATA AHCI Controller driver, but i shouldn't do while being sleepy....:( My hand moved before my brain realised...I uninstalled the device BUT i also checked the option for deleting the drivers. Now, i get the error while booting : What i...
"Windows failed to start", won't allow me to boot from CD/DVD drive
Hey guys, Recently my iTunes went haywire and froze my computer, and when I rebooted it, I got the error: Windows failed to start. A recent hardware or software change might be the cause. To fix the problem: 1. Insert your windows installation disc and restart your computer. 2. Choose...
General Discussion
"Boot selection failed because a required device is inaccessible"
Just installed Avira antivirus and rebooted to complete the installation. I am getting the error "Boot selection failed because a required device is inaccessible" whenever I attempt to boot. I have tried using the Windows 7 disc to repair but it does not work as it runs for a few seconds then...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:55.
Twitter Facebook Google+