Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 x64 "COMCTL32.ocx Failed To Register"

21 Apr 2013   #1
Jake1211

Windows 7 Home Premium x64
 
 
Windows 7 x64 "COMCTL32.ocx Failed To Register"

Hi, i have a laptop running Windows 7 Home Premium x64, and i am trying to run a program called "Advanced-Mart" Its for hacking Pokemon games. when i try to open it, it says that "COMCTL32.OCX or one of it dependencies is missing." i tried registering it, but IT WILL NOT WORK ! Its very frustrating because i have tried so many times. Any Ideas?

EDIT- How do i post a picture?


My System SpecsSystem Spec
.
25 Apr 2013   #2
GeorgeAM

Windows 8, XP, 7, Linux
 
 

Step 1: Re-register the component.

Verify if comctl32.ocx is in C:\windows\system32 folder. If you, you may try re-registering the file.

1. Go to start and type cmd.
2. Right-Click on cmd and select “Run as Administrator”.
3. Type regsvr32 comctl32.ocx and press Enter.

If successful you should get a popup saying "DllregisterServer in
comscl32.ocx succeeded"
My System SpecsSystem Spec
08 Aug 2014   #3
Fixocx

Windows 7 Ultimate x64
 
 
http://www.fixocx.com

Got to Fix OCX Errors - http://www.fixocx.com they offer a simple application that will allow you to fix (download & register) any OCX errors you have!

The program is very simple to use! Just download the software, no need to install, enter the name of the ocx file you need, click fix, and you are all done!

Here is also a video tutorial on how the software works:

https://www.youtube.com/watch?v=r9PhBN7l7uE
My System SpecsSystem Spec
.

Reply

 Windows 7 x64 "COMCTL32.ocx Failed To Register"




Thread Tools




Similar help and support threads
Thread Forum
"COMCTL32.DLL Missing" (Not April Fools!)
As title suggests I'm getting the comctl32.dll error. Cause: Google Chrome was slow so I ran Herd Protect. While removing a few things it detected something went wrong. Info: -I see this file in System 32 however I'm still seeing this problem. It states file was modified today. -Several...
General Discussion
Failed updates "WindowsUpdate_8007370B" "WindowsUpdate_dt000"
Hi there, Can someone please help to shed some light on this, or possibly fix this issue? I've been trying for ages to get my parents computer to download and install updates. It's running 7 Home Premium 64 bit with SP1. The Windows Update page shows that Windows could not search for updates,...
Windows Updates & Activation
"comctl32.dll is missing from your computer", even though it's not
Hi, when I try to install any program I get the message: "The program can't start because COMCTL32.dll is missing from your computer. Try reinstalling the the program to fix this problem." The confusing thing is, when I go in to "C:/Windows/System32", the file COMCTL32.dll is right there...
General Discussion
register for a "windows explorer context menu component"!
After running a program downloaded from the internet to verify file associations, I now have this problem :- Each time I right-click on a shortcut on the desktop and then click on "Open", a window opens, asking me to register for a "windows explorer context menu component"! I can't close the...
General Discussion
"Failure to register import hotkey....."
Hello ! So I'm test-driving this program that I like a lot, but every time I fire it up it throws an error message, something to the effect of "Failure to register import hotkey: Hotkey is already registered". The hotkey the app is referencing is 'Windows key + V'. So my...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App