Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "No DLL were found in the Waterfall procedure" Finally SOLVED.

01 Sep 2014   #21

Windows 7 Ultimate 32bit

Have been dealing with this issues for weeks now and this seems to have fixed it, thanks :)

My System SpecsSystem Spec
01 Sep 2014   #22

Windows7 Home Premium 64bit

Thanks for the welcome Layback Bear:)
My System SpecsSystem Spec
01 Sep 2014   #23

Windows 7 Home Premium x64

I know this is kind of an old thread, and I'm not sure if the OP is still around to see this, but...

Wasn't it possible to force uninstall the application in programs like iObit Uninstaller and keep the dlls in question? Because force uninstall bypasses the original setup and you have to delete everything manually, both files and registry keys. That way you can keep the dlls needed while removing everything else...
My System SpecsSystem Spec

30 Oct 2014   #24

Win 7 Professional x64

I have been using this forum informally for a while and finally decided to join after finding this post. Fixed a problem that has been really frustrating me. Perfect fix. Thanks to Contrabardus, lmicklus, and aaroux.
My System SpecsSystem Spec
08 Nov 2014   #25

windows home prem 7 64

Worked for me, added that file and removed the others. thanks !
My System SpecsSystem Spec
13 Dec 2014   #26

Windows 7 Home Premium x64

Thanks very much. Solved the problem.
My System SpecsSystem Spec
16 Dec 2014   #27

Thank you

I put the file where you said and it worked, so thank you very much!
My System SpecsSystem Spec
05 Jan 2015   #28

Win7 Home Premium 64bit
It worked

I have been fighting with this problem since this summer. I imagine that I probably uninstalled something during one of my "spring cleaning" attacks. I had to do the zip file plus the workaround.

The program was having trouble with was the Cyberlink Youcam version

I am so happy right now.

Thank you!!!!
My System SpecsSystem Spec
12 Jan 2015   #29

7, 8

Thank you lmicklus and aaroux. That worked perfectly, the same issue showed on Cyberlink Youcam and the workaround fixed it.
My System SpecsSystem Spec
23 Jan 2015   #30

7 64

Thanks. Also worked for me on Windows 8.1 using Aaroux's addition
My System SpecsSystem Spec

 "No DLL were found in the Waterfall procedure" Finally SOLVED.

Thread Tools

Similar help and support threads
Thread Forum
Samsung SSD - "A disk read error occured Press ctl alt del - SOLVED"
Hello, I encountered a problem and found a solution and just wanted to put it on the internet for posterity. So I have a Samsung SSD 850 EVO. I'm actually running Vista 64 Ultimate but ran across a relevant thread about this seemingly hardware issue here, so.... I started with a fresh...
Performance & Maintenance
When I click "install now", it's saying "No device drivers were found"
Ok, now I get another problem... When I click "install now", I get a msg box that is saying 'no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK' What should I do now?
Installation & Setup
Visual Studio 2008 Pro SP1: Error spawning "rc.exe" finally FIXED!
Hi All, This is my first VS2008 installation and I bumped to this error. Wasting much time googling the net showed bunch of lame solutions like "reboot pc, reinstall windows and etc..." I thought it is W7's incompatibility, however the problem is easily solved by adding additional component...
BSOD after "Remote procedure call failed and did not execute"
-Windows Home Premium x64 -Windows Vista initially installed; Dell provided a windows 7 Installation CD once it came out. Hardware was bought ~December 2009. Installed Windows 7 once in 2010 and once earlier this year. When I tried to make the System Health Report, it came up with "The...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:11.
Twitter Facebook